]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
- fix building kernel module for linux 5.6
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_pcmcia  # PCMCIA support in kernel drivers
6 %bcond_without  drivers_usb     # USB kernel drivers
7 %bcond_without  userspace       # userspace packages
8 %bcond_without  verbose         # verbose modules build (V=1)
9
10 %bcond_without  docs            # documentation build
11 %bcond_with     hotplug         # legacy hotplug support
12 %bcond_without  static_libs     # static library
13 %bcond_without  guile           # guile binding
14 %bcond_without  perl            # Perl binding
15 %bcond_with     php             # PHP binding
16 %bcond_without  python          # Python binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %undefine       with_drivers_pcmcia
31 %endif
32
33 %define         php_name        php%{?php_suffix}
34
35 %define         rel     6
36 %define         pname   linux-gpib
37 Summary:        GPIB (IEEE 488) Linux support
38 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
39 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
40 Version:        4.3.0
41 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
42 License:        GPL v2+
43 Group:          Applications/System
44 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
45 # Source0-md5:  3085422695baf210b866601db6108860
46 Patch2:         %{pname}-python.patch
47 Patch3:         %{pname}-perl.patch
48 Patch4:         %{pname}-firmwaredir.patch
49 Patch5:         %{pname}-guile2.patch
50 Patch6:         %{pname}-php7.patch
51 Patch8:         kernel-5.2.patch
52 Patch9:         kernel-5.6.patch
53 URL:            http://linux-gpib.sourceforge.net/
54 BuildRequires:  autoconf >= 2.50
55 BuildRequires:  automake
56 BuildRequires:  libtool
57 BuildRequires:  rpmbuild(macros) >= 1.614
58 %if %{with kernel}
59 BuildRequires:  kernel-module-build >= 3:2.6.8
60 %endif
61 %if %{with userspace}
62 BuildRequires:  bison
63 %{?with_docs:BuildRequires:     docbook-utils}
64 BuildRequires:  flex
65 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
66 %{?with_perl:BuildRequires:     perl-devel}
67 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
68 %{?with_python:BuildRequires:   python-devel >= 2}
69 BuildRequires:  readline-devel
70 %{?with_tcl:BuildRequires:      tcl-devel}
71 %endif
72 Requires:       %{pname}-libs = %{version}-%{release}
73 # for agilent_82357a and ni_usb_gpib
74 Suggests:       fxload
75 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
76 Suggests:       linux-gpib-firmware
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
81
82 %description -l pl.UTF-8
83 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
84
85 %package hotplug
86 Summary:        Linux GPIB support for legacy USB hotplug
87 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
88 Group:          Applications/System
89 Requires:       %{pname} = %{version}-%{release}
90 Requires:       hotplug
91
92 %description hotplug
93 Linux GPIB support for legacy USB hotplug.
94
95 %description hotplug -l pl.UTF-8
96 Obsługa Linux GPIB dla starego systemu hotplug USB.
97
98 %package libs
99 Summary:        Shared GPIB library
100 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
101 Group:          Libraries
102
103 %description libs
104 Shared GPIB library.
105
106 %description libs -l pl.UTF-8
107 Biblioteka współdzielona GPIB.
108
109 %package devel
110 Summary:        Header file for GPIB library
111 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
112 Group:          Development/Libraries
113 Requires:       %{pname}-libs = %{version}-%{release}
114
115 %description devel
116 Header file for GPIB library.
117
118 %description devel -l pl.UTF-8
119 Plik nagłówkowy biblioteki GPIB.
120
121 %package static
122 Summary:        Static GPIB library
123 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
124 Group:          Development/Libraries
125 Requires:       %{pname}-devel = %{version}-%{release}
126
127 %description static
128 Static GPIB library.
129
130 %description static -l pl.UTF-8
131 Biblioteka statyczna GPIB.
132
133 %package -n guile-gpib
134 Summary:        Guile bindings for GPIB library
135 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
136 Group:          Development/Languages/Perl
137 Requires:       %{pname}-libs = %{version}-%{release}
138 Requires:       guile-libs
139
140 %description -n guile-gpib
141 Guile bindings for GPIB library.
142
143 %description -n guile-gpib -l pl.UTF-8
144 Wiązania Guile do biblioteki GPIB.
145
146 %package -n perl-gpib
147 Summary:        Perl bindings for GPIB library
148 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
149 Group:          Development/Languages/Perl
150 Requires:       %{pname}-libs = %{version}-%{release}
151
152 %description -n perl-gpib
153 Perl bindings for GPIB library.
154
155 %description -n perl-gpib -l pl.UTF-8
156 Wiązania Perla do biblioteki GPIB.
157
158 %package -n %{php_name}-gpib
159 Summary:        PHP bindings for GPIB library
160 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
161 Group:          Development/Languages/PHP
162 Provides:       php(gpib) = %{version}
163 Requires:       %{pname}-libs = %{version}-%{release}
164 %{?requires_php_extension}
165
166 %description -n %{php_name}-gpib
167 PHP bindings for GPIB library.
168
169 %description -n %{php_name}-gpib -l pl.UTF-8
170 Wiązania PHP do biblioteki GPIB.
171
172 %package -n python-gpib
173 Summary:        Python bindings for GPIB library
174 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GPIB
175 Group:          Libraries/Python
176 Requires:       %{pname}-libs = %{version}-%{release}
177 Requires:       python-libs
178
179 %description -n python-gpib
180 Python bindings for GPIB library.
181
182 %description -n python-gpib -l pl.UTF-8
183 Wiązania Pythona do biblioteki GPIB.
184
185 %package -n tcl-gpib
186 Summary:        Tcl bindings for GPIB library
187 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
188 Group:          Libraries
189 Requires:       %{pname}-libs = %{version}-%{release}
190 Requires:       tcl
191
192 %description -n tcl-gpib
193 Tcl bindings for GPIB library.
194
195 %description -n tcl-gpib -l pl.UTF-8
196 Wiązania Tcl-a do biblioteki GPIB.
197
198 %package doc
199 Summary:        Linux-GPIB tools and library documentation
200 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
201 License:        GFDL v1.2+ or GPL v2+
202 Group:          Documentation
203
204 %description doc
205 Linux-GPIB tools and library documentation.
206
207 %description doc -l pl.UTF-8
208 Dokumentacja narzędzi i biblioteki Linux-GPIB.
209
210 %define kernel_pkg()\
211 %package -n kernel%{_alt_kernel}-gpib\
212 Summary:        Linux GPIB drivers\
213 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
214 Release:        %{rel}@%{_kernel_ver_str}\
215 Group:          Base/Kernel\
216 Requires(post,postun):  /sbin/depmod\
217 %requires_releq_kernel\
218 Requires(postun):       %releq_kernel\
219 \
220 %description -n kernel%{_alt_kernel}-gpib\
221 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
222 \
223 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
224 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
225 \
226 %if %{with kernel}\
227 %files -n kernel%{_alt_kernel}-gpib\
228 %defattr(644,root,root,755)\
229 /lib/modules/%{_kernel_ver}/kernel/gpib\
230 %endif\
231 \
232 %post -n kernel%{_alt_kernel}-gpib\
233 %depmod %{_kernel_ver}\
234 \
235 %postun -n kernel%{_alt_kernel}-gpib\
236 %depmod %{_kernel_ver}\
237 %{nil}
238
239 %define build_kernel_pkg()\
240 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
241 cd drivers/gpib\
242 %ifarch %{ix86}\
243 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
244 %else\
245 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
246 %endif\
247 cd ../..\
248 %{nil}
249
250 %define install_kernel_pkg()\
251 %{nil}
252
253 %{?with_kernel:%{expand:%create_kernel_packages}}
254
255 %prep
256 %setup -q -n %{pname}-%{version}
257 %if %{with userspace}
258 tar xzf linux-gpib-user-%{version}.tar.gz
259 cd linux-gpib-user-%{version}
260 %patch2 -p1
261 %patch3 -p1
262 %patch4 -p1
263 %patch5 -p1
264 #%patch6 -p1
265 cd ..
266 %endif
267
268 %if %{with kernel}
269 tar xzf linux-gpib-kernel-%{version}.tar.gz
270 cd linux-gpib-kernel-%{version}
271 %ifarch %{ix86}
272 %patch8 -p1
273 %endif
274 %patch9 -p1
275 %endif
276
277 %build
278 %if %{with userspace}
279 cd linux-gpib-user-%{version}
280 %{__libtoolize}
281 %{__aclocal}
282 %{__autoconf}
283 %{__autoheader}
284 %{__automake}
285 %if %{with guile}
286 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
287 %endif
288 %configure \
289         --with-udev-libdir=/lib/udev \
290         %{?with_drivers_isa:--enable-isa} \
291         %{?with_drivers_pcmcia:--enable-pcmcia} \
292         %{!?with_docs:--disable-documentation} \
293         %{!?with_guile:--disable-guile-binding} \
294         %{!?with_perl:--disable-perl-binding} \
295         %{!?with_php:--disable-php-binding} \
296         %{!?with_python:--disable-python-binding} \
297         %{?with_static_libs:--enable-static} \
298         %{!?with_tcl:--disable-tcl-binding}
299
300 %{__make}
301 cd ..
302 %endif
303
304 %if %{with kernel}
305 cd linux-gpib-kernel-%{version}
306 %{expand:%build_kernel_packages}
307 %endif
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311 install -d $RPM_BUILD_ROOT%{_examplesdir}
312
313 %if %{with kernel}
314 cd linux-gpib-kernel-%{version}
315 %{expand:%install_kernel_packages}
316 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
317 cd ..
318 %endif
319
320 %if %{with userspace}
321 cd linux-gpib-user-%{version}
322 %{__make} install \
323         DESTDIR=$RPM_BUILD_ROOT \
324         HOTPLUG_USB_CONF_DIR=/lib/udev \
325         UDEV_RULES_DIR=/lib/udev/rules.d \
326         USB_FIRMWARE_DIR=/lib/firmware
327
328 %if %{with hotplug}
329 # use udev paths as base and legacy hotplug as addon (not the opposite)
330 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
331 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
332 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
333 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
334 %endif
335
336 # obsoleted by pkg-config
337 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
338
339 %if %{with guile}
340 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
341 %if %{with static_libs}
342 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
343 %endif
344 %endif
345
346 %if %{with perl}
347 %{__make} -C language/perl pure_install \
348         DESTDIR=$RPM_BUILD_ROOT
349
350 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
351
352 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
353 %endif
354
355 %if %{with php}
356 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
357 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
358 ; Enable gpib extension module
359 extension=gpib_php.so
360 EOF
361
362 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
363 %if %{with static_libs}
364 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
365 %endif
366 %endif
367
368 %if %{with python}
369 %py_postclean
370 %endif
371
372 %if %{with tcl}
373 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
374
375 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
376 %if %{with static_libs}
377 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
378 %endif
379 %endif
380
381 %if %{with docs}
382 # packaged as %doc
383 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
384 %endif
385 %endif
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %post   libs -p /sbin/ldconfig
391 %postun libs -p /sbin/ldconfig
392
393 %post   -n guile-gpib -p /sbin/ldconfig
394 %postun -n guile-gpib -p /sbin/ldconfig
395
396 %post   -n tcl-gpib -p /sbin/ldconfig
397 %postun -n tcl-gpib -p /sbin/ldconfig
398
399 %post   -n %{php_name}-gpib
400 %php_webserver_restart
401
402 %postun -n %{php_name}-gpib
403 if [ "$1" = 0 ]; then
404         %php_webserver_restart
405 fi
406
407 %if %{with userspace}
408 %files
409 %defattr(644,root,root,755)
410 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
411 %attr(755,root,root) %{_bindir}/ibterm
412 %attr(755,root,root) %{_bindir}/ibtest
413 %attr(755,root,root) %{_sbindir}/gpib_config
414 /lib/udev/rules.d/98-gpib-generic.rules
415 /lib/udev/rules.d/99-agilent_82357a.rules
416 /lib/udev/rules.d/99-ni_usb_gpib.rules
417 %attr(755,root,root) /lib/udev/gpib_udev_config
418 %attr(755,root,root) /lib/udev/gpib_udev_fxloader
419 %attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
420
421 %if %{with hotplug}
422 %files hotplug
423 %defattr(644,root,root,755)
424 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
425 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
426 /etc/hotplug/usb/agilent_82357a.usermap
427 /etc/hotplug/usb/ni_usb_gpib.usermap
428 %endif
429
430 %files libs
431 %defattr(644,root,root,755)
432 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
433 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
434 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
435
436 %files devel
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/libgpib.so
439 %{_includedir}/gpib
440 %{_pkgconfigdir}/libgpib.pc
441
442 %if %{with static_libs}
443 %files static
444 %defattr(644,root,root,755)
445 %{_libdir}/libgpib.a
446 %endif
447
448 %if %{with guile}
449 %files -n guile-gpib
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
452 %attr(755,root,root) %{_libdir}/libgpib-guile.so
453 %endif
454
455 %if %{with perl}
456 %files -n perl-gpib
457 %defattr(644,root,root,755)
458 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
459 %{perl_vendorarch}/LinuxGpib.pm
460 %dir %{perl_vendorarch}/auto/LinuxGpib
461 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
462 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
463 %{_mandir}/man3/LinuxGpib.3pm*
464 %{_examplesdir}/perl-gpib-%{version}
465 %endif
466
467 %if %{with php}
468 %files -n %{php_name}-gpib
469 %defattr(644,root,root,755)
470 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
471 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
472 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
473 %endif
474
475 %if %{with python}
476 %files -n python-gpib
477 %defattr(644,root,root,755)
478 %doc linux-gpib-user-%{version}/language/python/README
479 %attr(755,root,root) %{py_sitedir}/gpib.so
480 %{py_sitedir}/Gpib.py[co]
481 %{py_sitedir}/gpib-1.0-py*.egg-info
482 %endif
483
484 %if %{with tcl}
485 %files -n tcl-gpib
486 %defattr(644,root,root,755)
487 %doc linux-gpib-user-%{version}/language/tcl/README
488 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
489 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
490 %{_examplesdir}/tcl-gpib-%{version}
491 %endif
492
493 %if %{with docs}
494 %files doc
495 %defattr(644,root,root,755)
496 %doc linux-gpib-user-%{version}/doc/doc_html/*
497 %endif
498 %endif
This page took 0.086573 seconds and 3 git commands to generate.