]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- more POSIX sh syntax fixes
[packages/lilypond.git] / lilypond.spec
1 Summary:        Music typesetter
2 Summary(pl):    Program do sk³adania nut
3 Name:           lilypond
4 Version:        2.4.1
5 Release:        0.2
6 License:        GPL
7 Group:          Applications/Sound
8 Source0:        http://lilypond.org/download/v2.4/%{name}-%{version}.tar.gz
9 # Source0-md5:  5fdb447c9a55c52c670c80f09bddcecf
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-sh.patch
12 Patch2:         %{name}-po.patch
13 Patch3:         %{name}-ps2png.patch
14 URL:            http://www.lilypond.org/
15 BuildRequires:  automake
16 BuildRequires:  bison >= 1.25
17 BuildRequires:  flex >= 2.5.4a
18 BuildRequires:  fontforge
19 BuildRequires:  gettext-devel
20 BuildRequires:  guile-devel >= 1.6
21 BuildRequires:  kpathsea-devel
22 BuildRequires:  libltdl-devel
23 BuildRequires:  libstdc++-devel >= 5:3.1
24 BuildRequires:  mftrace >= 1.0.17
25 BuildRequires:  python-devel >= 2.1
26 BuildRequires:  tetex-dvips
27 BuildRequires:  tetex-fonts-cm
28 BuildRequires:  tetex-fonts-cmextra
29 BuildRequires:  tetex-fonts-jknappen
30 BuildRequires:  tetex-fonts-type1-ec-mftraced
31 BuildRequires:  texinfo >= 4.6
32 BuildConflicts: lilypond < 1.6.0
33 Requires:       ghostscript
34 Requires:       guile >= 1.6
35 Requires:       python >= 2.1
36 Requires:       tetex-fonts-type1-ec-mftraced
37 Requires:       tetex-format-latex >= 1.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _localedir      %{_prefix}/share/locale
41 %define         texfontsdir     /usr/share/texmf/fonts
42
43 %description
44 LilyPond is a music typesetter. It produces beautiful sheet music
45 using a high level description file as input. It excels at typesetting
46 classical music, but you can also print pop-songs. With LilyPond we
47 hope to make music publication software available to anyone on the
48 internet.
49
50 %description -l pl
51 LilyPond jest programem do sk³adu muzycznego. Produkuje piêkne
52 partytury u¿ywaj±c jêzyka wysokiego poziomu jako wej¶cie. S³u¿y przede
53 wszystkim do sk³adania nut muzyki klasycznej, ale mo¿na drukowaæ tak¿e
54 piosenki pop. Autorzy udostêpniaj± LilyPond z nadziej± dostarczenia
55 wszystkim oprogramowania do publikacji muzycznych.
56
57 %package -n emacs-lilypond-mode-pkg
58 Summary:        LilyPond mode for Emacs
59 Summary(pl):    Tryb edycji plików LilyPond dla Emacsa
60 Group:          Applications/Editors/Emacs
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       emacs
63
64 %description -n emacs-lilypond-mode-pkg
65 LilyPond mode for Emacs.
66
67 %description -n emacs-lilypond-mode-pkg -l pl
68 Tryb edycji plików LilyPond dla Emacsa.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76
77 %build
78 cp -f /usr/share/automake/config.* stepmake/bin
79 %configure \
80         %{?debug:--disable-optimising}
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{texfontsdir}/{source,afm,tfm,type1}
86
87 %{__make} install \
88         local_lilypond_datadir=$RPM_BUILD_ROOT%{_datadir}/lilypond/%{version} \
89         datadir=$RPM_BUILD_ROOT%{_datadir} \
90         mandir=$RPM_BUILD_ROOT%{_mandir} \
91         bindir=$RPM_BUILD_ROOT%{_bindir} \
92         localedir=$RPM_BUILD_ROOT%{_localedir} \
93         infodir=$RPM_BUILD_ROOT%{_infodir} \
94         libdir=$RPM_BUILD_ROOT%{_libdir}
95
96 %{__perl} -pi -e "s#$RPM_BUILD_ROOT##" $RPM_BUILD_ROOT%{_bindir}/*
97
98 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/afm \
99       $RPM_BUILD_ROOT%{texfontsdir}/afm/lilypond
100 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
101       $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
102 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/tfm \
103       $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
104 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/type1 \
105       $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
106 rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts
107
108 mv -f $RPM_BUILD_ROOT%{_infodir}/lilypond/*.info* $RPM_BUILD_ROOT%{_infodir}
109
110 # to avoid conflict with tth (call in lily.scm changed by -ps2png.patch)
111 mv -f $RPM_BUILD_ROOT%{_bindir}/{ps2png,lilypond-ps2png}
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
120 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
121
122 %postun
123 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
124 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_libdir}/lilypond
131 %dir %{_libdir}/lilypond/%{version}
132 %dir %{_libdir}/lilypond/%{version}/python
133 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
134 %dir %{_datadir}/lilypond
135 %dir %{_datadir}/lilypond/%{version}
136 %{_datadir}/lilypond/%{version}/ly
137 %{_datadir}/lilypond/%{version}/ps
138 %dir %{_datadir}/lilypond/%{version}/python
139 %{_datadir}/lilypond/%{version}/python/*.py
140 %{_datadir}/lilypond/%{version}/python/*.pyc
141 %{_datadir}/lilypond/%{version}/dvips
142 %{_datadir}/lilypond/%{version}/fonts
143 %{_datadir}/lilypond/%{version}/scm
144 %{_datadir}/lilypond/%{version}/tex
145 %{_infodir}/*.info*
146 %{_mandir}/man1/*
147
148 # lilypond/stepmake build system - not needed at runtime
149 #%{_datadir}/lilypond/%{version}/make
150
151 %{texfontsdir}/*/lilypond
152
153 # needed? subpackage? (could install in non-existing dir)
154 %{_datadir}/omf/lilypond
155
156 %files -n emacs-lilypond-mode-pkg
157 %defattr(644,root,root,755)
158 %{_datadir}/emacs/site-lisp/*.el
This page took 0.087786 seconds and 3 git commands to generate.