]> git.pld-linux.org Git - SPECS.git/blob - likewise-open-agent.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / likewise-open-agent.spec
1 #
2 %define concurrentdir   /usr/lib/likewise
3 %define man_dir         %{_mandir}
4 %define lw_bin_dir      /usr/share/likewise/bin
5 %define lw_perlpm_dir   %{lw_bin_dir}/Centeris
6 %define lw_agent_dir    /usr/share/likewise/open-agent
7 %define lw_client_dir   /usr/share/likewise/open-agent/client
8 %define lw_agent_bin_dir %{lw_agent_dir}/bin
9 %define lw_data_dir      /usr/share/centeris/data
10 %define lw_client_files  %(find ../Windows/Install/LikewiseOpen/bin/?elease/* -type f -printf '/usr/share/likewise/open-agent/client/%f\\n')
11
12 Summary:        Likewise Open Agent - Linux authentication on a Microsoft network using AD
13 Name:           likewise-open-agent
14 Version:        0.12.1
15 Release:        0.1
16 License:        CDDL v1.0
17 Group:          Applications
18 Source0:        http://www.mirrorservice.org/sites/download.sourceforge.net/pub/sourceforge/l/li/likewiseopenagt/%{name}-%{version}-src.tar.gz
19 # Source0-md5:  4136d0d29d8aab09509033f8211a554c
20 URL:            http://www.likewisesoftware.com/
21 BuildRequires:  ant
22 BuildRequires:  autoconf
23 BuildRequires:  concurrent
24 BuildRequires:  jpackage-utils
25 BuildRequires:  heimdal-devel
26 BuildRequires:  rpm-perlprov
27 BuildRequires:  rpmbuild(macros) >= 1.300
28 BuildRequires:  samba-devel
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       perl-Convert-ASN1 >= 0.18
31 Requires:       perl-SOAP-Lite >= 0.66
32 Requires:       perl-URI
33 Requires:       perl-URI >= 1.33
34 Requires:       perl-XML-Parser >= 2.34
35 Requires:       perl-libwww-perl
36 Requires:       samba >= 3.0.20
37 Requires:       samba-client >= 3.0.20
38 Requires:       samba-winbind >= 3.0.20
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Likewise Open Agent provides Microsoft Windows system administrators
43 an easy way to perform basic administration of Linux servers for file
44 and print using the familiar Microsoft Management Console(MMC)
45 tools/wizards built into Windows.
46
47 Likewise Open Agent works in conjunction with Samba, CUPS and other
48 Linux applications. Many management functions utilize Samba and its
49 RPC mechanisms and callouts. Functionality not supported by Microsoft
50 RPC and Samba is provided through SOAP services calls to a server
51 hosted using SOAP-Lite.
52
53 Supports using the Windows Microsoft Management Console (MMC) to
54 perform the following administration task on Linux(R) servers:
55 - Add/delete/modify file shares
56 - Add/delete/modify print shares
57 - Use the Device Manager plug-in to view the properties of a Linux
58   system
59 - Right-click on a Linux server to view properties and/or shut down
60   the machine
61 - Collect events from the Linux system for display through the
62   Microsoft Event Viewer
63 - Using Samba 3.0.21 or later, provide performance counter
64   information through the perfmon client application
65
66
67
68 %prep
69 %setup -q
70 sed -i -e 's/^concurrentdir/#concurentdir/' Linux/cesm-agent/build.properties
71
72 %build
73 cd Linux
74 %ant build
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 install -d $RPM_BUILD_ROOT{%{lw_bin_dir},%{lw_perlpm_dir},%{lw_agent_dir}/log}
80 install -d $RPM_BUILD_ROOT{%{lw_agent_bin_dir},%{lw_data_dir}/{likewise-open,windows/system32}}
81 install -d $RPM_BUILD_ROOT{%{lw_client_dir},%{man_dir}/man7,/etc/rc.d/init.d}
82
83 cd Linux
84 install EventLogDB/EventLogs.pm $RPM_BUILD_ROOT%{lw_perlpm_dir}
85 install EventLogDB/evtsyslog.pl $RPM_BUILD_ROOT%{lw_bin_dir}
86 install EventLogDB/dist/likewisemsg.dll $RPM_BUILD_ROOT%{lw_data_dir}/windows/system32/likewisemsg.dll
87 install EventLogDB/likewise-evtlogd $RPM_BUILD_ROOT%{lw_bin_dir}
88 install HWInfoFilter/hwinfo_filter.pl $RPM_BUILD_ROOT%{lw_bin_dir}
89 install SambaScripts/shutdown $RPM_BUILD_ROOT%{lw_bin_dir}
90 install SambaScripts/abort_shutdown $RPM_BUILD_ROOT%{lw_bin_dir}
91 if [ -e ../Windows/Install/LikewiseOpen/bin/?elease/ ]; then
92    install ../Windows/Install/LikewiseOpen/bin/?elease/* $RPM_BUILD_ROOT%{lw_client_dir}
93 fi
94 install ./VERSION $RPM_BUILD_ROOT%{lw_agent_bin_dir}/VERSION
95 install cesm-agent/dist/likewise-open-agent.pl $RPM_BUILD_ROOT%{lw_agent_bin_dir}
96 install cesm-agent/dist/SambaCommands.jar $RPM_BUILD_ROOT%{lw_agent_bin_dir}
97 install cesm-agent/dist/sambaPrint $RPM_BUILD_ROOT%{lw_agent_bin_dir}
98 install cesm-agent/dist/sambaShare $RPM_BUILD_ROOT%{lw_agent_bin_dir}
99 install cesm-agent/dist/sambaShareInstaller $RPM_BUILD_ROOT%{lw_agent_bin_dir}
100 install cesm-agent/dist/likewise-open $RPM_BUILD_ROOT/etc/rc.d/init.d
101 install cesm-agent/dist/likewise-open $RPM_BUILD_ROOT%{lw_bin_dir}
102 install cesm-agent/dist/findjre.sh $RPM_BUILD_ROOT%{lw_agent_bin_dir}
103 install cesm-agent/dist/postinstall.sh $RPM_BUILD_ROOT%{lw_bin_dir}
104 install cesm-agent/dist/likewise-perfd $RPM_BUILD_ROOT%{lw_bin_dir}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
This page took 0.171097 seconds and 3 git commands to generate.