]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- pl for new mod_* subpackages
[packages/lighttpd.git] / lighttpd.spec
1 # TODO:
2 # - test ldap and mysql (failed at this time)
3 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
4 # - fam over gamin is possible, just configure doesn't check other than gamin
5 # - lua50 isn't properly detected
6 #
7 # NOTES:
8 # - fcgi-devel is only used for the test-scripts
9 # - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10 #   see http://article.gmane.org/gmane.comp.web.lighttpd:722
11 # - please make subpackages of modules that depend other modules than:
12 #  - pcre (core binary needs it too)
13 #  - openssl (core binary needs it too)
14 #
15 # Conditional build for lighttpd:
16 %bcond_without  xattr                   # support of extended attributes
17 %bcond_without  ipv6                    # IPv4-only version (doesn't require IPv6 in kernel)
18 %bcond_without  largefile               # largefile support (see notes above)
19 %bcond_without  ssl                             # ssl support
20 %bcond_with             mysql                   # mysql support in mod_mysql_vhost
21 %bcond_with             ldap                    # ldap support in mod_auth
22 %bcond_with             lua                             # LUA support in mod_cml
23 %bcond_with             memcache                # memcached support in mod_cml / mod_trigger_b4_dl
24 %bcond_with             gamin                   # gamin for reducing number of stat() calls. NOTE: must be enabled in config: server.stat-cache-engine = "fam"
25 %bcond_with             gdbm                    # gdbm in mod_trigger_b4_dl
26 %bcond_with             webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
27 %bcond_with             valgrind                # compile code with valgrind support.
28 %bcond_with             dirhide                 # with 'hide from dirlisting' hack
29
30 # Prerelease snapshot: DATE-TIME
31 #define _snap 20050116-1743
32
33 %if 0%{?_snap}
34 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35 %else
36 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37 %endif
38
39 %define         _rel 0.4
40
41 Summary:        Fast and light HTTP server
42 Summary(pl):    Szybki i lekki serwer HTTP
43 Name:           lighttpd
44 Version:        1.4.1
45 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
46 Group:          Networking/Daemons
47 License:        BSD
48 Source0:        %{_source}
49 # Source0-md5:  3abffbe574fd835721760a37c00d3714
50 Source1:        %{name}.init
51 Source2:        %{name}.conf
52 Source3:        %{name}.user
53 Source4:        %{name}.logrotate
54 Source5:        %{name}.sysconfig
55 Patch0:         http://minghetti.ch/blob/dirlist-hide.patch
56 Patch1:         %{name}-fcgi-verbose.patch
57 Patch2:         %{name}-ssl-redirect-fix.patch
58 Patch3:         %{name}-lua-pkgconfig.patch
59 Patch4: %{name}-openssl.patch
60 URL:            http://www.lighttpd.net/
61 %{?with_xattr:BuildRequires:    attr-devel}
62 BuildRequires:  autoconf
63 BuildRequires:  automake
64 BuildRequires:  bzip2-devel
65 %{?with_gamin:BuildRequires:    gamin-devel}
66 %{?with_webdav_props:BuildRequires:     sqlite3-devel}
67 %{?with_webdav_props:BuildRequires:     libxml2-devel}
68 BuildRequires:  libtool
69 %{?with_mysql:BuildRequires:    mysql-devel}
70 %{?with_ldap:BuildRequires:             openldap-devel}
71 %{?with_ssl:BuildRequires:      openssl-devel}
72 %{?with_lua:BuildRequires:      lua50-devel >= 5.0.2-4.1}
73 %{?with_memcache:BuildRequires: libmemcache-devel}
74 %{?with_gdbm:BuildRequires:     gdbm-devel}
75 BuildRequires:  pcre-devel
76 BuildRequires:  rpmbuild(macros) >= 1.202
77 %{?debug:BuildRequires: valgrind}
78 BuildRequires:  zlib-devel
79 PreReq:         rc-scripts
80 Requires(pre):  sh-utils
81 Requires(pre):  /bin/id
82 Requires(pre):  /usr/bin/getgid
83 Requires(pre):  /usr/sbin/groupadd
84 Requires(pre):  /usr/sbin/useradd
85 Requires(post,preun):   /sbin/chkconfig
86 Requires(postun):       /usr/sbin/groupdel
87 Requires(postun):       /usr/sbin/userdel
88 Provides:       group(lighttpd)
89 Provides:       httpd
90 Provides:       user(lighttpd)
91 Provides:       webserver
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _libdir         %{_prefix}/%{_lib}/%{name}
95 %define         _lighttpddir    /home/services/%{name}
96 %define         _sysconfdir     /etc/%{name}
97
98 %description
99 lighttpd is a secure, fast, compliant and very flexible web-server
100 which has been optimized for high-performance environments. It has a
101 very low memory footprint compared to other webservers and takes care
102 of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
103 Output-Compression, URL-Rewriting and many more) make lighttpd the
104 perfect webserver-software for every server that is suffering load
105 problems.
106
107 %description -l pl
108 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
109 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
110 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci w
111 porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
112 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
113 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
114 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy z
115 powodu problemów z obci±¿eniem.
116
117 %package mod_compress
118 Summary:        Output Compression
119 Summary(pl):    Kompresja wyj¶cia
120 Group:          Networking/Daemons
121 URL:            http://www.lighttpd.net/documentation/compress.html
122 Requires:       %{name} = %{version}-%{release}
123
124 %description mod_compress
125 Output compression reduces the network load and can improve the
126 overall throughput of the webserver.
127
128 Only static content is supported up to now.
129
130 The server negotiates automatically which compression method is used.
131 Supported are gzip, deflate, bzip.
132
133 %description mod_compress -l pl
134 Kompresja wyj¶cia zmniejsza obci±¿enie sieci i mo¿e poprawiæ ca³kowit±
135 przepustowo¶æ serwera WWW.
136
137 Jak na razie obs³ugiwana jest tylko statyczna tre¶æ.
138
139 Serwer automatycznie negocjuje, która metoda kompresji jest u¿ywana.
140 Obs³ugiwane s± gzip, deflate i bzip.
141
142 %package mod_cml
143 Summary:        Cache Meta Language module
144 Summary(pl):    Modu³ Cache Meta Language
145 Group:          Networking/Daemons
146 URL:            http://www.lighttpd.net/documentation/cml.html
147 Requires:       %{name} = %{version}-%{release}
148
149 %description mod_cml
150 CML is a Meta language to describe the dependencies of a page at one
151 side and building a page from its fragments on the other side using
152 LUA.
153
154 %description mod_cml -l pl
155 CML to metajêzyk s³u¿±cy z jednej strony do opisu zale¿no¶ci strony i
156 z drugiej strony do budowania strony z fragmentów przy u¿yciu LUA.
157
158 %package mod_mysql_vhost
159 Summary:        MySQL based vhosting
160 Summary(pl):    vhosty oparte na MySQL-u
161 Group:          Networking/Daemons
162 URL:            http://www.lighttpd.net/documentation/mysqlvhost.html
163 Requires:       %{name} = %{version}-%{release}
164
165 %description mod_mysql_vhost
166 This module provides virtual hosts (vhosts) based on a MySQL table.
167
168 %description mod_mysql_vhost -l pl
169 Ten modu³ udostêpnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
170
171 %package mod_trigger_b4_dl
172 Summary:        Trigger before Download
173 Summary(pl):    Wyzwalacz przed ¶ci±ganiem
174 Group:          Networking/Daemons
175 URL:            http://www.lighttpd.net/documentation/trigger_b4_dl.html
176 Requires:       %{name} = %{version}-%{release}
177
178 %description mod_trigger_b4_dl
179 Another anti hot-linking module.
180
181 %description mod_trigger_b4_dl -l pl
182 Jeszcze jeden modu³ blokuj±cy bezpo¶rednie linkowanie.
183
184 %package mod_webdav
185 Summary:        WebDAV module for lighttpd
186 Summary(pl):    Modu³ WebDAV dla libghttpd
187 Group:          Networking/Daemons
188 URL:            http://www.lighttpd.net/documentation/webdav.html
189 Requires:       %{name} = %{version}-%{release}
190
191 %description mod_webdav
192 The WebDAV module is a very minimalistic implementation of RFC 2518.
193 Minimalistic means that not all operations are implementated yet.
194
195 So far we have
196 - PROPFIND
197 - OPTIONS
198 - MKCOL
199 - DELETE
200 - PUT
201
202 and the usual GET, POST, HEAD from HTTP/1.1.
203
204 So far mounting a webdav resource into Windows XP works and the basic
205 litmus tests are passed.
206
207 %description mod_webdav -l pl
208 Modu³ WebDAV to bardzo minimalistyczna implementacja RFC 2518.
209 Minimalistyczna oznacza, ¿e jeszcze nie wszystkie operacje s±
210 zaimplementowane. Jak na razie s±:
211 - PROPFIND
212 - OPTIONS
213 - MKCOL
214 - DELETE
215 - PUT
216 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
217
218 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
219 podstawowe testy lakmusowe przechodz±.
220
221 %package -n spawn-fcgi
222 Summary:        Spawn fcgi-process directly
223 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
224 Group:          Applications
225
226 %description -n spawn-fcgi
227 spawn-fcgi is used to spawn fcgi-process directly without the help of
228 a webserver or the programm itself.
229
230 %description -n spawn-fcgi -l pl
231 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
232 pomocy serwera WWW ani samego programu.
233
234 %prep
235 %setup -q
236 %{?with_dirhide:%patch0 -p0}
237 %patch1 -p1
238 %patch2 -p1
239 %patch3 -p1
240 %patch4 -p2
241
242 %build
243 %{__libtoolize}
244 %{__aclocal}
245 %{__autoconf}
246 %{__automake}
247
248 %configure \
249         %{!?with_ipv6:--disable-ipv6} \
250         %{!?with_largefile:--disable-lfs} \
251         %{?with_valgrind:--with-valgrind} \
252         %{?with_xattr:--with-attr} \
253         %{?with_mysql:--with-mysql} \
254         %{?with_ldap:--with-ldap} \
255         %{?with_ssl:--with-openssl} \
256         %{?with_lua:--with-lua} \
257         %{?with_memcache:--with-memcache} \
258         %{?with_webdav_props:--with-webdav-props} \
259         %{?with_gamin:--with-gamin} \
260         %{?with_gdbm:--with-gdbm}
261
262 %{__make}
263
264 %install
265 rm -rf $RPM_BUILD_ROOT
266 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
267         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
268
269 %{__make} install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
273 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
274 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
275 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
276
277 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
278
279 # could use automake patch, but automake generation fails...
280 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %pre
286 %groupadd -g 109 lighttpd
287 %useradd -u 116 -d %{_lighttpddir} -c "HTTP User" -g lighttpd lighttpd
288
289 %post
290 /sbin/chkconfig --add %{name}
291 if [ -f /var/lock/subsys/%{name} ]; then
292         /etc/rc.d/init.d/%{name} restart 1>&2
293 else
294         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
295 fi
296
297 %preun
298 if [ "$1" = "0" ]; then
299         if [ -f /var/lock/subsys/%{name} ]; then
300                 /etc/rc.d/init.d/%{name} stop 1>&2
301         fi
302         /sbin/chkconfig --del %{name}
303 fi
304
305 %postun
306 if [ "$1" = "0" ]; then
307         %userremove lighttpd
308         %groupremove lighttpd
309 fi
310
311 %triggerpostun -- %{name} <= 1.3.6-2
312 # upgraded
313 if [ "$1" = "2" ]; then
314 %banner %{name} -e <<EOF
315 spawn-fcgi program is now available separately from spawn-fcgi package.
316
317 EOF
318 fi
319
320 %files
321 %defattr(644,root,root,755)
322 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
323 %attr(755,root,root) %{_sbindir}/*
324 %dir %{_libdir}
325 %attr(755,root,root) %{_libdir}/mod_access.so
326 %attr(755,root,root) %{_libdir}/mod_accesslog.so
327 %attr(755,root,root) %{_libdir}/mod_alias.so
328 %attr(755,root,root) %{_libdir}/mod_auth.so
329 %attr(755,root,root) %{_libdir}/mod_cgi.so
330 %attr(755,root,root) %{_libdir}/mod_dirlisting.so
331 %attr(755,root,root) %{_libdir}/mod_evhost.so
332 %attr(755,root,root) %{_libdir}/mod_expire.so
333 %attr(755,root,root) %{_libdir}/mod_fastcgi.so
334 %attr(755,root,root) %{_libdir}/mod_indexfile.so
335 %attr(755,root,root) %{_libdir}/mod_proxy.so
336 %attr(755,root,root) %{_libdir}/mod_redirect.so
337 %attr(755,root,root) %{_libdir}/mod_rewrite.so
338 %attr(755,root,root) %{_libdir}/mod_rrdtool.so
339 %attr(755,root,root) %{_libdir}/mod_scgi.so
340 %attr(755,root,root) %{_libdir}/mod_secdownload.so
341 %attr(755,root,root) %{_libdir}/mod_setenv.so
342 %attr(755,root,root) %{_libdir}/mod_simple_vhost.so
343 %attr(755,root,root) %{_libdir}/mod_ssi.so
344 %attr(755,root,root) %{_libdir}/mod_staticfile.so
345 %attr(755,root,root) %{_libdir}/mod_status.so
346 %attr(755,root,root) %{_libdir}/mod_userdir.so
347 %attr(755,root,root) %{_libdir}/mod_usertrack.so
348 %attr(750,root,root) %dir /var/log/archiv/%{name}
349 %dir %attr(750,lighttpd,root) /var/log/%{name}
350 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
351 %attr(754,root,root) /etc/rc.d/init.d/%{name}
352 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
353 %dir %attr(750,root,lighttpd) %{_sysconfdir}
354 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
355 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
356 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
357 %{_mandir}/man?/*
358
359 %files mod_compress
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_libdir}/mod_compress.so
362
363 %files mod_cml
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_libdir}/mod_cml.so
366
367 %if %{with mysql}
368 %files mod_mysql_vhost
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/mod_mysql_vhost.so
371 %endif
372
373 %files mod_trigger_b4_dl
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_libdir}/mod_trigger_b4_dl.so
376
377 %files mod_webdav
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_libdir}/mod_webdav.so
380
381 %files -n spawn-fcgi
382 %defattr(644,root,root,755)
383 %doc doc/spawn-php.sh
384 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.209984 seconds and 4 git commands to generate.