]> git.pld-linux.org Git - SPECS.git/blob - light.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / light.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk1    # use GTK+ 1.2 instead of 2.x
4 #
5 %define         minmozver       3:1.2.1
6 %define         gtkv            gtk%{?with_gtk1:1}%{!?with_gtk1:2}
7 Summary:        Light - yet another Mozilla based browser
8 Summary(pl.UTF-8):      Light - jeszcze jedna przeglÄ…darka oparta na Mozilli (gecko)
9 Name:           light
10 Version:        1.4.12
11 Release:        5.1
12 License:        GPL
13 Group:          X11/Applications/Networking
14 Source0:        http://www.ne.jp/asahi/linux/timecop/software/%{name}-%{version}.tar.bz2
15 # Source0-md5:  b83da71a3504cbb7812d0b56bf709cd9
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-mozilla1.1-noxfer.patch
18 Patch1:         %{name}-mozilla1.2b.patch
19 Patch2:         %{name}-mozilla1.4.patch
20 Patch3:         %{name}-gtk2.patch
21 URL:            http://www.ne.jp/asahi/linux/timecop/#light
22 BuildRequires:  autoconf
23 %{?with_gtk1:BuildRequires:     gtk+-devel >= 1.2.6}
24 %{!?with_gtk1:BuildRequires:    gtk+2-devel >= 1:2.0.0}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  mozilla-embedded(%{gtkv}) >= %{minmozver}
27 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
28 %{!?with_gtk1:BuildRequires:    pkgconfig}
29 BuildRequires:  zlib-devel
30 Requires:       mozilla-embedded(%{gtkv}) = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # can be provided by mozilla or mozilla-embedded
34 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
35
36 %description
37 This is "Yet Another Mozilla Based Browser", called "Light".
38
39 %description -l pl.UTF-8
40 To jest jeszcze jedna przeglÄ…darka oparta na Mozilli o nazwie "Light".
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 %{!?with_gtk1:%patch3 -p1}
48
49 %build
50 %{__autoconf}
51 %configure \
52         --with-mozilla-libs=/usr/lib \
53         --with-mozilla-includes="/usr/include/mozilla -I/usr/include/mozilla/gtkembedmoz -I/usr/include/mozilla/necko -I/usr/include/mozilla/xpcom -I/usr/include/mozilla/string -I/usr/include/mozilla/embed_base -I/usr/include/mozilla/docshell -I/usr/include/mozilla/content -I/usr/include/mozilla/webbrwsr -I/usr/include/mozilla/webbrowserpersist -I/usr/include/mozilla/find -I/usr/include/mozilla/webshell -I/usr/include/mozilla/gfx -I/usr/include/mozilla/shistory -I/usr/include/mozilla/appcomps -I/usr/include/mozilla/uconv -I/usr/include/mozilla/widget -I/usr/include/mozilla/dom -I/usr/include/mozilla/layout -I/usr/include/mozilla/mozxfer -I/usr/include/mozilla/nkcache -I/usr/include/mozilla/pref" \
54         --with-nspr-includes=/usr/include/nspr \
55         --enable-mozilla-cvs
56
57 %{__make} OPT="%{rpmcflags} -DNEW_H=\<new.h\>"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_bindir},%{_applnkdir}/Network/WWW}
62
63 install src/light $RPM_BUILD_ROOT%{_bindir}/light-bin
64
65 cat > $RPM_BUILD_ROOT%{_bindir}/light <<EOF
66 #!/bin/sh
67
68 MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla
69 export MOZILLA_FIVE_HOME
70
71 exec %{_bindir}/light-bin \$@
72 EOF
73
74 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS ChangeLog README TODO doc/*.html
82 %attr(755,root,root) %{_bindir}/*
83 %{_desktopdir}/*.desktop
This page took 1.574063 seconds and 3 git commands to generate.