]> git.pld-linux.org Git - packages/libzapojit.git/blob - libzapojit.spec
ebb45e3f7f39b34cfbfaf7ad9238c18e5cf4f85e
[packages/libzapojit.git] / libzapojit.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs
7 Summary(pl.UTF-8):      Obudowanie GLib/GObject dla API REST-owych SkyDrive'a i Hotmaila
8 Name:           libzapojit
9 Version:        0.0.3
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libzapojit/0.0/%{name}-%{version}.tar.xz
14 # Source0-md5:  9de0d94e2c6a86852133a6f2f0b5fee1
15 URL:            http://live.gnome.org/Zapojit
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gnome-common >= 3.6.0
21 BuildRequires:  gnome-online-accounts-devel
22 BuildRequires:  gobject-introspection-devel >= 1.30.0
23 BuildRequires:  gtk-doc >= 1.11
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  json-glib-devel
26 BuildRequires:  libsoup-devel >= 2.38.0
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  pkgconfig
29 BuildRequires:  rest-devel >= 0.7
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       glib2 >= 1:2.28.0
33 Requires:       libsoup >= 2.38.0
34 Requires:       rest >= 0.7
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libzapojit is a GLib/GObject wrapper for the SkyDrive and Hotmail REST
39 APIs. It supports SkyDrive file and folder objects, and the following
40 SkyDrive operations:
41 - Deleting a file, folder or photo.
42 - Listing the contents of a folder.
43 - Reading the properties of a file, folder or photo.
44 - Uploading files and photos.
45
46 %description -l pl.UTF-8
47 libzapojit to obudowanie GLib/GObject dla API REST-owych SkyDrive'a i
48 Hotmaila. Obsługuje obiekty plików i folderów SkyDrive'a oraz
49 następujące operacje SkyDrive:
50 - usuwanie pliku, folderu lub zdjęcia,
51 - listowanie zawartości folderu,
52 - odczyt właściwości pliku, folderu lub zdjecia,
53 - przesyłanie plików i zdjęć.
54
55 %package devel
56 Summary:        Header files for libzapojit library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libzapojit
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       glib2-devel >= 1:2.28.0
61 Requires:       gnome-online-accounts-devel
62 Requires:       json-glib-devel
63 Requires:       libsoup-devel >= 2.38.0
64 Requires:       rest-devel >= 0.7
65
66 %description devel
67 Header files for libzapojit library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki libzapojit.
71
72 %package static
73 Summary:        Static libzapojit library
74 Summary(pl.UTF-8):      Statyczna biblioteka libzapojit
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libzapojit library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka libzapojit.
83
84 %package apidocs
85 Summary:        libzapojit API documentation
86 Summary(pl.UTF-8):      Dokumentacja API biblioteki libzapojit
87 Group:          Documentation
88 Requires:       gtk-doc-common
89
90 %description apidocs
91 API documentation for libzapojit library.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API biblioteki libzapojit.
95
96 %prep
97 %setup -q
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         %{__enable_disable apidocs gtk-doc} \
108         %{__enable_disable static_libs static} \
109         --with-html-dir=%{_gtkdocdir}
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README
129 %attr(755,root,root) %{_libdir}/libzapojit-0.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libzapojit-0.0.so.0
131 %{_libdir}/girepository-1.0/Zpj-0.0.typelib
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libzapojit-0.0.so
136 %{_libdir}/libzapojit-0.0.la
137 %{_includedir}/libzapojit-0.0
138 %{_pkgconfigdir}/zapojit-0.0.pc
139 %{_datadir}/gir-1.0/Zpj-0.0.gir
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libzapojit-0.0.a
145 %endif
146
147 %if %{with apidocs}
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/libzapojit-0.0
151 %endif
This page took 0.060159 seconds and 3 git commands to generate.