]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
- 1.1.17
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         libxml2ver      1:2.6.21
6
7 Summary:        XSLT processor
8 Summary(pl):    Procesor XSLT
9 Summary(pt_BR): Biblioteca que disponibiliza o sistema XSLT do GNOME
10 Name:           libxslt
11 Version:        1.1.17
12 Release:        1
13 License:        MIT
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
16 # Source0-md5:  af99d7b06eba109ab374ccd7015561c4
17 Patch0:         %{name}-DESTDIR.patch
18 URL:            http://xmlsoft.org/XSLT/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libgcrypt-devel >= 1.1.42
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  libxml2-devel >= %{libxml2ver}
24 BuildRequires:  perl-base
25 BuildRequires:  python
26 BuildRequires:  python-devel
27 BuildRequires:  python-libxml2 >= %{libxml2ver}
28 Requires:       libgcrypt >= 1.1.42
29 Requires:       libxml2 >= %{libxml2ver}
30 Obsoletes:      libxslt1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Library for XSLT processing.
35
36 %description -l pl
37 Biblioteka do przetwarzania XSLT.
38
39 %description -l pt_BR
40 Esta biblioteca C permite a transformação de arquivos XML em outros
41 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
42 transformação dos estilos XSLT. O comando xsltproc é uma interface em
43 linha de comandos para o mecanismo XSLT.
44
45 %package devel
46 Summary:        Header files for libxslt
47 Summary(pl):    Pliki nag³ówkowe libxslt
48 Summary(pt_BR): Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libgcrypt-devel >= 1.1.42
52 Requires:       libxml2-devel >= %{libxml2ver}
53 Obsoletes:      libxslt1-devel
54
55 %description devel
56 Header files for libxslt - XSLT processor.
57
58 %description devel -l pl
59 Pliki nag³ówkowe procesora XSLT.
60
61 %description devel -l pt_BR
62 Esta biblioteca C permite a transformação de arquivos XML em outros
63 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
64 transformação dos estilos XSLT.
65
66 %package static
67 Summary:        Static libraries of libxslt
68 Summary(pl):    Biblioteki statyczne libxslt
69 Summary(pt_BR): Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libraries of libxslt - XSLT processor.
75
76 %description static -l pl
77 Statyczne biblioteki procesora XSLT.
78
79 %description static -l pt_BR
80 Esta biblioteca C permite a transformação de arquivos XML em outros
81 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
82 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
83 estática.
84
85 %package progs
86 Summary:        XSLT processor
87 Summary(pl):    Procesor XSLT
88 Group:          Applications/Text
89 Requires:       %{name} = %{version}-%{release}
90 Obsoletes:      libxslt-proc
91
92 %description progs
93 XSLT processor.
94
95 %description progs -l pl
96 Procesor XSLT.
97
98 %package -n python-%{name}
99 Summary:        Python support for libxslt
100 Summary(pl):    Modu³y jêzyka Python dla biblioteki libxslt
101 Group:          Libraries/Python
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       python-libxml2 => %{libxml2ver}
104 %pyrequires_eq  python-modules
105 Obsoletes:      libxslt-python
106
107 %description -n python-%{name}
108 Python support for libxslt.
109
110 %description -n python-%{name} -l pl
111 Modu³y jêzyka Python dla biblioteki libxslt.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         %{!?with_static_libs:--disable-static}
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 # move examples to proper dir
134 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
135 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
136   $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
137 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
138
139 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
140 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
141
142 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*
154 %dir %{_libdir}/libxslt-plugins
155
156 %files devel
157 %defattr(644,root,root,755)
158 %doc doc/{*.{gif,html},html}
159 %attr(755,root,root) %{_bindir}/xslt-config
160 %attr(755,root,root) %{_libdir}/lib*.so
161 %{_libdir}/lib*.la
162 %attr(755,root,root) %{_libdir}/*.sh
163 %{_includedir}/libxslt
164 %{_includedir}/libexslt
165 %{_mandir}/man3/*
166 %{_pkgconfigdir}/*.pc
167 %{_aclocaldir}/*.m4
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/lib*.a
173 %endif
174
175 %files progs
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_bindir}/xsltproc
178 %{_mandir}/man1/*
179
180 %files -n python-%{name}
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{py_sitedir}/*.so
183 %{py_sitedir}/*.py[co]
184 %{_examplesdir}/python-%{name}-%{version}
This page took 0.058058 seconds and 3 git commands to generate.