]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
- updated to 1.1.21
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # don't build python binding
4 %bcond_without  static_libs     # don't build static library
5 %bcond_with     tests           # run test suite
6 #
7 %define         libxml2ver      1:2.6.29
8
9 Summary:        XSLT processor
10 Summary(pl.UTF-8):      Procesor XSLT
11 Summary(pt_BR.UTF-8):   Biblioteca que disponibiliza o sistema XSLT do GNOME
12 Name:           libxslt
13 Version:        1.1.21
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0:       http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
18 Source0:        ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
19 # Source0-md5:  59fe34e85692f71df2a38c2ee291b3ca
20 URL:            http://xmlsoft.org/XSLT/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libgcrypt-devel >= 1.1.42
24 BuildRequires:  libtool >= 1:1.4.2-9
25 BuildRequires:  libxml2-devel >= %{libxml2ver}
26 BuildRequires:  perl-base
27 %if %{with python}
28 BuildRequires:  python
29 BuildRequires:  python-devel
30 BuildRequires:  python-libxml2 >= %{libxml2ver}
31 %endif
32 BuildRequires:  rpm-pythonprov
33 Requires:       libgcrypt >= 1.1.42
34 Requires:       libxml2 >= %{libxml2ver}
35 Obsoletes:      libxslt1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Library for XSLT processing.
40
41 %description -l pl.UTF-8
42 Biblioteka do przetwarzania XSLT.
43
44 %description -l pt_BR.UTF-8
45 Esta biblioteca C permite a transformação de arquivos XML em outros
46 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
47 transformação dos estilos XSLT. O comando xsltproc é uma interface em
48 linha de comandos para o mecanismo XSLT.
49
50 %package devel
51 Summary:        Header files for libxslt
52 Summary(pl.UTF-8):      Pliki nagłówkowe libxslt
53 Summary(pt_BR.UTF-8):   Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libgcrypt-devel >= 1.1.42
57 Requires:       libxml2-devel >= %{libxml2ver}
58 Obsoletes:      libxslt1-devel
59
60 %description devel
61 Header files for libxslt - XSLT processor.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe procesora XSLT.
65
66 %description devel -l pt_BR.UTF-8
67 Esta biblioteca C permite a transformação de arquivos XML em outros
68 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
69 transformação dos estilos XSLT.
70
71 %package static
72 Summary:        Static libraries of libxslt
73 Summary(pl.UTF-8):      Biblioteki statyczne libxslt
74 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libraries of libxslt - XSLT processor.
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki procesora XSLT.
83
84 %description static -l pt_BR.UTF-8
85 Esta biblioteca C permite a transformação de arquivos XML em outros
86 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
87 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
88 estática.
89
90 %package progs
91 Summary:        XSLT processor
92 Summary(pl.UTF-8):      Procesor XSLT
93 Group:          Applications/Text
94 Requires:       %{name} = %{version}-%{release}
95 Obsoletes:      libxslt-proc
96
97 %description progs
98 XSLT processor.
99
100 %description progs -l pl.UTF-8
101 Procesor XSLT.
102
103 %package -n python-%{name}
104 Summary:        Python support for libxslt
105 Summary(pl.UTF-8):      Moduły języka Python dla biblioteki libxslt
106 Group:          Libraries/Python
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       python-libxml2 => %{libxml2ver}
109 %pyrequires_eq  python-modules
110 Obsoletes:      libxslt-python
111
112 %description -n python-%{name}
113 Python support for libxslt.
114
115 %description -n python-%{name} -l pl.UTF-8
116 Moduły języka Python dla biblioteki libxslt.
117
118 %prep
119 %setup -q
120
121 %build
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         %{!?with_static_libs:--disable-static} \
129         %{!?with_python:--without-python}
130 %{__make}
131
132 %{?with_tests:%{__make} -C tests test}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %if %{with python}
141 # move examples to proper dir
142 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
143 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
144   $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
145 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
146
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149
150 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
151 %endif
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
162 %attr(755,root,root) %{_libdir}/lib*.so.*.*
163 %dir %{_libdir}/libxslt-plugins
164
165 %files devel
166 %defattr(644,root,root,755)
167 %doc doc/{*.{gif,html},html}
168 %attr(755,root,root) %{_bindir}/xslt-config
169 %attr(755,root,root) %{_libdir}/lib*.so
170 %{_libdir}/lib*.la
171 %attr(755,root,root) %{_libdir}/*.sh
172 %{_includedir}/libxslt
173 %{_includedir}/libexslt
174 %{_mandir}/man3/*
175 %{_pkgconfigdir}/*.pc
176 %{_aclocaldir}/*.m4
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/lib*.a
182 %endif
183
184 %files progs
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_bindir}/xsltproc
187 %{_mandir}/man1/*
188
189 %if %{with python}
190 %files -n python-%{name}
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{py_sitedir}/*.so
193 %{py_sitedir}/*.py[co]
194 %{_examplesdir}/python-%{name}-%{version}
195 %endif
This page took 0.088429 seconds and 3 git commands to generate.