]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
- rebuild with 2.5
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     tests           # run test suite
5 #
6 %define         libxml2ver      1:2.6.21
7
8 Summary:        XSLT processor
9 Summary(pl):    Procesor XSLT
10 Summary(pt_BR): Biblioteca que disponibiliza o sistema XSLT do GNOME
11 Name:           libxslt
12 Version:        1.1.17
13 Release:        3
14 License:        MIT
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
17 # Source0-md5:  af99d7b06eba109ab374ccd7015561c4
18 Patch0:         %{name}-DESTDIR.patch
19 URL:            http://xmlsoft.org/XSLT/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libgcrypt-devel >= 1.1.42
23 BuildRequires:  libtool >= 1:1.4.2-9
24 BuildRequires:  libxml2-devel >= %{libxml2ver}
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  python-devel
28 BuildRequires:  python-libxml2 >= %{libxml2ver}
29 Requires:       libgcrypt >= 1.1.42
30 Requires:       libxml2 >= %{libxml2ver}
31 Obsoletes:      libxslt1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Library for XSLT processing.
36
37 %description -l pl
38 Biblioteka do przetwarzania XSLT.
39
40 %description -l pt_BR
41 Esta biblioteca C permite a transformação de arquivos XML em outros
42 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
43 transformação dos estilos XSLT. O comando xsltproc é uma interface em
44 linha de comandos para o mecanismo XSLT.
45
46 %package devel
47 Summary:        Header files for libxslt
48 Summary(pl):    Pliki nag³ówkowe libxslt
49 Summary(pt_BR): Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libgcrypt-devel >= 1.1.42
53 Requires:       libxml2-devel >= %{libxml2ver}
54 Obsoletes:      libxslt1-devel
55
56 %description devel
57 Header files for libxslt - XSLT processor.
58
59 %description devel -l pl
60 Pliki nag³ówkowe procesora XSLT.
61
62 %description devel -l pt_BR
63 Esta biblioteca C permite a transformação de arquivos XML em outros
64 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
65 transformação dos estilos XSLT.
66
67 %package static
68 Summary:        Static libraries of libxslt
69 Summary(pl):    Biblioteki statyczne libxslt
70 Summary(pt_BR): Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static libraries of libxslt - XSLT processor.
76
77 %description static -l pl
78 Statyczne biblioteki procesora XSLT.
79
80 %description static -l pt_BR
81 Esta biblioteca C permite a transformação de arquivos XML em outros
82 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
83 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
84 estática.
85
86 %package progs
87 Summary:        XSLT processor
88 Summary(pl):    Procesor XSLT
89 Group:          Applications/Text
90 Requires:       %{name} = %{version}-%{release}
91 Obsoletes:      libxslt-proc
92
93 %description progs
94 XSLT processor.
95
96 %description progs -l pl
97 Procesor XSLT.
98
99 %package -n python-%{name}
100 Summary:        Python support for libxslt
101 Summary(pl):    Modu³y jêzyka Python dla biblioteki libxslt
102 Group:          Libraries/Python
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       python-libxml2 => %{libxml2ver}
105 %pyrequires_eq  python-modules
106 Obsoletes:      libxslt-python
107
108 %description -n python-%{name}
109 Python support for libxslt.
110
111 %description -n python-%{name} -l pl
112 Modu³y jêzyka Python dla biblioteki libxslt.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 %build
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         %{!?with_static_libs:--disable-static}
126 %{__make}
127
128 %{?with_tests:%{__make} -C tests test}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 # move examples to proper dir
137 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
138 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
139   $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
140 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
141
142 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
143 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
144
145 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157 %dir %{_libdir}/libxslt-plugins
158
159 %files devel
160 %defattr(644,root,root,755)
161 %doc doc/{*.{gif,html},html}
162 %attr(755,root,root) %{_bindir}/xslt-config
163 %attr(755,root,root) %{_libdir}/lib*.so
164 %{_libdir}/lib*.la
165 %attr(755,root,root) %{_libdir}/*.sh
166 %{_includedir}/libxslt
167 %{_includedir}/libexslt
168 %{_mandir}/man3/*
169 %{_pkgconfigdir}/*.pc
170 %{_aclocaldir}/*.m4
171
172 %if %{with static_libs}
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/lib*.a
176 %endif
177
178 %files progs
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/xsltproc
181 %{_mandir}/man1/*
182
183 %files -n python-%{name}
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{py_sitedir}/*.so
186 %{py_sitedir}/*.py[co]
187 %{_examplesdir}/python-%{name}-%{version}
This page took 0.036133 seconds and 3 git commands to generate.