]> git.pld-linux.org Git - SPECS.git/blob - libxml++5.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libxml++5.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C++ interface for working with XML files
6 Summary(pl.UTF-8):      Interfejs C++ do pracy z plikami XML
7 Name:           libxml++5
8 Version:        5.0.1
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        https://download.gnome.org/sources/libxml++/5.0/libxml++-%{version}.tar.xz
13 # Source0-md5:  b95f8c7cd1068bd7b88111340aba6238
14 URL:            http://libxmlplusplus.sourceforge.net/
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  doxygen >= 1:1.8.9
18 BuildRequires:  libstdc++-devel >= 6:7
19 BuildRequires:  libtool >= 2:2.2.6
20 BuildRequires:  libxml2-devel >= 1:2.7.7
21 BuildRequires:  mm-common >= 0.9.10
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       libxml2 >= 1:2.7.7
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libxml++ is a C++ interface for the libxml XML parser library.
32
33 %description -l pl.UTF-8
34 libxml++ jest interfejsem C++ do biblioteki libxml.
35
36 %package devel
37 Summary:        Header files for libxml++
38 Summary(pl.UTF-8):      Pliki nagłówkowe do libxml++
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libstdc++-devel >= 6:7
42 Requires:       libxml2-devel >= 1:2.7.7
43
44 %description devel
45 Header files for libxml++.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe do libxml++.
49
50 %package static
51 Summary:        Static libxml++ libraries
52 Summary(pl.UTF-8):      Biblioteka statyczna libxml++
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libxml++ libraries.
58
59 %description static -l pl.UTF-8
60 Biblioteka statyczna libxml++.
61
62 %package apidocs
63 Summary:        libxml++ API documentation
64 Summary(pl.UTF-8):      Dokumentacja API libxml++
65 Group:          Documentation
66 BuildArch:      noarch
67
68 %description apidocs
69 libxml++ API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API libxml++.
73
74 %package examples
75 Summary:        libxml++ - example programs
76 Summary(pl.UTF-8):      libxml++ - przykładowe programy
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description examples
81 libxml++ - example programs.
82
83 %description examples -l pl.UTF-8
84 libxml++ - przykładowe programy.
85
86 %prep
87 %setup -q -n libxml++-%{version}
88
89 %build
90 mm-common-prepare --copy --force
91 %{__libtoolize}
92 %{__aclocal} -I build
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{?with_static_libs:--enable-static} \
98         --disable-silent-rules
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml++-5.0.la
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README
121 %attr(755,root,root) %{_libdir}/libxml++-5.0.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libxml++-5.0.so.1
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libxml++-5.0.so
127 %{_libdir}/libxml++-5.0
128 %{_includedir}/libxml++-5.0
129 %{_pkgconfigdir}/libxml++-5.0.pc
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libxml++-5.0.a
135 %endif
136
137 %files apidocs
138 %defattr(644,root,root,755)
139 %{_datadir}/devhelp/books/libxml++-5.0
140 %{_docdir}/libxml++-5.0
141
142 %files examples
143 %defattr(644,root,root,755)
144 %{_examplesdir}/%{name}-%{version}
This page took 0.247138 seconds and 3 git commands to generate.