]> git.pld-linux.org Git - SPECS.git/blob - libxml++4.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / libxml++4.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define glibmm_ver      2.68.0
6 Summary:        C++ interface for working with XML files
7 Summary(pl.UTF-8):      Interfejs C++ do pracy z plikami XML
8 Name:           libxml++4
9 Version:        4.0.3
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/libxml++/4.0/libxml++-%{version}.tar.xz
14 # Source0-md5:  4fb9ca065659856aef74b37ff53e20ef
15 URL:            http://libxmlplusplus.sourceforge.net/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd50-xml
19 BuildRequires:  docbook-style-xsl-ns
20 BuildRequires:  doxygen >= 1:1.8.9
21 BuildRequires:  glibmm2.68-devel >= %{glibmm_ver}
22 BuildRequires:  libstdc++-devel >= 6:7
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 1:2.7.7
25 BuildRequires:  mm-common >= 0.9.10
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 1.752
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       glibmm2.68 >= %{glibmm_ver}
32 Requires:       libxml2 >= 1:2.7.7
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libxml++ is a C++ interface for the libxml XML parser library.
37
38 %description -l pl.UTF-8
39 libxml++ jest interfejsem C++ do biblioteki libxml.
40
41 %package devel
42 Summary:        Header files for libxml++
43 Summary(pl.UTF-8):      Pliki nagłówkowe do libxml++
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glibmm2.68-devel >= %{glibmm_ver}
47 Requires:       libstdc++-devel >= 6:7
48 Requires:       libxml2-devel >= 1:2.7.7
49
50 %description devel
51 Header files for libxml++.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do libxml++.
55
56 %package static
57 Summary:        Static libxml++ libraries
58 Summary(pl.UTF-8):      Biblioteka statyczna libxml++
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libxml++ libraries.
64
65 %description static -l pl.UTF-8
66 Biblioteka statyczna libxml++.
67
68 %package apidocs
69 Summary:        libxml++ API documentation
70 Summary(pl.UTF-8):      Dokumentacja API libxml++
71 Group:          Documentation
72 BuildArch:      noarch
73
74 %description apidocs
75 libxml++ API documentation.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API libxml++.
79
80 %package examples
81 Summary:        libxml++ - example programs
82 Summary(pl.UTF-8):      libxml++ - przykładowe programy
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description examples
87 libxml++ - example programs.
88
89 %description examples -l pl.UTF-8
90 libxml++ - przykładowe programy.
91
92 %prep
93 %setup -q -n libxml++-%{version}
94
95 %build
96 mm-common-prepare --copy --force
97 %{__libtoolize}
98 %{__aclocal} -I build
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         %{?with_static_libs:--enable-static} \
104         --disable-silent-rules
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml++-4.0.la
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ChangeLog NEWS README.md
127 %attr(755,root,root) %{_libdir}/libxml++-4.0.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libxml++-4.0.so.1
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libxml++-4.0.so
133 %{_libdir}/libxml++-4.0
134 %{_includedir}/libxml++-4.0
135 %{_pkgconfigdir}/libxml++-4.0.pc
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libxml++-4.0.a
141 %endif
142
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_datadir}/devhelp/books/libxml++-4.0
146 %{_docdir}/libxml++-4.0
147
148 %files examples
149 %defattr(644,root,root,755)
150 %{_examplesdir}/%{name}-%{version}
This page took 0.82374 seconds and 3 git commands to generate.