]> git.pld-linux.org Git - packages/libxcrypt.git/blob - libxcrypt.spec
- disable -Werror from CFLAGS or this code won't compile under modern gcc
[packages/libxcrypt.git] / libxcrypt.spec
1 Summary:        Crypt Library for DES, MD5, and Blowfish
2 Summary(pl.UTF-8):      Biblioteka szyfrująca hasła obsługująca DES, MD5 i Blowfish
3 Name:           libxcrypt
4 Version:        3.0.2
5 Release:        2
6 License:        LGPL v2.1+ (library), LGPL v2.1+/Public Domain (plugins)
7 Group:          Libraries
8 Source0:        ftp://ftp.suse.com/pub/people/kukuk/libxcrypt/%{name}-%{version}.tar.bz2
9 # Source0-md5:  56cf4285086f26649b8792b53fe8b00f
10 Patch0:         %{name}-noWerror.patch
11 BuildRequires:  sed >= 4.0
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %undefine       __cxx
15
16 %description
17 libxcrypt is a replacement for libcrypt, which comes with the GNU C
18 Library. It supports DES crypt, MD5, and passwords with Blowfish
19 encryption.
20
21 %description -l pl.UTF-8
22 libxcrypt to zamiennik biblioteki libcrypt dostarczanej wraz z
23 biblioteką GNU C (libc). Obsługuje szyfrowanie haseł DES, MD5 oraz
24 Blowfish.
25
26 %package devel
27 Summary:        Header file for libxcrypt
28 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libxcrypt
29 License:        LGPL v2.1+
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 This package contains the header file to develop software using
35 libxcrypt.
36
37 %description devel -l pl.UTF-8
38 Ten pakiet zawiera plik nagłówkowy pozwalający na tworzenie programów
39 korzystających z libxcrypt.
40
41 %package static
42 Summary:        Static libxcrypt library
43 Summary(pl.UTF-8):      Statyczna biblioteka libxcrypt
44 License:        LGPL v2.1+
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 This package contains the static libxcrypt library used for
50 development.
51
52 %description static -l pl.UTF-8
53 Ten pakiet zawiera statyczną wersję biblioteki libxcrypt.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %configure \
61         --libdir=/%{_lib}
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_libdir}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 mv -f $RPM_BUILD_ROOT/%{_lib}/libxcrypt.{so,la,a} $RPM_BUILD_ROOT%{_libdir}
72 sed -i -e 's#/%{_lib}#%{_libdir}#g' $RPM_BUILD_ROOT%{_libdir}/libxcrypt.la
73 ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libxcrypt.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libxcrypt.so
74
75 %{__rm} $RPM_BUILD_ROOT/%{_lib}/xcrypt/*.{la,a}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 # COPYING specifies licenses for particular plugins
86 %doc COPYING ChangeLog NEWS README*
87 %attr(755,root,root) /%{_lib}/libxcrypt.so.*.*.*
88 %attr(755,root,root) %ghost /%{_lib}/libxcrypt.so.2
89 %dir /%{_lib}/xcrypt
90 %attr(755,root,root) /%{_lib}/xcrypt/libxcrypt_*.so*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/libxcrypt.so
95 %{_libdir}/libxcrypt.la
96 %{_includedir}/xcrypt.h
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/libxcrypt.a
This page took 0.067473 seconds and 4 git commands to generate.