]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- release 2
[packages/libx264.git] / libx264.spec
1 %define         snap    20100512
2 %define         snaph   2245
3 %define         rel     2
4 Summary:        H264 encoder library
5 Summary(pl.UTF-8):      Biblioteka kodująca H264
6 Name:           libx264
7 Version:        0.1.3
8 Release:        1.%{snap}_%{snaph}.%{rel}
9 License:        GPL v2+
10 Group:          Libraries
11 # unofficial, debianized/libtoolized packaging:
12 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
13 # but it's too old, so use snapshots...
14 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
15 # Source0-md5:  38c331e76ab11517261522a60da8dd31
16 Patch0:         %{name}-alpha.patch
17 Patch1:         %{name}-syms.patch
18 URL:            http://www.videolan.org/developers/x264.html
19 BuildRequires:  pkgconfig
20 %ifarch %{ix86} %{x8664}
21 BuildRequires:  yasm >= 0.6.0
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # encoder/macroblock.c breaks strict-aliasing rules
26 %define         specflags       -fno-strict-aliasing
27
28 %description
29 libx264 library for encoding H264 video format.
30
31 %description -l pl.UTF-8
32 Biblioteka libx264 do kodowania w formacie obrazu H264.
33
34 %package devel
35 Summary:        Header files for x264 library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for x264 library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki x264.
45
46 %package static
47 Summary:        Static x264 library
48 Summary(pl.UTF-8):      Statyczna biblioteka x264
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static x264 library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka x264.
57
58 %prep
59 %setup -q -n x264-snapshot-%{snap}-%{snaph}
60 %patch0 -p1
61 %patch1 -p1
62 sed -i 's:-O4::g' configure
63
64 %build
65 CC="%{__cc}" \
66 ./configure \
67         --prefix=%{_prefix} \
68         --exec-prefix=%{_prefix} \
69         --bindir=%{_bindir} \
70         --includedir=%{_includedir} \
71         --libdir=%{_libdir} \
72         --extra-cflags="%{rpmcflags}" \
73         --enable-pic \
74         --enable-shared
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS
93 %attr(755,root,root) %{_bindir}/x264
94 %attr(755,root,root) %{_libdir}/libx264.so.[0-9][0-9]
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libx264.so
99 %{_includedir}/x264.h
100 %{_pkgconfigdir}/x264.pc
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libx264.a
This page took 0.041663 seconds and 4 git commands to generate.