]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- fix x86_64 build; rel 4
[packages/libx264.git] / libx264.spec
1 %define         snap    20080816
2 %define         snaph   2245
3 %define         rel     4
4 Summary:        H264 encoder library
5 Summary(pl.UTF-8):      Biblioteka kodująca H264
6 Name:           libx264
7 Version:        0.1.2
8 Release:        1.%{snap}_%{snaph}.%{rel}
9 License:        GPL v2+
10 Group:          Libraries
11 # unofficial, debianized/libtoolized packaging:
12 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
13 # but it's too old, so use snapshots...
14 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
15 # Source0-md5:  0a188b8e13c62f6a97eba1c5d4ab3a3f
16 Patch0:         %{name}-alpha.patch
17 Patch1:         %{name}-syms.patch
18 URL:            http://www.videolan.org/developers/x264.html
19 BuildRequires:  gettext-devel
20 BuildRequires:  gtk+2-devel
21 BuildRequires:  pkgconfig
22 %ifarch %{ix86} %{x8664}
23 BuildRequires:  yasm >= 0.6.0
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # encoder/macroblock.c breaks strict-aliasing rules
28 %define         specflags       -fno-strict-aliasing
29
30 %description
31 libx264 library for encoding H264 video format.
32
33 %description -l pl.UTF-8
34 Biblioteka libx264 do kodowania w formacie obrazu H264.
35
36 %package devel
37 Summary:        Header files for x264 library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for x264 library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki x264.
47
48 %package static
49 Summary:        Static x264 library
50 Summary(pl.UTF-8):      Statyczna biblioteka x264
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static x264 library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka x264.
59
60 %package gtk
61 Summary:        x264 GTK+ configuration interface library
62 Summary(pl.UTF-8):      Biblioteka interfejsu konfiguracyjnego GTK+ dla x264
63 Group:          X11/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Conflicts:      libx264-gui < 0.1.2-1.20080816_2245.2
66
67 %description gtk
68 x264 GTK+ configuration interface library.
69
70 %description gtk -l pl.UTF-8
71 Biblioteka interfejsu konfiguracyjnego GTK+ dla x264.
72
73 %package gtk-devel
74 Summary:        Header files for x264gtk library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264gtk
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78 Requires:       %{name}-gtk = %{version}-%{release}
79
80 %description gtk-devel
81 Header files for x264gtk library.
82
83 %description gtk-devel -l pl.UTF-8
84 Pliki nagłówkowe biblioteki x264gtk.
85
86 %package gtk-static
87 Summary:        Static x264gtk library
88 Summary(pl.UTF-8):      Statyczna biblioteka x264gtk
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-gtk-devel = %{version}-%{release}
91
92 %description gtk-static
93 Static x264gtk library.
94
95 %description gtk-static -l pl.UTF-8
96 Statyczna biblioteka x264gtk.
97
98 %package gui
99 Summary:        Encoding GUI for x264
100 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do kodera x264
101 Group:          X11/Applications/Multimedia
102 Requires:       %{name}-gtk = %{version}-%{release}
103
104 %description gui
105 Encoding GUI for x264.
106
107 %description gui -l pl.UTF-8
108 Graficzny interfejs użytkownika do kodera x264.
109
110 %prep
111 %setup -q -n x264-snapshot-%{snap}-%{snaph}
112 %patch0 -p1
113 %patch1 -p1
114 sed -i 's:-O4::g' configure
115
116 %build
117 CC="%{__cc}" \
118 ./configure \
119         --prefix=%{_prefix} \
120         --exec-prefix=%{_prefix} \
121         --bindir=%{_bindir} \
122         --includedir=%{_includedir} \
123         --libdir=%{_libdir} \
124         --extra-cflags="%{rpmcflags}" \
125         --enable-gtk \
126         --enable-pic \
127         --enable-shared
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %find_lang x264_gtk
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS
148 %attr(755,root,root) %{_bindir}/x264
149 %attr(755,root,root) %{_libdir}/libx264.so.60
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libx264.so
154 %{_includedir}/x264.h
155 %{_pkgconfigdir}/x264.pc
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libx264.a
160
161 %files gtk -f x264_gtk.lang
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libx264gtk.so.60
164 %{_datadir}/x264
165
166 %files gtk-devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libx264gtk.so
169 %{_includedir}/x264_gtk*.h
170 %{_pkgconfigdir}/x264gtk.pc
171
172 %files gtk-static
173 %defattr(644,root,root,755)
174 %{_libdir}/libx264gtk.a
175
176 %files gui
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/x264_gtk_encode
This page took 0.060816 seconds and 4 git commands to generate.