]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- tabs.
[packages/libx264.git] / libx264.spec
1 Summary:        H264 encoder library
2 Summary(pl):    Biblioteka koduj±ca H264
3 Name:           libx264
4 Version:        0.1.2
5 %define snap    20060430
6 %define snaph   2245
7 Release:        1.%{snap}_%{snaph}.1
8 License:        GPL v2
9 Group:          Libraries
10 # unofficial, debianized/libtoolized packaging:
11 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
12 # but it's too old, so use snapshots...
13 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
14 # Source0-md5:  667c760dda91e9a3f50186d4676b5d5a
15 #Patch0:                %{name}-acam.patch
16 Patch1:         %{name}-liblink.patch
17 URL:            http://developers.videolan.org/x264.html
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 %ifarch %{ix86}
22 BuildRequires:  nasm
23 %endif
24 BuildRequires:  sed >= 4.0
25 %ifarch %{x8664}
26 BuildRequires:  yasm
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # encoder/macroblock.c breaks strict-aliasing rules
31 %define         specflags       -fno-strict-aliasing
32
33 %description
34 libx264 library for encoding H264 video format.
35
36 %description -l pl
37 Biblioteka libx264 do kodowania w formacie obrazu H264.
38
39 %package devel
40 Summary:        Header files for x264 library
41 Summary(pl):    Pliki nag³ówkowe biblioteki x264
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for x264 library.
47
48 %description devel -l pl
49 Pliki nag³ówkowe biblioteki x264.
50
51 %package static
52 Summary:        Static x264 library
53 Summary(pl):    Statyczna biblioteka x264
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static x264 library.
59
60 %description static -l pl
61 Statyczna biblioteka x264.
62
63 %prep
64 %setup -q -n x264-snapshot-%{snap}-%{snaph}
65 #%patch0 -p1
66 %patch1 -p0
67 sed -i 's:-O4::g' configure
68
69 %build
70 ./configure \
71         --prefix=%{_prefix} \
72         --exec-prefix=%{_prefix} \
73         --bindir=%{_bindir} \
74         --includedir=%{_includedir} \
75         --libdir=%{_libdir} \
76         --extra-cflags="%{rpmcflags}" \
77         --enable-shared
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS
96 %attr(755,root,root) %{_bindir}/x264
97 %attr(755,root,root) %{_libdir}/libx264.so.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libx264.so
102 %{_includedir}/x264.h
103 %{_pkgconfigdir}/x264.pc
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libx264.a
This page took 0.076504 seconds and 3 git commands to generate.