]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- rel .3
[packages/libx264.git] / libx264.spec
1 %define         snap    20080816
2 %define         snaph   2245
3 %define         rel     3
4 Summary:        H264 encoder library
5 Summary(pl.UTF-8):      Biblioteka kodująca H264
6 Name:           libx264
7 Version:        0.1.2
8 Release:        1.%{snap}_%{snaph}.%{rel}
9 License:        GPL v2+
10 Group:          Libraries
11 # unofficial, debianized/libtoolized packaging:
12 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
13 # but it's too old, so use snapshots...
14 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
15 # Source0-md5:  0a188b8e13c62f6a97eba1c5d4ab3a3f
16 Patch0:         %{name}-alpha.patch
17 URL:            http://www.videolan.org/developers/x264.html
18 BuildRequires:  gettext-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  pkgconfig
21 %ifarch %{ix86} %{x8664}
22 BuildRequires:  yasm >= 0.6.0
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # encoder/macroblock.c breaks strict-aliasing rules
27 %define         specflags       -fno-strict-aliasing
28
29 %description
30 libx264 library for encoding H264 video format.
31
32 %description -l pl.UTF-8
33 Biblioteka libx264 do kodowania w formacie obrazu H264.
34
35 %package devel
36 Summary:        Header files for x264 library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for x264 library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki x264.
46
47 %package static
48 Summary:        Static x264 library
49 Summary(pl.UTF-8):      Statyczna biblioteka x264
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static x264 library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka x264.
58
59 %package gtk
60 Summary:        x264 GTK+ configuration interface library
61 Summary(pl.UTF-8):      Biblioteka interfejsu konfiguracyjnego GTK+ dla x264
62 Group:          X11/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Conflicts:      libx264-gui < 0.1.2-1.20080816_2245.2
65
66 %description gtk
67 x264 GTK+ configuration interface library.
68
69 %description gtk -l pl.UTF-8
70 Biblioteka interfejsu konfiguracyjnego GTK+ dla x264.
71
72 %package gtk-devel
73 Summary:        Header files for x264gtk library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264gtk
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Requires:       %{name}-gtk = %{version}-%{release}
78
79 %description gtk-devel
80 Header files for x264gtk library.
81
82 %description gtk-devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki x264gtk.
84
85 %package gtk-static
86 Summary:        Static x264gtk library
87 Summary(pl.UTF-8):      Statyczna biblioteka x264gtk
88 Group:          X11/Development/Libraries
89 Requires:       %{name}-gtk-devel = %{version}-%{release}
90
91 %description gtk-static
92 Static x264gtk library.
93
94 %description gtk-static -l pl.UTF-8
95 Statyczna biblioteka x264gtk.
96
97 %package gui
98 Summary:        Encoding GUI for x264
99 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do kodera x264
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name}-gtk = %{version}-%{release}
102
103 %description gui
104 Encoding GUI for x264.
105
106 %description gui -l pl.UTF-8
107 Graficzny interfejs użytkownika do kodera x264.
108
109 %prep
110 %setup -q -n x264-snapshot-%{snap}-%{snaph}
111 %patch0 -p1
112 sed -i 's:-O4::g' configure
113
114 %build
115 CC="%{__cc}" \
116 ./configure \
117         --prefix=%{_prefix} \
118         --exec-prefix=%{_prefix} \
119         --bindir=%{_bindir} \
120         --includedir=%{_includedir} \
121         --libdir=%{_libdir} \
122         --extra-cflags="%{rpmcflags}" \
123         --enable-gtk \
124         --enable-pic \
125         --enable-shared
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %find_lang x264_gtk
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS
146 %attr(755,root,root) %{_bindir}/x264
147 %attr(755,root,root) %{_libdir}/libx264.so.60
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libx264.so
152 %{_includedir}/x264.h
153 %{_pkgconfigdir}/x264.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libx264.a
158
159 %files gtk -f x264_gtk.lang
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libx264gtk.so.60
162 %{_datadir}/x264
163
164 %files gtk-devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libx264gtk.so
167 %{_includedir}/x264_gtk*.h
168 %{_pkgconfigdir}/x264gtk.pc
169
170 %files gtk-static
171 %defattr(644,root,root,755)
172 %{_libdir}/libx264gtk.a
173
174 %files gui
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/x264_gtk_encode
This page took 0.085243 seconds and 3 git commands to generate.