]> git.pld-linux.org Git - packages/libutempter.git/blob - libutempter.spec
- added Group(pl)
[packages/libutempter.git] / libutempter.spec
1 Summary:        Privledged helper for utmp/wtmp updates
2 Name:           utempter
3 Version:        0.5
4 Release:        2
5 Copyright:      MIT
6 Group:          Base
7 Group(pl):      Podstawy
8 Source:         %{name}-%{version}.tar.gz
9 Prereq:         /usr/sbin/groupadd, fileutils
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %description
13 Utempter is a utility which allows programs to log information to a
14 privledged file (/var/run/utmp), without compromising system security. It
15 accomplishes this task by acting as a buffer between root and the programs.
16
17 %package devel
18 Summary:        utempter library header files
19 Group:          Development/Libraties
20 Group(pl):      Programowanie/Biblioteki
21 Requires:       %{name} = %{version}
22
23 %description devel
24 utempter library header files.
25
26 %prep
27 %setup -q
28
29 %build
30 make
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 make PREFIX=$RPM_BUILD_ROOT install
35
36 strip --strip-unneeded $RPM_BUILD_ROOT/usr/{lib/lib*.so.*.*,sbin/*}
37
38 %pre 
39 /usr/sbin/groupadd -r -f utmp
40
41 %post
42 /sbin/ldconfig
43
44 if [ -f /var/log/wtmp ]; then
45     chown root.utmp /var/log/wtmp
46     chmod 664 /var/log/wtmp
47 fi
48
49 if [ -f /var/run/utmp ]; then
50     chown root.utmp /var/run/utmp
51     chmod 664 /var/run/utmp
52 fi
53
54 %postun -p /sbin/ldconfig
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(2755,root,utmp) /usr/sbin/utempter
62 %attr(0755,root,root) /usr/lib/lib*.so.*.*
63
64 %files devel
65 %defattr(644,root,root,755)
66 %attr(0755,root,root) /usr/lib/lib*.so
67 /usr/include/utempter.h
68
69 %changelog
70 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
71   [0.5-2]
72 - added -q %setup parameter,
73 - added stripping shared library and binaries,
74 - added devel subpackage,
75 - removed /sbin/ldconfig from Prereq (this is automatically generated).
This page took 0.09092 seconds and 3 git commands to generate.