]> git.pld-linux.org Git - packages/libtirpc.git/blob - libtirpc.spec
- drop unneeded and unused patches (libtirpc no longer require NIS)
[packages/libtirpc.git] / libtirpc.spec
1 #
2 # Conditional build:
3 %bcond_with     gssglue         # build with MIT Kerberos instead of Heimdal
4 #
5 Summary:        Transport Independent RPC Library
6 Summary(pl.UTF-8):      Biblioteka RPC niezależnego od transportu
7 Name:           libtirpc
8 Version:        0.2.3
9 Release:        1
10 Epoch:          1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b70e6c12a369a91e69fcc3b9feb23d61
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-heimdal.patch
17 URL:            http://sourceforge.net/projects/libtirpc/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  glibc >= 6:2.14-9.1
21 %if %{with gssglue}
22 BuildRequires:  libgssglue-devel >= 0.1
23 %else
24 BuildRequires:  heimdal-devel
25 %endif
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 %if %{with gssglue}
29 Requires:       libgssglue >= 0.1
30 %else
31 Requires:       heimdal-libs
32 %endif
33 Requires:       glibc >= 6:2.14-9.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # FIXME: this allows invalid (unresolved symbols) library to be installed.
37 # Left until upstream fixes this properly.
38 %define no_install_post_check_so        1
39
40 %description
41 This package contains SunLib's implementation of transport-independent
42 RPC (TI-RPC) documentation. This library forms a piece of the base of
43 Open Network Computing (ONC), and is derived directly from the Solaris
44 2.3 source.
45
46 TI-RPC is an enhanced version of TS-RPC that requires the UNIX System
47 V Transport Layer Interface (TLI) or an equivalent X/Open Transport
48 Interface (XTI). TI-RPC is on-the-wire compatible with the TS-RPC,
49 which is supported by almost 70 vendors on all major operating
50 systems. TS-RPC source code (RPCSRC 4.0) remains available from
51 several Internet sites.
52
53 %description -l pl.UTF-8
54 Ten pakiet zawiera implementację SunLib RPC niezależnego od transportu
55 (TI-RPC). Ta biblioteka tworzy element podstawy dla ONC (Open Network
56 Computing) i wywodzi się bezpośrednio ze źródeł Solarisa 2.3.
57
58 TI-RPC to rozszerzona wersja TS-RPC wymagająca TLI (UNIX System V
59 Transport Layer Interface). Jest kompatybilna w locie z TS-RPC,
60 obsługiwanym przez prawie 70 producentów dla wszystkich znaczących
61 systemów operacyjnych. Kod źródłowy TS-RPC (RPCSRC 4.0) pozostaje
62 dostępny z różnych stron internetowych.
63
64 %package devel
65 Summary:        Development files for the TI-RPC library
66 Summary(pl.UTF-8):      Pliki programistyczne biblioteki TI-RPC
67 Group:          Development/Libraries
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69 Requires:       glibc-devel >= 6:2.14-9.1
70 %if %{with gssglue}
71 Requires:       libgssglue-devel >= 0.1
72 %else
73 Requires:       heimdal-devel
74 %endif
75
76 %description devel
77 This package includes header files necessary for developing programs
78 which use the TI-RPC library.
79
80 %description devel -l pl.UTF-8
81 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
82 wykorzystujących bibliotekę TI-RPC.
83
84 %package static
85 Summary:        Static TI-RPC library
86 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
89
90 %description static
91 This package includes static TI-RPC library.
92
93 %description static -l pl.UTF-8
94 Ten pakiet zawiera statyczną bibliotekę TI-RPC.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --enable-gss=%{?with_gssglue:libgssglue}%{!?with_gssglue:heimdal-gssapi}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/%{_lib},%{_mandir}/man{3,5}}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__make} -C doc install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 mv -f $RPM_BUILD_ROOT%{_libdir}/libtirpc.so.* $RPM_BUILD_ROOT/%{_lib}
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
124 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
125         $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
126
127 # obsoleted by pkgconfig
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS README
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
140 %attr(755,root,root) /%{_lib}/libtirpc.so.*.*
141 %attr(755,root,root) %ghost /%{_lib}/libtirpc.so.1
142 %{_mandir}/man5/netconfig.5*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libtirpc.so
147 %{_includedir}/tirpc
148 %{_pkgconfigdir}/libtirpc.pc
149 %{_mandir}/man3/bindresvport.3t*
150 %{_mandir}/man3/des_crypt.3t*
151 %{_mandir}/man3/getnet*.3t*
152 %{_mandir}/man3/getrpc*.3t*
153 %{_mandir}/man3/rpc*.3t*
154 %{_mandir}/man3/rtime.3t*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libtirpc.a
This page took 0.072766 seconds and 4 git commands to generate.