]> git.pld-linux.org Git - packages/libtirpc.git/blob - libtirpc.spec
- added glibc-2.14 patch which adds some symbols no longer available from glibc ...
[packages/libtirpc.git] / libtirpc.spec
1 #
2 # Conditional build:
3 %bcond_with     gssglue         # build with MIT Kerberos instead of Heimdal
4 #
5 Summary:        Transport Independent RPC Library
6 Summary(pl.UTF-8):      Biblioteka RPC niezależnego od transportu
7 Name:           libtirpc
8 Version:        0.2.2
9 Release:        1.2
10 Epoch:          1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  74c41c15c2909f7d11d9c7bfa7db6273
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-heimdal.patch
17 Patch2:         %{name}-XDR_GETPOS.patch
18 Patch3:         %{name}-rpc-des-prot.patch
19 Patch4:         %{name}-nis.patch
20 Patch5:         %{name}-glibc-2.14.patch
21 URL:            http://sourceforge.net/projects/libtirpc/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  glibc >= 6:2.14
25 %if %{with gssglue}
26 BuildRequires:  libgssglue-devel >= 0.1
27 %else
28 BuildRequires:  heimdal-devel
29 %endif
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 %if %{with gssglue}
33 Requires:       libgssglue >= 0.1
34 %else
35 Requires:       heimdal-libs
36 %endif
37 Requires:       glibc >= 6:2.14
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # FIXME: this allows invalid (unresolved symbols) library to be installed.
41 # Left until upstream fixes this properly.
42 %define no_install_post_check_so        1
43
44 %description
45 This package contains SunLib's implementation of transport-independent
46 RPC (TI-RPC) documentation. This library forms a piece of the base of
47 Open Network Computing (ONC), and is derived directly from the Solaris
48 2.3 source.
49
50 TI-RPC is an enhanced version of TS-RPC that requires the UNIX System
51 V Transport Layer Interface (TLI) or an equivalent X/Open Transport
52 Interface (XTI). TI-RPC is on-the-wire compatible with the TS-RPC,
53 which is supported by almost 70 vendors on all major operating
54 systems. TS-RPC source code (RPCSRC 4.0) remains available from
55 several Internet sites.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera implementację SunLib RPC niezależnego od transportu
59 (TI-RPC). Ta biblioteka tworzy element podstawy dla ONC (Open Network
60 Computing) i wywodzi się bezpośrednio ze źródeł Solarisa 2.3.
61
62 TI-RPC to rozszerzona wersja TS-RPC wymagająca TLI (UNIX System V
63 Transport Layer Interface). Jest kompatybilna w locie z TS-RPC,
64 obsługiwanym przez prawie 70 producentów dla wszystkich znaczących
65 systemów operacyjnych. Kod źródłowy TS-RPC (RPCSRC 4.0) pozostaje
66 dostępny z różnych stron internetowych.
67
68 %package devel
69 Summary:        Development files for the TI-RPC library
70 Summary(pl.UTF-8):      Pliki programistyczne biblioteki TI-RPC
71 Group:          Development/Libraries
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73 Requires:       glibc-devel >= 6:2.14
74 %if %{with gssglue}
75 Requires:       libgssglue-devel >= 0.1
76 %else
77 Requires:       heimdal-devel
78 %endif
79
80 %description devel
81 This package includes header files necessary for developing programs
82 which use the TI-RPC library.
83
84 %description devel -l pl.UTF-8
85 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
86 wykorzystujących bibliotekę TI-RPC.
87
88 %package static
89 Summary:        Static TI-RPC library
90 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
93
94 %description static
95 This package includes static TI-RPC library.
96
97 %description static -l pl.UTF-8
98 Ten pakiet zawiera statyczną bibliotekę TI-RPC.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         --enable-gss=%{?with_gssglue:libgssglue}%{!?with_gssglue:heimdal-gssapi}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/%{_lib},%{_mandir}/man{3,5}}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__make} -C doc install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 mv -f $RPM_BUILD_ROOT%{_libdir}/libtirpc.so.* $RPM_BUILD_ROOT/%{_lib}
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
132 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
133         $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
134
135 # rpc headers for glibc 2.14+
136 install -d $RPM_BUILD_ROOT%{_includedir}/rpc
137 ln -s tirpc/netconfig.h $RPM_BUILD_ROOT%{_includedir}/netconfig.h
138 for i in $RPM_BUILD_ROOT%{_includedir}/tirpc/rpc/*.h; do
139         i="$(basename $i)"
140         ln -s ../tirpc/rpc/$i $RPM_BUILD_ROOT%{_includedir}/rpc/$i
141 done
142
143 # obsoleted by pkgconfig
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.la
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
156 %attr(755,root,root) /%{_lib}/libtirpc.so.*.*
157 %attr(755,root,root) %ghost /%{_lib}/libtirpc.so.1
158 %{_mandir}/man5/netconfig.5*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libtirpc.so
163 %{_includedir}/netconfig.h
164 %{_includedir}/rpc/*.h
165 %{_includedir}/tirpc
166 %{_pkgconfigdir}/libtirpc.pc
167 %{_mandir}/man3/bindresvport.3t*
168 %{_mandir}/man3/des_crypt.3t*
169 %{_mandir}/man3/getnet*.3t*
170 %{_mandir}/man3/getrpc*.3t*
171 %{_mandir}/man3/rpc*.3t*
172 %{_mandir}/man3/rtime.3t*
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libtirpc.a
This page took 0.061092 seconds and 4 git commands to generate.