]> git.pld-linux.org Git - SPECS.git/blob - libthreadar.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / libthreadar.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        C++ classes to work with threads
7 Summary(pl.UTF-8):      Klasy C++ do pracy z wątkami
8 Name:           libthreadar
9 Version:        1.4.0
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        https://downloads.sourceforge.net/libthreadar/%{name}-%{version}.tar.gz
14 # Source0-md5:  88c53a1981d91c22e56e122c609e1c11
15 URL:            https://libthreadar.sourceforge.net/
16 BuildRequires:  autoconf >= 2.69
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 2:1.5
19 %{?with_apidocs:BuildRequires:  doxygen >= 1.3}
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  rpm-build >= 4.6
22 BuildRequires:  sed >= 4.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libthreadar provides C++ classes for manipulating threads and
27 propagating back exception from thread to parent thread when the
28 parent calls the join() method.
29
30 %description -l pl.UTF-8
31 Biblioteka libthreadar dostarcza klasy C++ do operowania na wątkach i
32 propagowania wyjątków z wątku do wątku rodzica, kiedy rodzic wywołuje
33 metodę join().
34
35 %package devel
36 Summary:        Header files for libthreadar library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libthreadar
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       libstdc++-devel >= 6:4.7
41
42 %description devel
43 Header files for libthreadar library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki libthreadar.
47
48 %package static
49 Summary:        Static libthreadar library
50 Summary(pl.UTF-8):      Statyczna biblioteka libthreadar
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static libthreadar library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libthreadar.
59
60 %package apidocs
61 Summary:        API documentation for libthreadar library
62 Summary(pl.UTF-8):      Dokumentacja API biblioteki libthreadar
63 Group:          Documentation
64 BuildArch:      noarch
65
66 %description apidocs
67 API documentation for libthreadar library.
68
69 %description apidocs -l pl.UTF-8
70 Dokumentacja API biblioteki libthreadar.
71
72 %prep
73 %setup -q
74
75 # don't use static linking
76 %{__sed} -i -e '/ = -all-static$/d' doc/examples/Makefile.am
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         %{!?with_apidocs:--disable-build-html} \
86         %{!?with_static_libs:--disable-static}
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # obsoleted by pkg-config
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libthreadar.la
97
98 # packaged as %doc in -apidocs
99 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/libthreadar/{README,html}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS README
110 %attr(755,root,root) %{_libdir}/libthreadar.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libthreadar.so.1000
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libthreadar.so
116 %{_includedir}/libthreadar
117 %{_pkgconfigdir}/libthreadar.pc
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libthreadar.a
123 %endif
124
125 %if %{with apidocs}
126 %files apidocs
127 %defattr(644,root,root,755)
128 %doc doc/html/{search,*.css,*.html,*.js,*.png}
129 %endif
This page took 0.125844 seconds and 3 git commands to generate.