]> git.pld-linux.org Git - packages/libtheora.git/blob - libtheora.spec
- x32 rebuild
[packages/libtheora.git] / libtheora.spec
1 #
2 # Conditional build:
3 %if "%{pld_release}" == "ac"
4 %bcond_with             apidocs         # do not build and package API docs
5 %else
6 %bcond_without  apidocs         # do not build and package API docs
7 %endif
8
9 Summary:        Theora - video codec intended for use within Ogg multimedia streaming system
10 Summary(pl.UTF-8):      Theora - kodek obrazu do używania w systemie strumieni multimedialnych Ogg
11 Name:           libtheora
12 Version:        1.1.1
13 Release:        3
14 License:        BSD-like
15 Group:          Libraries
16 Source0:        http://downloads.xiph.org/releases/theora/%{name}-%{version}.tar.bz2
17 # Source0-md5:  292ab65cedd5021d6b7ddd117e07cd8e
18 Patch0:         link.patch
19 Patch1:         libpng16.patch
20 URL:            http://www.theora.org/
21 BuildRequires:  SDL-devel
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  libogg-devel >= 2:1.1
25 BuildRequires:  libtool
26 BuildRequires:  libvorbis-devel >= 1:1.0.1
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm >= 4.4.9-56
29 %if %{with apidocs}
30 BuildRequires:  doxygen
31 BuildRequires:  tetex-format-pdflatex
32 BuildRequires:  tetex-latex-bibtex
33 BuildRequires:  tetex-latex-ltablex
34 BuildRequires:  transfig
35 %endif
36 Requires:       libogg >= 2:1.1
37 Requires:       libvorbis >= 1:1.0.1
38 Provides:       libtheora-mmx
39 Obsoletes:      libtheora-mmx
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         no_install_post_check_so        1
43
44 %description
45 Theora is Xiph.Org's first publicly released video codec, intended for
46 use within the Ogg's project's Ogg multimedia streaming system. Theora
47 is derived directly from On2's VP3 codec; Currently the two are nearly
48 identical, varying only in framing headers, but Theora will diverge
49 and improve from the main VP3 development lineage as time progresses.
50
51 %description -l pl.UTF-8
52 Theora to pierwszy publicznie wypuszczony przez Xiph.Org kodek obrazu,
53 mający być używany w systemie strumieni multimedialnych Ogg. Theora
54 wywodzi się bezpośrednio z kodeka VP3 On2. Aktualnie oba są prawie
55 identyczne, różnią się jedynie nagłówkami ramek, ale Theora będzie się
56 coraz bardziej rozwijać w stosunku do VP3.
57
58 %package devel
59 Summary:        Header files for Theora library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Theora
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libogg-devel >= 2:1.1
64 Provides:       libtheora-mmx-devel
65 Obsoletes:      libtheora-mmx-devel
66
67 %description devel
68 Header files for Theora library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki Theora.
72
73 %package static
74 Summary:        Static Theora library
75 Summary(pl.UTF-8):      Statyczna biblioteka Theora
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78 Provides:       libtheora-mmx-static
79 Obsoletes:      libtheora-mmx-static
80
81 %description static
82 Static Theora library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka Theora.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 %configure
98
99 %{__make}
100 %if %{with apidocs}
101 %{__make} -C doc/spec
102 %endif
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} -j1 install \
108         DESTDIR=$RPM_BUILD_ROOT \
109         docdir=%{_docdir}/libtheora-docs
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS CHANGES COPYING LICENSE README
120 %attr(755,root,root) %{_libdir}/libtheora.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libtheora.so.0
122 %attr(755,root,root) %{_libdir}/libtheoradec.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libtheoradec.so.1
124 %attr(755,root,root) %{_libdir}/libtheoraenc.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libtheoraenc.so.1
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc doc/{color.html,draft-ietf-avt-rtp-theora-00.txt,vp3-format.txt} doc/libtheora/html doc/spec/Theora.pdf
130 %attr(755,root,root) %{_libdir}/libtheora.so
131 %attr(755,root,root) %{_libdir}/libtheoradec.so
132 %attr(755,root,root) %{_libdir}/libtheoraenc.so
133 %{_libdir}/libtheora.la
134 %{_libdir}/libtheoradec.la
135 %{_libdir}/libtheoraenc.la
136 %{_includedir}/theora
137 %{_pkgconfigdir}/theora.pc
138 %{_pkgconfigdir}/theoradec.pc
139 %{_pkgconfigdir}/theoraenc.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libtheora.a
144 %{_libdir}/libtheoradec.a
145 %{_libdir}/libtheoraenc.a
This page took 0.294231 seconds and 3 git commands to generate.