]> git.pld-linux.org Git - SPECS.git/blob - libtasn1.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libtasn1.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        ASN.1 library used in GNUTLS
7 Summary(pl.UTF-8):      Biblioteka ASN.1 używana w GNUTLS
8 Name:           libtasn1
9 Version:        4.17.0
10 Release:        1
11 License:        LGPL v2.1+ (library), GPL v3+ (tools)
12 Group:          Libraries
13 Source0:        https://ftp.gnu.org/gnu/libtasn1/%{name}-%{version}.tar.gz
14 # Source0-md5:  c46f6eb3bd1287031ae5d36465094402
15 Patch0:         %{name}-info.patch
16 URL:            http://www.gnu.org/software/libtasn1/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.4}
21 BuildRequires:  gtk-doc-automake >= 1.4
22 BuildRequires:  help2man
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  rpmbuild(macros) >= 1.98
27 BuildRequires:  texinfo
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Library 'libasn1' developed for ASN1 (Abstract Syntax Notation One)
32 structures management. The main features of this library are:
33 - on line ASN1 structure management that doesn't require any C code
34   file generation.
35 - off line ASN1 structure management with C code file generation
36   containing an array.
37 - DER (Distinguish Encoding Rules) encoding
38 - no limits for INTEGER and ENUMERATED values
39
40 %description -l pl.UTF-8
41 Biblioteka libasn1 stworzona do zarządzania strukturami ASN1 (Abstract
42 Syntax Notation One). Główne cechy biblioteki to:
43 - zarządzanie strukturami ASN1 w sposób nie wymagający generowania
44   plików z kodem w C
45 - zarządzanie strukturami ASN1 w sposób umożliwiający generowanie
46   plików z kodem w C
47 - kodowanie DER (Distinguish Encoding Rules)
48 - brak limitów dla wartości INTEGER oraz ENUMERATED
49
50 %package devel
51 Summary:        Header files etc to develop libtasn1 applications
52 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do libtasn1
53 License:        LGPL v2.1+
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 Header files etc to develop libtasn1 applications.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe i inne do libtasn1.
62
63 %package static
64 Summary:        Static libtasn1 library
65 Summary(pl.UTF-8):      Biblioteka statyczna libtasn1
66 License:        LGPL v2.1+
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static libtasn1 library.
72
73 %description static -l pl.UTF-8
74 Biblioteka statyczna libtasn1.
75
76 %package apidocs
77 Summary:        libtasn1 API documentation
78 Summary(pl.UTF-8):      Dokumentacja API libtasn1
79 Group:          Documentation
80 Requires:       gtk-doc-common
81 Conflicts:      libtasn1-devel < 0.3.9-2
82 BuildArch:      noarch
83
84 %description apidocs
85 libtasn1 API documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API libtasn1.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 %{?with_apidocs:%{__gtkdocize}}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --enable-gtk-doc%{!?with_apidocs:=no} \
103         --disable-silent-rules \
104         %{!?with_static_libs:--disable-static} \
105         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
106         --with-packager="PLD/Linux" \
107         --with-packager-bug-reports="http://bugs.pld-linux.org/"
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %post   devel -p /sbin/postshell
126 -/usr/sbin/fix-info-dir -c %{_infodir}
127
128 %postun devel -p /sbin/postshell
129 -/usr/sbin/fix-info-dir -c %{_infodir}
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README.md THANKS doc/*.html
134 %attr(755,root,root) %{_bindir}/asn1*
135 %attr(755,root,root) %{_libdir}/libtasn1.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libtasn1.so.6
137 %{_mandir}/man1/asn1*.1*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libtasn1.so
142 %{_libdir}/libtasn1.la
143 %{_includedir}/libtasn1.h
144 %{_pkgconfigdir}/libtasn1.pc
145 %{_infodir}/libtasn1.info*
146 %{_mandir}/man3/asn1_*.3*
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libtasn1.a
152 %endif
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_gtkdocdir}/%{name}
158 %endif
This page took 0.319037 seconds and 3 git commands to generate.