]> git.pld-linux.org Git - packages/libsmraw.git/blob - libsmraw.spec
- release 3 (by relup.sh)
[packages/libsmraw.git] / libsmraw.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python bindings
4 #
5 Summary:        Library to access the storage media (SM) (split) RAW format
6 Summary(pl.UTF-8):      Biblioteka służąca do dostępu do surowego (dzielonego) formatu nośnika danych (SM)
7 Name:           libsmraw
8 Version:        20150105
9 Release:        3
10 License:        LGPL v3+
11 Group:          Libraries
12 Source0:        https://github.com/libyal/libsmraw/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  0f40bc041ec5d22083cee46091ef6205
14 Patch0:         %{name}-system-libs.patch
15 URL:            https://github.com/libyal/libsmraw/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  gettext-tools >= 0.18.1
19 BuildRequires:  libbfio-devel >= 20120426
20 BuildRequires:  libcdata-devel >= 20150102
21 BuildRequires:  libcerror-devel >= 20120425
22 BuildRequires:  libcfile-devel >= 20140503
23 BuildRequires:  libclocale-devel >= 20120425
24 BuildRequires:  libcnotify-devel >= 20120425
25 BuildRequires:  libcpath-devel >= 20120701
26 BuildRequires:  libcsplit-devel >= 20120701
27 BuildRequires:  libcstring-devel >= 20120425
28 BuildRequires:  libcsystem-devel >= 20141018
29 BuildRequires:  libcthreads-devel >= 20130509
30 BuildRequires:  libfcache-devel >= 20140601
31 BuildRequires:  libfdata-devel >= 20140915
32 BuildRequires:  libfuse-devel >= 2.6
33 BuildRequires:  libfvalue-devel >= 20130415
34 BuildRequires:  libhmac-devel >= 20130714
35 BuildRequires:  libuna-devel >= 20120425
36 BuildRequires:  libtool
37 BuildRequires:  openssl-devel >= 1.0
38 BuildRequires:  pkgconfig
39 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
40 BuildRequires:  sed >= 4.0
41 Requires:       libbfio >= 20120426
42 Requires:       libcdata >= 20150102
43 Requires:       libcerror >= 20120425
44 Requires:       libcfile >= 20140503
45 Requires:       libclocale >= 20120425
46 Requires:       libcnotify >= 20120425
47 Requires:       libcpath >= 20120701
48 Requires:       libcsplit >= 20120701
49 Requires:       libcstring >= 20120425
50 Requires:       libcthreads >= 20130509
51 Requires:       libfcache >= 20140601
52 Requires:       libfdata >= 20140915
53 Requires:       libfvalue >= 20130415
54 Requires:       libuna >= 20120425
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 libsmraw is a library to access the storage media (SM) (split) RAW
59 format.
60
61 %description -l pl.UTF-8
62 libsmraw to biblioteka służąca do dostępu do surowego (dzielonego)
63 formatu nośnika danych (SM - Storage Media).
64
65 %package devel
66 Summary:        Header files for libsmraw library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsmraw
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       libbfio-devel >= 20120426
71 Requires:       libcdata-devel >= 20150102
72 Requires:       libcerror-devel >= 20120425
73 Requires:       libcfile-devel >= 20140503
74 Requires:       libclocale-devel >= 20120425
75 Requires:       libcnotify-devel >= 20120425
76 Requires:       libcpath-devel >= 20120701
77 Requires:       libcsplit-devel >= 20120701
78 Requires:       libcstring-devel >= 20120425
79 Requires:       libcthreads-devel >= 20130509
80 Requires:       libfcache-devel >= 20140601
81 Requires:       libfdata-devel >= 20140915
82 Requires:       libfvalue-devel >= 20130415
83 Requires:       libuna-devel >= 20120425
84
85 %description devel
86 Header files for libsmraw library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki libsmraw.
90
91 %package static
92 Summary:        Static libsmraw library
93 Summary(pl.UTF-8):      Statyczna biblioteka libsmraw
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static libsmraw library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka libsmraw.
102
103 %package tools
104 Summary:        Tools for libsmraw library
105 Summary(pl.UTF-8):      Narzędzia do biblioteki smraw
106 Group:          Applications/System
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       libcsystem >= 20141018
109 Requires:       libfuse >= 2.6
110 Requires:       libhmac >= 20130714
111
112 %description tools
113 Tools for libsmraw library.
114
115 %description tools -l pl.UTF-8
116 Narzędzia do biblioteki smraw.
117
118 %package -n python-pysmraw
119 Summary:        Python bindings for libsmraw library
120 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libsmraw
121 Group:          Libraries/Python
122 Requires:       %{name} = %{version}-%{release}
123
124 %description -n python-pysmraw
125 Python bindings for libsmraw library.
126
127 %description -n python-pysmraw -l pl.UTF-8
128 Wiązania Pythona do biblioteki libsmraw.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 %{__gettextize}
136 %{__sed} -i -e 's/ po\/Makefile.in//' configure.ac
137 %{__libtoolize}
138 %{__aclocal} -I m4
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         %{?with_python:--enable-python}
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # obsoleted by pkg-config
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsmraw.la
154
155 %if %{with python}
156 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/pysmraw.{la,a}
157 %endif
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog README
168 %attr(755,root,root) %{_libdir}/libsmraw.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libsmraw.so.1
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libsmraw.so
174 %{_includedir}/libsmraw
175 %{_includedir}/libsmraw.h
176 %{_pkgconfigdir}/libsmraw.pc
177 %{_mandir}/man3/libsmraw.3*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libsmraw.a
182
183 %files tools
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/smrawmount
186 %attr(755,root,root) %{_bindir}/smrawverify
187 %{_mandir}/man1/smrawmount.1*
188
189 %if %{with python}
190 %files -n python-pysmraw
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{py_sitedir}/pysmraw.so
193 %endif
This page took 0.104158 seconds and 4 git commands to generate.