]> git.pld-linux.org Git - packages/libsmi.git/blob - libsmi.spec
- fixed %doc list.
[packages/libsmi.git] / libsmi.spec
1 Summary:        Structure of Management Information library
2 Name:           libsmi
3 Version:        0.2
4 Release:        1
5 Copyright:      distributable (see COPYING file)
6 Group:          Libraries
7 Group(pl):      Biblioteki
8 Source:         ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/%{name}-%{version}.tar.gz
9 URL:            http://www.ibr.cs.tu-bs.de/projects/libsmi/
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %define         _prefix         /usr
13
14 %description
15 Libsmi is a C library that allows network management applications to access
16 MIB module information through a well defined API that hides the nasty
17 details of locating and parsing SMIv1/v2 MIB modules.
18
19 Libsmi supports exact and iterative retrieval functions for all major SMIv1
20 and SMIv2 constructs (except the AGENT-CAPABILITIES statement).
21
22 The layered concept of libsmi allows to add further methods to retrieve MIB
23 information from persistent repositories. In fact, besides the SMIv1/v2 MIB
24 file parser an additional parser for `SMIng' is included. Both parsers are
25 built on flex/bison grammar specifications.
26
27 SMIng is a research project concerned with the definition of a MIB module
28 language that is semantically fully compatible with SMIv2 but avoids many
29 problems of the ASN.1 based SMI versions.
30
31 Included with the library, there are three tools that make use of libsmi:
32 Smiquery allows simple queries of single MIB module items.  Smilint allows
33 to increase the verbosity of the parser(s), so that MIB modules can be
34 checked for syntax and semantic errors. Finally, smidump can be used to dump
35 MIB modules. Currently, SMIng and SMIv2 are supported as output formats, so
36 that SMIv2 <-> SMIng conversions are possible.
37
38 %package devel
39 Summary:        Header files and development documentation for libsmi
40 Summary(pl):    Pliki nag³ówkowe i dokumentacja do libsmi
41 Group:          Development/Libraries
42 Group(pl):      Programowanie/Biblioteki
43 Requires:       %{name} = %{version}
44
45 %description devel
46 Header files and development documentation for libsmi.
47
48 %description -l pl devel
49 Pliki nag³ówkowe i dokumentacja do libsmi.
50
51 %package static
52 Summary:        Static libsmi libraries
53 Summary(pl):    Biblioteki statyczne libsmi
54 Group:          Development/Libraries
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name}-devel = %{version}
57
58 %description static
59 Static libsmi libraries.
60
61 %description -l pl static
62 Biblioteki statyczne libsmi.
63
64 %prep
65 %setup -q
66
67 %build
68 LDFLAGS="-s"; export LDFLAGS
69 %configure \
70         --enable-smi \
71         --enable-sming \
72         --enable-shared \
73         --enable-static \
74         --with-mibdir=%{_datadir}/mibs
75
76 make
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 make install DESTDIR=$RPM_BUILD_ROOT
82
83 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
84
85 gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man?/* \
86         ChangeLog README THANKS TODO \
87         doc/draft-irtf-nmrg-sming-*.txt
88
89 %find_lang %{name}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*
101 %{_datadir}/mibs
102 %{_mandir}/man1/*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc *.gz doc/draft-irtf-nmrg-sming-*.txt.gz
107 %attr(755,root,root) %{_libdir}/lib*.so
108 %attr(755,root,root) %{_libdir}/lib*.la
109 %{_includedir}/*
110 %{_mandir}/man3/*
111
112 %files static
113 %attr(644,root,root) %{_libdir}/lib*.a
114
115 %changelog
This page took 0.059674 seconds and 3 git commands to generate.