]> git.pld-linux.org Git - packages/libskk.git/blob - libskk.spec
abcd67a310af0d838d48de1ee568ecc06a1ea5f4
[packages/libskk.git] / libskk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  fep             # fep client
6 #
7 Summary:        Library to deal with Japanese kana-to-kanji conversion method
8 Summary(pl.UTF-8):      Biblioteka obsługi metody konwersji tekstu japońskiego kana do kanji
9 Name:           libskk
10 Version:        1.0.2
11 Release:        2
12 License:        GPL v3+
13 Group:          Libraries
14 #Source0Download: https://github.com/ueno/libskk/downloads
15 Source0:        https://github.com/ueno/libskk/releases/download/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  26d5fedd29add95faae53dc90487330d
17 URL:            https://github.com/ueno/libskk/
18 BuildRequires:  gettext-devel
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.0
21 BuildRequires:  json-glib-devel
22 BuildRequires:  libgee-devel
23 BuildRequires:  pkgconfig
24 # not needed for releases
25 #BuildRequires: vala >= 2:0.14.0
26 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
27 %if %{with fep}
28 BuildRequires:  libfep-devel >= 0.0.7
29 BuildRequires:  vala-libfep >= 0.0.7
30 %endif
31 BuildRequires:  vala-libgee
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libskk is a library to deal with Japanese kana-to-kanji conversion
36 method.
37
38 %description -l pl.UTF-8
39 libskk to biblioteka do obsługi metody konwersji tekstu japońśkiego
40 kana do kanji.
41
42 %package fep
43 Summary:        skkfep - Japanese SKK input method on text terminal
44 Summary(pl.UTF-8):      skkfep - metoda wprowadzania znaków japońskich SKK z terminala tekstowego
45 Group:          Applications/Text
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libfep >= 0.0.7
48
49 %description fep
50 skkfep is a tool that allows to use Japanese input method called SKK
51 (Simple Kana to Kanji conversion program) on ANSI compliant text
52 terminals.
53
54 %description fep -l pl.UTF-8
55 skkfep to narzędzie pozwalające na używanie metody wprowadzania znaków
56 japońskich SKK (Simple Kana to Kanji - konwersja uproszczonego kana do
57 kanji) na terminalach tekstowych zgodnych z ANSI.
58
59 %package devel
60 Summary:        Header files for libskk library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libskk
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 2.0
65 Requires:       json-glib-devel
66 Requires:       libgee-devel
67
68 %description devel
69 Header files for libskk library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libskk.
73
74 %package static
75 Summary:        Static libskk library
76 Summary(pl.UTF-8):      Statyczna biblioteka libskk
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libskk library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libskk.
85
86 %package -n vala-libskk
87 Summary:        Vala API for libskk library
88 Summary(pl.UTF-8):      API języka Vala do biblioteki libskk
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Requires:       vala >= 2:0.14.0
92 Requires:       vala-libgee
93
94 %description -n vala-libskk
95 Vala API for libskk library.
96
97 %description -n vala-libskk -l pl.UTF-8
98 API języka Vala do biblioteki libskk.
99
100 %package apidocs
101 Summary:        libskk API documentation
102 Summary(pl.UTF-8):      Dokumentacja API biblioteki libskk
103 Group:          Documentation
104
105 %description apidocs
106 API and internal documentation for libskk library.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API biblioteki libskk.
110
111 %prep
112 %setup -q
113
114 %build
115 # pass fake VALADOC_* args to avoid requiring valadoc-devel
116 # (only utility is needed here, but configure checks for development package)
117 %configure \
118         VALADOC_CFLAGS=fake \
119         VALADOC_LIBS=fake \
120         %{?with_apidocs:--enable-docs} \
121         %{?with_fep:--enable-fep} \
122         %{?with_static_libs:--enable-static}
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         libskkgtkdocdir=%{_gtkdocdir}/libskk
131
132 # obsoleted by pkg-config
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libskk.la
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc ChangeLog NEWS README
146 %attr(755,root,root) %{_bindir}/skk
147 %attr(755,root,root) %{_libdir}/libskk.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libskk.so.0
149 %{_libdir}/girepository-1.0/Skk-1.0.typelib
150 %{_datadir}/libskk
151 %{_mandir}/man1/skk.1*
152
153 %if %{with fep}
154 %files fep
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/skkfep
157 %attr(755,root,root) %{_libdir}/skkfep-client
158 %{_mandir}/man1/skkfep.1*
159 %endif
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libskk.so
164 %{_datadir}/gir-1.0/Skk-1.0.gir
165 %{_includedir}/libskk
166 %{_pkgconfigdir}/libskk.pc
167
168 %if %{with static_libs}
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libskk.a
172 %endif
173
174 %files -n vala-libskk
175 %defattr(644,root,root,755)
176 %{_datadir}/vala/vapi/skk-1.0.deps
177 %{_datadir}/vala/vapi/skk-1.0.vapi
178
179 %if %{with apidocs}
180 %files apidocs
181 %defattr(644,root,root,755)
182 %{_gtkdocdir}/libskk
183 # should it be here?
184 %{_datadir}/devhelp/references/libskk
185 %endif
This page took 0.107096 seconds and 2 git commands to generate.