]> git.pld-linux.org Git - packages/libsecret.git/blob - libsecret.spec
noarch apidocs
[packages/libsecret.git] / libsecret.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  vala            # do not build Vala API
6
7 Summary:        Library for storing and retrieving passwords and other secrets
8 Summary(pl.UTF-8):      Biblioteka do przechowywania i odczytu haseł oraz innych tajnych informacji
9 Name:           libsecret
10 Version:        0.18
11 Release:        4
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsecret/0.18/%{name}-%{version}.tar.xz
15 # Source0-md5:  279d723cd005e80d1d304f74a3488acc
16 URL:            https://live.gnome.org/Libsecret
17 BuildRequires:  glib2-devel >= 1:2.38.0
18 BuildRequires:  gobject-introspection-devel >= 1.29
19 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  libgcrypt-devel >= 1.2.2
22 BuildRequires:  libxslt-progs
23 BuildRequires:  pkgconfig
24 %{?with_vala:BuildRequires:     vala >= 2:0.17.2.12}
25 Requires:       glib2 >= 1:2.38.0
26 Requires:       libgcrypt >= 1.2.2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libsecret is a library for storing and retrieving passwords and other
31 secrets. It communicates with the "Secret Service" using DBus.
32 gnome-keyring and KSecretService are both implementations of a Secret
33 Service.
34
35 %description -l pl.UTF-8
36 libsecret to biblioteka do przechowywania i odczytu haseł oraz innych
37 tajnych informacji. Komunikuje się z usługą informacji tajnych
38 ("Secret Service") poprzez DBus. Zarówno gnome-keyring, jak i
39 KSecretService są implementacjami tej usługi.
40
41 %package devel
42 Summary:        Header files for libsecret library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsecret
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.38.0
47 Requires:       libgcrypt-devel >= 1.2.2
48
49 %description devel
50 Header files for libsecret library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libsecret.
54
55 %package static
56 Summary:        Static libsecret library
57 Summary(pl.UTF-8):      Statyczna biblioteka libsecret
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libsecret library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libsecret.
66
67 %package apidocs
68 Summary:        libsecret API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki libsecret
70 Group:          Documentation
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 libsecret API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki libsecret.
80
81 %package -n vala-libsecret
82 Summary:        libsecret API for Vala language
83 Summary(pl.UTF-8):      API libsecret dla języka Vala
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala >= 2:0.17.2.12
87
88 %description -n vala-libsecret
89 libsecret API for Vala language.
90
91 %description -n vala-libsecret -l pl.UTF-8
92 API libsecret dla języka Vala.
93
94 %prep
95 %setup -q
96
97 %build
98 %configure \
99         --disable-silent-rules \
100         %{__enable_disable static_libs static} \
101         %{__enable_disable apidocs gtk-doc} \
102         %{__enable_disable vala vala} \
103         --with-html-dir=%{_gtkdocdir}/%{name}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %find_lang libsecret
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files -f libsecret.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README
123 %attr(755,root,root) %{_bindir}/secret-tool
124 %attr(755,root,root) %{_libdir}/libsecret-1.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libsecret-1.so.0
126 %{_libdir}/girepository-1.0/Secret-1.typelib
127 %{_mandir}/man1/secret-tool.1*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libsecret-1.so
132 %{_libdir}/libsecret-1.la
133 %{_includedir}/libsecret-1
134 %{_pkgconfigdir}/libsecret-1.pc
135 %{_pkgconfigdir}/libsecret-unstable.pc
136 %{_datadir}/gir-1.0/Secret-1.gir
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libsecret-1.a
142 %endif
143
144 %if %{with apidocs}
145 %files apidocs
146 %defattr(644,root,root,755)
147 %{_gtkdocdir}/%{name}
148 %endif
149
150 %if %{with vala}
151 %files -n vala-libsecret
152 %defattr(644,root,root,755)
153 %{_datadir}/vala/vapi/libsecret-1.deps
154 %{_datadir}/vala/vapi/libsecret-1.vapi
155 %endif
This page took 0.042938 seconds and 3 git commands to generate.