]> git.pld-linux.org Git - packages/libseccomp.git/blob - libseccomp.spec
fa32890a348564d80e29c663dfd3569bf5bef4b1
[packages/libseccomp.git] / libseccomp.spec
1 #
2 %bcond_without  tests
3
4 Summary:        Enhanced Seccomp (mode 2) Helper library
5 Summary(pl.UTF-8):      Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
6 Name:           libseccomp
7 Version:        2.1.1
8 Release:        2
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://downloads.sourceforge.net/libseccomp/%{name}-%{version}.tar.gz
12 # Source0-md5:  1f41207b29e66a7e5e375dd48a64de85
13 Patch0:         %{name}-pc.patch
14 URL:            http://libseccomp.sourceforge.net/
15 BuildRequires:  bash
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The libseccomp library provides and easy to use, platform independent,
20 interface to the Linux Kernel's syscall filtering mechanism: seccomp.
21 The libseccomp API is designed to abstract away the underlying BPF
22 based syscall filter language and present a more conventional
23 function-call based filtering interface that should be familiar to,
24 and easily adopted by application developers.
25
26 %description -l pl.UTF-8
27 Biblioteka libseccomp udostępnia łatwy w użyciu, niezależny od
28 platformy interfejs do mechanizmu filtrowania wywołań systemowych
29 jądra Linuksa - seccomp. API libseccomp jest zaprojektowane tak, żeby
30 wyabstrahować język filtrowania wywołań BPF niższego poziomu i
31 zaprezentować bardziej konwencjonalny interfejs filtrowania w oparciu
32 o wywołania funkcji, który powinien być bardziej przyjazny i łatwiej
33 adaptowalny dla programistów aplikacji.
34
35 %package devel
36 Summary:        Header files for Seccomp library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Seccomp
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for Seccomp library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki Seccomp.
46
47 %package static
48 Summary:        Static Seccomp library
49 Summary(pl.UTF-8):      Statyczna biblioteka Seccomp
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static Seccomp library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka Seccomp.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 # not autoconf configure
65 ./configure \
66         --prefix=%{_prefix} \
67         --libdir=%{_libdir}
68
69 GCC="%{__cc}" \
70 CFLAGS="%{rpmcflags} -Wall" \
71 %{__make} \
72         V=1
73
74 %{?with_tests:%{__make} check V=1}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 cp -p src/libseccomp.a $RPM_BUILD_ROOT%{_libdir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc CHANGELOG CREDITS README
92 %attr(755,root,root) %{_bindir}/scmp_sys_resolver
93 %attr(755,root,root) %{_libdir}/libseccomp.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libseccomp.so.2
95 %{_mandir}/man1/scmp_sys_resolver.1*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libseccomp.so
100 %{_includedir}/seccomp.h
101 %{_pkgconfigdir}/libseccomp.pc
102 %{_mandir}/man3/seccomp_*.3*
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libseccomp.a
This page took 0.111567 seconds and 2 git commands to generate.