]> git.pld-linux.org Git - SPECS.git/blob - librevenge.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / librevenge.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  gdb             # GDB pretty printers
5
6 Summary:        Library for generic document converters
7 Summary(pl.UTF-8):      Biblioteka dla ogólnych konwerterów dokumentów
8 Name:           librevenge
9 Version:        0.0.5
10 Release:        1
11 License:        MPL v2.0 or LGPL v2.1+
12 Group:          Libraries
13 Source0:        https://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
14 # Source0-md5:  c6e629dfb9557a6a2cd4309b31eddfa8
15 URL:            https://sourceforge.net/p/libwpd/wiki/librevenge/
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.20
19 BuildRequires:  cppunit-devel
20 BuildRequires:  doxygen
21 BuildRequires:  libstdc++-devel >= 6:4.7
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  pkgconfig
24 %{?with_gdb:BuildRequires:      python}
25 %{?with_gdb:BuildRequires:      python-modules}
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpmbuild(macros) >= 1.234
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 librevenge is a base library for writing document import filters. It
35 has interfaces for text documents, vector graphics, spreadsheets and
36 presentations.
37
38 %description -l pl.UTF-8
39 librevenge to biblioteka podstawowa do pisania filtrów importujących
40 dokumenty. Zawiera interfejsy dla dokumentów tekstowych, grafiki
41 wektorowej, arkuszy kalkulacyjnych oraz prezentacji.
42
43 %package devel
44 Summary:        Header files for librevenge library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki librevenge
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel >= 6:4.7
49
50 %description devel
51 Header files for librevenge library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki librevenge.
55
56 %package static
57 Summary:        Static librevenge library
58 Summary(pl.UTF-8):      Statyczna biblioteka librevenge
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static librevenge library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka librevenge.
67
68 %package apidocs
69 Summary:        API documentation for librevenge library
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki librevenge
71 Group:          Documentation
72 BuildArch:      noarch
73
74 %description apidocs
75 API documentation for librevenge library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki librevenge.
79
80 %package gdb
81 Summary:        GDB Python pretty printers for librevenge types
82 Summary(pl.UTF-8):      Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge
83 Group:          Development/Debuggers
84 Requires:       gdb
85
86 %description gdb
87 GDB Python pretty printers for librevenge types.
88
89 %description gdb -l pl.UTF-8
90 Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{?with_gdb:--enable-pretty-printers} \
103         %{?with_static_libs:--enable-static} \
104         --disable-werror \
105         --disable-silent-rules
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librevenge-*.la
116
117 %if %{with gdb}
118 %py_comp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
119 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
120 %py_postclean %{_datadir}/librevenge/python/librevenge
121 %endif
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README
132 %attr(755,root,root) %{_libdir}/librevenge-0.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/librevenge-0.0.so.0
134 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/librevenge-generators-0.0.so.0
136 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/librevenge-stream-0.0.so.0
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/librevenge-0.0.so
142 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so
143 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so
144 %{_includedir}/librevenge-0.0
145 %{_pkgconfigdir}/librevenge-0.0.pc
146 %{_pkgconfigdir}/librevenge-generators-0.0.pc
147 %{_pkgconfigdir}/librevenge-stream-0.0.pc
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/librevenge-0.0.a
153 %{_libdir}/librevenge-generators-0.0.a
154 %{_libdir}/librevenge-stream-0.0.a
155 %endif
156
157 %files apidocs
158 %defattr(644,root,root,755)
159 %doc docs/doxygen/html/*
160
161 %if %{with gdb}
162 %files gdb
163 %defattr(644,root,root,755)
164 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-0.0-gdb.py
165 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-stream-0.0-gdb.py
166 %dir %{_datadir}/librevenge
167 %{_datadir}/librevenge/python
168 %endif
This page took 0.858828 seconds and 3 git commands to generate.