]> git.pld-linux.org Git - SPECS.git/blob - libraptor2.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / libraptor2.spec
1 Summary:        Raptor RDF Parser Toolkit
2 Summary(pl.UTF-8):      Raptor - zestaw narzędzi do analizy RDF
3 Name:           libraptor2
4 # the real name is raptor2, but it follows libraptor (named as such because raptor was already occupied)
5 %define rname   raptor2
6 Version:        2.0.16
7 Release:        2
8 License:        LGPL v2.1+ or GPL v2+ or Apache v2.0+
9 Group:          Libraries
10 Source0:        https://download.librdf.org/source/%{rname}-%{version}.tar.gz
11 # Source0-md5:  0a71f13b6eaa0a04bf411083d89d7bc2
12 Patch0:         %{rname}-libxml2.patch
13 URL:            https://librdf.org/raptor/
14 BuildRequires:  autoconf >= 2.62
15 BuildRequires:  automake >= 1:1.11
16 # WWW library can be one of: curl(default),xml,libfetch,none
17 BuildRequires:  curl-devel >= 7.12.0
18 BuildRequires:  gtk-doc-automake >= 1.3
19 BuildRequires:  libicu-devel
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  libxml2-devel >= 1:2.6.8
22 BuildRequires:  libxslt-devel >= 1.0.18
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  yajl-devel
26 Requires:       curl-libs >= 7.12.0
27 Requires:       libxml2 >= 1:2.6.8
28 Requires:       libxslt >= 1.0.18
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Raptor is the RDF Parser Toolkit for Redland written in C consisting
33 of two parsers for the RDF/XML and N-Triples syntaxes for RDF. Raptor
34 is designed to work efficiently when used with Redland but is entirely
35 separate.
36
37 %description -l pl.UTF-8
38 Raptor to zestaw narzędzi do analizy RDF dla Redland napisany w C,
39 składający się z dwóch analizatorów dla składni RDF/XML i N-Triplets
40 dla RDF. Raptor został zaprojektowany, by pracować wydajnie, jeśli
41 jest używany z Redland, ale jest całkowicie oddzielny.
42
43 %package devel
44 Summary:        libraptor2 library header files
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libraptor2
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       curl-devel >= 7.12.0
49 Requires:       libicu-devel
50 Requires:       libxml2-devel >= 1:2.6.8
51 Requires:       libxslt-devel >= 1.0.18
52 Requires:       yajl-devel
53
54 %description devel
55 libraptor2 library header files.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki libraptor2.
59
60 %package static
61 Summary:        Static libraptor2 library
62 Summary(pl.UTF-8):      Statyczna biblioteka libraptor2
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static libraptor2 library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka libraptor2.
71
72 %package apidocs
73 Summary:        libraptor2 API documentation
74 Summary(pl.UTF-8):      Dokumentacja API biblioteki libraptor2
75 Group:          Documentation
76 Requires:       gtk-doc-common
77 BuildArch:      noarch
78
79 %description apidocs
80 libraptor2 API documentation.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki libraptor2.
84
85 %package rapper
86 Summary:        Raptor RDF parser test program
87 Summary(pl.UTF-8):      Testowy program parsera Raptor RDF
88 Group:          Applications
89 Requires:       %{name} = %{version}-%{release}
90 Obsoletes:      libraptor-rapper < 2.0.0
91 Obsoletes:      redland-rapper < 0.9.18
92
93 %description rapper
94 Raptor RDF parser test program.
95
96 %description rapper -l pl.UTF-8
97 Testowy program parsera Raptor RDF.
98
99 %prep
100 %setup -q -n %{rname}-%{version}
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 # avoid using parsedate from libinn, use curl_getdate instead
110 %configure \
111         ac_cv_header_libinn_h=no \
112         --enable-release \
113         --with-html-dir=%{_gtkdocdir}
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraptor2.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog LICENSE.txt NEWS NOTICE README RELEASE.html UPGRADING.html
134 %attr(755,root,root) %{_libdir}/libraptor2.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libraptor2.so.0
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libraptor2.so
140 %{_includedir}/raptor2
141 %{_pkgconfigdir}/raptor2.pc
142 %{_mandir}/man3/libraptor2.3*
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libraptor2.a
147
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/raptor2
151
152 %files rapper
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/rapper
155 %{_mandir}/man1/rapper.1*
This page took 0.285166 seconds and 3 git commands to generate.