]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- version up and build fixes
[packages/libprelude.git] / libprelude.spec
1 %bcond_without  perl
2 %bcond_without  python          # required by prewikka
3
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The Prelude library
6 Summary(pl):    Biblioteka Prelude
7 Name:           libprelude
8 Version:        0.9.12.2
9 Release:        1
10 License:        GPL
11 Group:          Libraries
12 Source0:        http://www.prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  4636cf21c3e96adbd9463138fb49f401
14 URL:            http://www.prelude-ids.org/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gnutls-devel >= 1.0.17
18 BuildRequires:  gtk-doc
19 %{?with_perl:BuildRequires:     perl-devel}
20 %{?with_python:BuildRequires:   python-devel}
21 BuildRequires:  rpm-perlprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Prelude library is a collection of generic functions providing
26 communication between the Prelude Hybrid IDS suite components. It
27 provides a convenient interface for sending alerts to Prelude Manager
28 with transparent SSL, failover and replication support, asynchronous
29 events and timer interfaces, an abstracted configuration API (hooking
30 at the commandline, the configuration line, or wide configuration,
31 available from the Manager), and a generic plugin API. It allows you
32 to easily turn your favorite security program into a Prelude sensor.
33
34 %description -l pl
35 Biblioteka Prelude to zbiór ogólnych funkcji zapewniaj±cych
36 komunikacjê pomiêdzy komponentami zestawu Prelude Hybrid IDS.
37 Dostarcza wygodny interfejs do wysy³ania alarmów do zarz±dcy Prelude z
38 przezroczyst± obs³ugê SSL, failover i replikacji, interfejsy do
39 zdarzeñ asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
40 (obs³uguj±ce liniê poleceñ, liniê konfiguracji i konfiguracjê
41 dostêpn± z zarz±dcy) oraz ogólne API wtyczek. Pozwala ³atwo zamieniæ
42 ulubiony program zwi±zany z bezpieczeñstwem na czujnik Prelude.
43
44 %package libs
45 Summary:        The Prelude library
46 Summary(pl):    Biblioteka Prelude
47 Group:          Libraries
48
49 %description libs
50 The Prelude library.
51
52 %description libs -l pl
53 Biblioteka Prelude.
54
55 %package devel
56 Summary:        Header files and development documentation for libprelude
57 Summary(pl):    Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{version}-%{release}
60 Requires:       gnutls-devel
61
62 %description devel
63 Header files and development documentation for libprelude.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude.
67
68 %package static
69 Summary:        Static libprelude library
70 Summary(pl):    Statyczna biblioteka libprelude
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static libprelude library.
76
77 %description static -l pl
78 Statyczna biblioteka libprelude.
79
80 %package -n perl-libprelude
81 Summary:        libprelude Perl bindings
82 Summary(pl):    Dowi±zania Perla do libprelude
83 Group:          Development/Languages/Perl
84
85 %description -n perl-libprelude
86 libprelude Perl bindings.
87
88 %description -n perl-libprelude -l pl
89 Dowi±zania Perla dla libprelude.
90
91 %package -n python-libprelude
92 Summary:        libprelude Python bindings
93 Summary(pl):    Dowi±zania Pythona dla libprelude
94 Group:          Development/Languages/Python
95
96 %description -n python-libprelude
97 libprelude Python bindings.
98
99 %description -n python-libprelude -l pl
100 Dowi±zania Pythona dla libprelude.
101
102 %prep
103 %setup -q
104
105 %build
106 %configure \
107         --enable-shared \
108         --enable-static \
109         --enable-gtk-doc \
110         --with%{!?with_perl:out}-perl \
111         --with%{!?with_python:out}-python \
112         --with-html-dir=%{_gtkdocdir}/libprelude
113
114 # first make the perl makefile otherwise with jobserver strange things happen:
115 # Makefile out-of-date with respect to Makefile.PL
116 %if %{with perl}
117 %{__make} -C bindings perl/Makefile.PL
118 %endif
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # are generating wrong dependencies (and are not needed anyway)
129 find $RPM_BUILD_ROOT -iregex .*.la -exec rm {} \;
130
131 %if %{with perl}
132 cd bindings/perl && %{__perl} Makefile.PL \
133         INSTALLDIRS=vendor
134 cd ../..
135 %{__make} -C bindings/perl install \
136         DESTDIR=$RPM_BUILD_ROOT
137 %endif
138
139 %if %{with python}
140 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
141 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
142 %endif
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   libs -p /sbin/ldconfig
148 %postun libs -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README
153 %dir %{_sysconfdir}/prelude
154 %dir %{_sysconfdir}/prelude/default
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
156 %dir %{_sysconfdir}/prelude/profile
157
158 %files libs
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/prelude-adduser
161 %attr(755,root,root) %{_libdir}/lib*.so.*.*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/libprelude-config
166 %attr(755,root,root) %{_libdir}/lib*.so
167 %{_includedir}/libprelude
168 %{_aclocaldir}/*.m4
169 %{_gtkdocdir}/libprelude
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/lib*.a
174
175 %if %{with perl}
176 %files -n perl-libprelude
177 %defattr(644,root,root,755)
178 %dir %{perl_vendorarch}/auto/Prelude
179 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/*.so
180 %{perl_vendorarch}/auto/Prelude/*.bs
181 %{perl_vendorarch}/Prelude.pm
182 %endif
183
184 %if %{with python}
185 %files -n python-libprelude
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{py_sitedir}/*.so
188 %{py_sitedir}/*.py[co]
189 %endif
This page took 0.058081 seconds and 4 git commands to generate.