]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- bcond descs
[packages/libprelude.git] / libprelude.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # don't build perl bindings
4 %bcond_without  python  # don't build python bindings (required by prewikka)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The Prelude library
8 Summary(pl):    Biblioteka Prelude
9 Name:           libprelude
10 Version:        0.9.12.2
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://www.prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  4636cf21c3e96adbd9463138fb49f401
16 URL:            http://www.prelude-ids.org/
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gnutls-devel >= 1.0.17
20 BuildRequires:  gtk-doc
21 %{?with_perl:BuildRequires:     perl-devel}
22 %{?with_python:BuildRequires:   python-devel}
23 BuildRequires:  rpm-perlprov
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Prelude library is a collection of generic functions providing
28 communication between the Prelude Hybrid IDS suite components. It
29 provides a convenient interface for sending alerts to Prelude Manager
30 with transparent SSL, failover and replication support, asynchronous
31 events and timer interfaces, an abstracted configuration API (hooking
32 at the commandline, the configuration line, or wide configuration,
33 available from the Manager), and a generic plugin API. It allows you
34 to easily turn your favorite security program into a Prelude sensor.
35
36 %description -l pl
37 Biblioteka Prelude to zbiór ogólnych funkcji zapewniaj±cych
38 komunikacjê pomiêdzy komponentami zestawu Prelude Hybrid IDS.
39 Dostarcza wygodny interfejs do wysy³ania alarmów do zarz±dcy Prelude z
40 przezroczyst± obs³ugê SSL, failover i replikacji, interfejsy do
41 zdarzeñ asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
42 (obs³uguj±ce liniê poleceñ, liniê konfiguracji i konfiguracjê
43 dostêpn± z zarz±dcy) oraz ogólne API wtyczek. Pozwala ³atwo zamieniæ
44 ulubiony program zwi±zany z bezpieczeñstwem na czujnik Prelude.
45
46 %package libs
47 Summary:        The Prelude library
48 Summary(pl):    Biblioteka Prelude
49 Group:          Libraries
50
51 %description libs
52 The Prelude library.
53
54 %description libs -l pl
55 Biblioteka Prelude.
56
57 %package devel
58 Summary:        Header files and development documentation for libprelude
59 Summary(pl):    Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       gnutls-devel
63
64 %description devel
65 Header files and development documentation for libprelude.
66
67 %description devel -l pl
68 Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude.
69
70 %package static
71 Summary:        Static libprelude library
72 Summary(pl):    Statyczna biblioteka libprelude
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libprelude library.
78
79 %description static -l pl
80 Statyczna biblioteka libprelude.
81
82 %package -n perl-libprelude
83 Summary:        libprelude Perl bindings
84 Summary(pl):    Dowi±zania Perla do libprelude
85 Group:          Development/Languages/Perl
86
87 %description -n perl-libprelude
88 libprelude Perl bindings.
89
90 %description -n perl-libprelude -l pl
91 Dowi±zania Perla dla libprelude.
92
93 %package -n python-libprelude
94 Summary:        libprelude Python bindings
95 Summary(pl):    Dowi±zania Pythona dla libprelude
96 Group:          Development/Languages/Python
97
98 %description -n python-libprelude
99 libprelude Python bindings.
100
101 %description -n python-libprelude -l pl
102 Dowi±zania Pythona dla libprelude.
103
104 %prep
105 %setup -q
106
107 %build
108 %configure \
109         --enable-shared \
110         --enable-static \
111         --enable-gtk-doc \
112         --with%{!?with_perl:out}-perl \
113         --with%{!?with_python:out}-python \
114         --with-html-dir=%{_gtkdocdir}/libprelude
115
116 # first make the perl makefile otherwise with jobserver strange things happen:
117 # Makefile out-of-date with respect to Makefile.PL
118 %if %{with perl}
119 %{__make} -C bindings perl/Makefile.PL
120 %endif
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 # are generating wrong dependencies (and are not needed anyway)
131 find $RPM_BUILD_ROOT -iregex .*.la -exec rm {} \;
132
133 %if %{with perl}
134 cd bindings/perl && %{__perl} Makefile.PL \
135         INSTALLDIRS=vendor
136 cd ../..
137 %{__make} -C bindings/perl install \
138         DESTDIR=$RPM_BUILD_ROOT
139 %endif
140
141 %if %{with python}
142 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
143 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
144 %endif
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   libs -p /sbin/ldconfig
150 %postun libs -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %dir %{_sysconfdir}/prelude
156 %dir %{_sysconfdir}/prelude/default
157 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
158 %dir %{_sysconfdir}/prelude/profile
159
160 %files libs
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/prelude-adduser
163 %attr(755,root,root) %{_libdir}/lib*.so.*.*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/libprelude-config
168 %attr(755,root,root) %{_libdir}/lib*.so
169 %{_includedir}/libprelude
170 %{_aclocaldir}/*.m4
171 %{_gtkdocdir}/libprelude
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/lib*.a
176
177 %if %{with perl}
178 %files -n perl-libprelude
179 %defattr(644,root,root,755)
180 %dir %{perl_vendorarch}/auto/Prelude
181 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/*.so
182 %{perl_vendorarch}/auto/Prelude/*.bs
183 %{perl_vendorarch}/Prelude.pm
184 %endif
185
186 %if %{with python}
187 %files -n python-libprelude
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{py_sitedir}/*.so
190 %{py_sitedir}/*.py[co]
191 %endif
This page took 0.055358 seconds and 4 git commands to generate.