]> git.pld-linux.org Git - SPECS.git/blob - libopenshot.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libopenshot.spec
1 Summary:        Library for creating and editing videos
2 Name:           libopenshot
3 Version:        0.2.0
4 Release:        3
5 License:        LGPL-3.0+
6 Group:          Libraries
7 Source0:        https://github.com/OpenShot/libopenshot/archive/v%{version}.tar.gz
8 # Source0-md5:  09b05e23356d53777bcb2cad1615683b
9 Patch0:         imagemagick7.patch
10 Patch1:         %{name}-ffmpeg.patch
11 Group:          Development/Libraries
12 URL:            http://www.openshot.org/
13 BuildRequires:  ImageMagick-c++-devel
14 BuildRequires:  Qt5Core-devel
15 BuildRequires:  Qt5Multimedia-devel
16 BuildRequires:  Qt5MultimediaWidgets-devel
17 BuildRequires:  cmake
18 BuildRequires:  cppzmq-devel
19 BuildRequires:  doxygen
20 BuildRequires:  ffmpeg-devel
21 BuildRequires:  ffmpeg-libs
22 BuildRequires:  libopenshot-audio-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  python3-devel
25 BuildRequires:  swig
26 BuildRequires:  unittest-cpp-devel
27 BuildRequires:  zeromq-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         skip_post_check_so      libopenshot.so.*
31
32 %description
33 OpenShot Library (libopenshot) is an open-source project dedicated to
34 delivering high quality video editing, animation, and playback
35 solutions to the world. For more information visit
36 <http://www.openshot.org/>.
37
38 %package devel
39 Summary:        Development files for %{name}
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 The %{name}-devel package contains libraries and header files for
45 developing applications that use %{name}.
46
47 %package -n python3-%{name}
48 Summary:        Python bindings for %{name}
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n python3-%{name}
53 The python-%{name} package contains python bindings for applications
54 that use %{name}.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 sed -i -e 's#${_REL_PYTHON_MODULE_PATH}#%{py3_sitedir}#g' src/bindings/python/CMakeLists.txt
62
63 %build
64 install -d build
65 cd build
66 %cmake .. \
67         -DENABLE_RUBY=NO
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libopenshot.so.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libopenshot.so.15
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/libopenshot
90 %attr(755,root,root) %{_libdir}/libopenshot.so
91
92 %files -n python3-%{name}
93 %defattr(644,root,root,755)
94 %{py3_sitedir}/openshot.py
95 %attr(755,root,root) %{py3_sitedir}/_openshot.so
This page took 1.264637 seconds and 3 git commands to generate.