]> git.pld-linux.org Git - SPECS.git/blob - libobjc2.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / libobjc2.spec
1 # TODO: make gcc-objc separate libobjc
2 # - separate libobjcxx? (requires libstdc++ while libobjc doesn't)
3 # - use -DLIBOBJC_NAME=objc2 to allow parallel installation with gcc's libobjc?
4 #
5 Summary:        GNUStep runtime for Objective C
6 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla Objective C z projektu GNUstep
7 Name:           libobjc2
8 Version:        1.7
9 Release:        0.1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.gna.org/gnustep/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7bd9f154ed2f78b3cf55ede7dea536bd
14 Patch0:         %{name}-link.patch
15 URL:            http://www.gnustep.org/
16 BuildRequires:  clang
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  gnustep-make
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is the GNUstep Objective-C runtime (a.k.a. libobjc2). This
25 runtime was designed to support the features of Objective-C 2 for use
26 with GNUstep and other Objective-C programs.
27
28 %description -l pl.UTF-8
29 Ten pakiet zawiera bibliotekę uruchomieniową Objective-C z projektu
30 GNUstep (znaną także jako libobjc2). Ta biblioteka została
31 zaprojektowana, aby wspierać cechy języka Objective-C 2, w celu
32 używania w GNUstepie i innych programach w Objective-C.
33
34 %package devel
35 Summary:        Development files for programs using libobjc2
36 Summary(pl.UTF-8):      Pliki programistyczne do biblioteki libobjc2
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 This package contains the header files needed for developing programs
42 using the libobjc2 library.
43
44 %description devel -l pl.UTF-8
45 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia programów
46 wykorzystujących bibliotekę libobjc2.
47
48 %package static
49 Summary:        Static libobjc2 library
50 Summary(pl.UTF-8):      Statyczna biblioteka libobjc2
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static libobjc2 library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libobjc2.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 %build
65 install -d build
66 cd build
67 %cmake .. \
68         -DBUILD_STATIC_LIBOBJC=ON \
69         -DCMAKE_C_COMPILER="clang" \
70         -DCMAKE_CXX_COMPILER="clang++" \
71         -DGNUSTEP_INSTALL_TYPE=SYSTEM
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT 
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc ANNOUNCE* API COPYING README
90 %attr(755,root,root) %{_libdir}/libobjc.so.*.*
91 %attr(755,root,root) %{_libdir}/libobjcxx.so.*.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libobjc.so
96 %attr(755,root,root) %{_libdir}/libobjcxx.so
97 %{_includedir}/objc
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libobjc.a
This page took 0.828067 seconds and 3 git commands to generate.