]> git.pld-linux.org Git - packages/libnl.git/blob - libnl.spec
- fix apidocs
[packages/libnl.git] / libnl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build api docs
4
5 Summary:        Netlink library
6 Summary(pl.UTF-8):      Biblioteka do obsługi gniazd netlink
7 Name:           libnl
8 Version:        1.1
9 Release:        3
10 Epoch:          1
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        http://people.suug.ch/~tgr/libnl/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  ae970ccd9144e132b68664f98e7ceeb1
15 Patch0:         %{name}-static.patch
16 Patch1:         %{name}-ULONG_MAX.patch
17 URL:            http://people.suug.ch/~tgr/libnl/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  linux-libc-headers >= 6:2.6.23
21 %{?with_apidocs:BuildRequires:  tetex-dvips}
22 %{?with_apidocs:BuildRequires:  tetex-format-latex}
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 libnl is a library for applications dealing with netlink socket. It
28 provides an easy to use interface for raw netlink message but also
29 netlink family specific APIs.
30
31 %description -l pl.UTF-8
32 libnl jest biblioteką dla aplikacji rozmawiających z gniazdem netlink.
33 Udostępnia łatwy w użyciu interfejs do korzystania z surowych
34 wiadomości netlink, a także API specyficzne dla rodziny gniazd
35 netlink.
36
37 %package devel
38 Summary:        Header files for libnl library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnl
40 Group:          Development/Libraries
41 Requires:       %{name} = %{epoch}:%{version}-%{release}
42
43 %description devel
44 Header files for libnl library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki libnl.
48
49 %package static
50 Summary:        Static libnl library
51 Summary(pl.UTF-8):      Statyczna biblioteka libnl
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
54
55 %description static
56 Static libnl library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka libnl.
60
61 %package apidocs
62 Summary:        libnl library API documentation
63 Group:          Documentation
64
65 %description apidocs
66 Documentation for libnl library API and guides in HTML format
67 generated from sources by doxygen.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %{__aclocal}
76 %{__autoconf}
77
78 %configure \
79         --enable-verbose-errors
80
81 %{__make}
82 %{?with_apidocs:%{__make} -C doc gendoc}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # for autodeps to work
91 chmod +x $RPM_BUILD_ROOT%{_libdir}/libnl.so.*.*
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc ChangeLog
102 %attr(755,root,root) %{_libdir}/libnl.so.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libnl.so.1
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libnl.so
108 %{_includedir}/netlink
109 %{_pkgconfigdir}/libnl-1.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libnl.a
114
115 %if %{with apidocs}
116 %files apidocs
117 %defattr(644,root,root,755)
118 %doc doc/html/*
119 %endif
This page took 0.077091 seconds and 3 git commands to generate.