]> git.pld-linux.org Git - SPECS.git/blob - libnice.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libnice.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        The GLib ICE (Interactive Connectivity Establishment) implementation
6 Summary(pl.UTF-8):      Implementacja ICE (Interactive Connectivity Establishment) oparta o GLib
7 Name:           libnice
8 Version:        0.1.17
9 Release:        1
10 License:        LGPL v2.1 or MPL v1.1
11 Group:          Libraries
12 #Source0Download: https://libnice.freedesktop.org/#download
13 Source0:        https://libnice.freedesktop.org/releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  0a6a8215013f1b8631fac8027e9ed90d
15 URL:            https://libnice.freedesktop.org/
16 BuildRequires:  autoconf >= 2.62
17 BuildRequires:  automake >= 1:1.12
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.54
20 BuildRequires:  gnutls-devel >= 2.12
21 BuildRequires:  gobject-introspection-devel >= 1.30.0
22 BuildRequires:  gstreamer-devel >= 1.0.0
23 BuildRequires:  gtk-doc >= 1.10
24 BuildRequires:  gupnp-igd-devel >= 0.2.4
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  pkgconfig
27 Requires:       glib2 >= 1:2.54
28 Requires:       gnutls-libs >= 2.12
29 Requires:       gupnp-igd >= 0.2.4
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libnice is an implementation of the IETF's draft Interactive
34 Connectivity Establishment standard (ICE). It provides GLib-based
35 library and GStreamer elements.
36
37 ICE is useful for applications that want to establish peer-to-peer UDP
38 data streams. It automates the process of traversing NATs and provides
39 security against some attacks.
40
41 Existing standards that use ICE include the Session Initiation
42 Protocol (SIP) and Jingle, XMPP extension for audio/video calls.
43
44 %description -l pl.UTF-8
45 libnice to implementacja standardu ICE (Interactive Connectivity
46 Establishment) wg szkicu IETF. Udostępnia bibliotekę opartą na GLibie
47 oraz elementy GStreamera.
48
49 ICE służy aplikacjom chcącym tworzyć strumienie danych UDP
50 peer-to-peer. Automatyzuje proces przechodzenia przez NAT i
51 zabezpiecza przed pewnymi atakami.
52
53 Istniejące standardy wykorzystujące ICE obejmują protokoły SIP
54 (Session Initiation Protocol) oraz Jingle (rozszerzenie XMPP dla
55 połączeń audio/video).
56
57 %package devel
58 Summary:        Header files for libnice library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnice
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       glib2-devel >= 1:2.54
63 Requires:       gnutls-devel >= 2.12
64 Requires:       gupnp-igd-devel >= 0.2.4
65
66 %description devel
67 Header files for libnice library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki libnice.
71
72 %package static
73 Summary:        Static libnice library
74 Summary(pl.UTF-8):      Statyczna biblioteka libnice
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libnice library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka libnice.
83
84 %package apidocs
85 Summary:        libnice library API documentation
86 Summary(pl.UTF-8):      Dokumentacja API biblioteki libnice
87 Group:          Documentation
88 Requires:       gtk-doc-common
89 BuildArch:      noarch
90
91 %description apidocs
92 libnice library API documentation.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki libnice.
96
97 %package -n gstreamer-nice
98 Summary:        ICE source plugin for GStreamer
99 Summary(pl.UTF-8):      Wtyczka źródła ICE dla GStreamera
100 Group:          Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       gstreamer >= 1.0.0
103
104 %description -n gstreamer-nice
105 ICE source plugin for GStreamer.
106
107 %description -n gstreamer-nice -l pl.UTF-8
108 Wtyczka źródła ICE dla GStreamera.
109
110 %prep
111 %setup -q
112
113 %build
114 %{__gtkdocize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --enable-compile-warnings \
122         --enable-gtk-doc \
123         --disable-silent-rules \
124         %{?with_static_libs:--enable-static} \
125         --with-html-dir=%{_gtkdocdir} \
126         --without-gstreamer-0.10
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
137         $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/*.la
138 %if %{with static_libs}
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/*.a
140 %endif
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS COPYING ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_bindir}/stunbdc
152 %attr(755,root,root) %{_bindir}/stund
153 %attr(755,root,root) %{_libdir}/libnice.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libnice.so.10
155 %{_libdir}/girepository-1.0/Nice-0.1.typelib
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libnice.so
160 %{_includedir}/nice
161 %{_includedir}/stun
162 %{_datadir}/gir-1.0/Nice-0.1.gir
163 %{_pkgconfigdir}/nice.pc
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libnice.a
169 %endif
170
171 %files apidocs
172 %defattr(644,root,root,755)
173 %{_gtkdocdir}/libnice
174
175 %files -n gstreamer-nice
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstnice.so
This page took 0.787074 seconds and 3 git commands to generate.