]> git.pld-linux.org Git - packages/libnet.git/blob - libnet.spec
- added using %%{__make} macro.
[packages/libnet.git] / libnet.spec
1 Summary:        Packet creation and handling library
2 Summary(pl):    Biblioteka do generacji i obróbki pakietów
3 Name:           libnet
4 Version:        1.0.1a
5 Release:        1
6 Copyright:      distributable
7 Group:          Development/Libraries
8 Group(fr):      Development/Librairies
9 Group(pl):      Programowanie/Biblioteki
10 Source0:        http://www.packetfactory.net/libnet/dist/%{name}-%{version}.tgz
11 Patch0:         libnet-autoconf.patch
12 URL:            http://www.packetfactory.net/libnet
13 BuildRequires:  libpcap-devel
14 Requires:       libpcap-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Libnet is a collection of routines to help with the construction and
19 sending of network packets at the link layer and the IP layer. Use
20 libnet in conjunction with packet capture library (libpcap) and you
21 can write some really cool stuff!.
22
23 %description -l pl 
24 Libnet jest bibliotek± na któr± sk³adaj± siê procedury pomagaj±ce w
25 tworzeniu i wysy³aniu pakietów w sieciowych warstwach: danych oraz IP.
26 W po³±czeniu z bibliotek± do przechwytywania pakietów (libpcap),
27 libnet pozwoli Ci na napisanie naprawdê fajnych rzeczy!.
28
29 %package demo
30 Summary:        Libnet library - source code of demo programs
31 Summary(pl):    Biblioteka libnet - ¼ród³a programów demonstracyjnych
32 Group:          Development/Libraries
33 Group(fr):      Development/Librairies
34 Group(pl):      Programowanie/Biblioteki
35 Requires:       %{name} = %{version}
36
37 %description demo
38 Libnet library - source code of demo programs
39
40 %description demo -l pl
41 Biblioteka libnet - wersje ¼ród³owe programów demonstracyjnych
42
43
44 %prep
45 %setup -q -n Libnet-%{version}
46 %patch -p0
47
48 rm -rf doc/{.#CHANGELOG.1.13,CVS,html/CVS}
49 rm -rf example/{CVS,html/CVS}
50 rm -rf test/CVS test/*/CVS
51
52 %build
53 autoconf
54 %configure \
55         --with-pf_packet=yes
56
57 %{__make} CFLAGS="$RPM_OPT_FLAGS -funroll-loops -fomit-frame-pointer -Wall"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/libnet/libnet-examples
62
63 %{__make} install DESTDIR=$RPM_BUILD_ROOT
64
65 ln -sf libnet.a $RPM_BUILD_ROOT%{_libdir}/libpwrite.a
66 cp -r example/* $RPM_BUILD_ROOT%{_prefix}/src/examples/libnet/libnet-examples
67 cp -r test/* $RPM_BUILD_ROOT%{_prefix}/src/examples/libnet/
68
69 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
70         doc/{CHANGELOG*,README*,COPYING,TODO*}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc doc/*.gz
78 %attr(755,root,root) %{_bindir}/*
79
80 %{_includedir}/*
81 %{_libdir}/*.a
82 %{_mandir}/man3/*
83
84 %files demo
85 %defattr(644,root,root,755)
86 %{_prefix}/src/examples/libnet
This page took 0.036217 seconds and 4 git commands to generate.