]> git.pld-linux.org Git - packages/libmpcdec.git/blob - libmpcdec.spec
- https source URL
[packages/libmpcdec.git] / libmpcdec.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Musepack SV7 decoding library
6 Summary(pl.UTF-8):      Biblioteka do dekodowania formatu musepack SV7
7 Name:           libmpcdec
8 Version:        1.2.6
9 Release:        4
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://www.musepack.net/index.php?pg=src
13 Source0:        https://files.musepack.net/source/%{name}-%{version}.tar.bz2
14 # Source0-md5:  7f7a060e83b4278acf4b77d7a7b9d2c0
15 Patch0:         ac.patch
16 URL:            https://www.musepack.net/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  sed >= 4.0
21 Obsoletes:      libmusepack
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This library handles decoding of the MPC format, which is an audio
26 compression format with a strong emphasis on high quality. It's not
27 lossless, but it is designed for transparency, so that you won't be
28 able to hear differences between the original wave file and the much
29 smaller MPC file. It is based on the MPEG-1 Layer-2 / MP2 algorithms,
30 but since 1997 it has rapidly developed and vastly improved and is now
31 at an advanced stage in which it contains heavily optimized and
32 patentless code.
33
34 This library handles SV7 (StreamVersion7) format.
35
36 %description -l pl.UTF-8
37 Ta biblioteka obsługuje dekodowanie formatu MPC, który jest formatem
38 kompresji dźwięku z naciskiem na wysoką jakość. Nie jest bezstratny,
39 ale jest zaprojektowany dla przezroczystości tak, że nie można
40 usłyszeć różnicy między oryginalnym plikiem wave a dużo mniejszym
41 plikiem MPC. Jest oparty na algorytmach MPEG-1 Layer-2 / MP2, ale od
42 1997 roku został znacznie rozwinięty i ulepszony, a teraz jest w
43 zaawansowanym stadium, w którym zawiera silnie zoptymalizowany i nie
44 objęty patentami kod.
45
46 Ta biblioteka obsługuje format SV7 (StreamVersion7).
47
48 %package devel
49 Summary:        Header files for libmpcdec
50 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki libmpcdec
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Obsoletes:      libmusepack-devel
54
55 %description devel
56 Header files for libmpcdec.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe do biblioteki libmpcdec.
60
61 %package static
62 Summary:        Static version of the libmpcdec library
63 Summary(pl.UTF-8):      Statyczna wersja biblioteki libmpcdec
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Obsoletes:      libmusepack-static
67
68 %description static
69 Static version of the libmpcdec library.
70
71 %description static -l pl.UTF-8
72 Statyczna wersja biblioteki libmpcdec.
73
74 %package examples
75 Summary:        Example of using libmpcdec with documentation
76 Summary(pl.UTF-8):      Przykład użycia libmpcdec z dokumentacją
77 Group:          Documentation
78
79 %description examples
80 Example of using libmpcdec with documentation.
81
82 %description examples -l pl.UTF-8
83 Przykład użycia libmpcdec z dokumentacją.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{?debug:%{__sed} -i -e "s,-O3 -fomit-frame-pointer,,g" configure.ac}
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?with_static_libs:--disable-static}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 cp -p src/sample.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog
117 %attr(755,root,root) %{_libdir}/libmpcdec.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libmpcdec.so.5
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libmpcdec.so
123 %{_libdir}/libmpcdec.la
124 %{_includedir}/mpcdec
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libmpcdec.a
130 %endif
131
132 %files examples
133 %defattr(644,root,root,755)
134 %{_examplesdir}/%{name}-%{version}
This page took 0.070892 seconds and 4 git commands to generate.