]> git.pld-linux.org Git - packages/libmpcdec.git/blob - libmpcdec.spec
- updated URLs
[packages/libmpcdec.git] / libmpcdec.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Musepack decoding library
6 Summary(pl.UTF-8):      Biblioteka do dekodowania formatu musepack
7 Name:           libmpcdec
8 Version:        1.2.6
9 Release:        4
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://files.musepack.net/source/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7f7a060e83b4278acf4b77d7a7b9d2c0
14 Patch0:         ac.patch
15 URL:            https://www.musepack.net/
16 BuildRequires:  automake
17 BuildRequires:  autoconf
18 BuildRequires:  libtool
19 BuildRequires:  sed >= 4.0
20 Obsoletes:      libmusepack
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This library handles decoding of the MPC format, which is an audio
25 compression format with a strong emphasis on high quality. It's not
26 lossless, but it is designed for transparency, so that you won't be
27 able to hear differences between the original wave file and the much
28 smaller MPC file. It is based on the MPEG-1 Layer-2 / MP2 algorithms,
29 but since 1997 it has rapidly developed and vastly improved and is now
30 at an advanced stage in which it contains heavily optimized and
31 patentless code.
32
33 %description -l pl.UTF-8
34 Ta biblioteka obsługuje dekodowanie formatu MPC, który jest formatem
35 kompresji dźwięku z naciskiem na wysoką jakość. Nie jest bezstratny,
36 ale jest zaprojektowany dla przezroczystości tak, że nie można
37 usłyszeć różnicy między oryginalnym plikiem wave a dużo mniejszym
38 plikiem MPC. Jest oparty na algorytmach MPEG-1 Layer-2 / MP2, ale od
39 1997 roku został znacznie rozwinięty i ulepszony, a teraz jest w
40 zaawansowanym stadium, w którym zawiera silnie zoptymalizowany i nie
41 objęty patentami kod.
42
43 %package devel
44 Summary:        Header files for libmpcdec
45 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki libmpcdec
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Obsoletes:      libmusepack-devel
49
50 %description devel
51 Header files for libmpcdec.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do biblioteki libmpcdec.
55
56 %package static
57 Summary:        Static version of the libmpcdec library
58 Summary(pl.UTF-8):      Statyczna wersja biblioteki libmpcdec
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61 Obsoletes:      libmusepack-static
62
63 %description static
64 Static version of the libmpcdec library.
65
66 %description static -l pl.UTF-8
67 Statyczna wersja biblioteki libmpcdec.
68
69 %package examples
70 Summary:        Example of using libmpcdec with documentation
71 Summary(pl.UTF-8):      Przykład użycia libmpcdec z dokumentacją
72 Group:          Documentation
73
74 %description examples
75 Example of using libmpcdec with documentation.
76
77 %description examples -l pl.UTF-8
78 Przykład użycia libmpcdec z dokumentacją.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %{?debug:%{__sed} -i -e "s,-O3 -fomit-frame-pointer,,g" configure.ac}
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         %{!?with_static_libs:--disable-static}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install src/sample.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog
112 %attr(755,root,root) %{_libdir}/libmpcdec.so.*.*.*
113 %ghost %{_libdir}/libmpcdec.so.5
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libmpcdec.so
118 %{_libdir}/libmpcdec.la
119 %{_includedir}/mpcdec
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libmpcdec.a
125 %endif
126
127 %files examples
128 %defattr(644,root,root,755)
129 %{_examplesdir}/%{name}-%{version}
This page took 0.063042 seconds and 3 git commands to generate.