]> git.pld-linux.org Git - packages/libmicrohttpd.git/blob - libmicrohttpd.spec
- rel 1
[packages/libmicrohttpd.git] / libmicrohttpd.spec
1 %bcond_with     tests
2 Summary:        Embeded HTTP server library
3 Name:           libmicrohttpd
4 Version:        0.4.2
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
9 # Source0-md5:  2853d8f32417e3c5f3b18fda38f96e52
10 URL:            http://www.gnu.org/software/libmicrohttpd/
11 BuildRequires:  autoconf >= 2.61
12 BuildRequires:  automake >= 1:1.10
13 BuildRequires:  libgcrypt-devel >= 1.2.4
14 BuildRequires:  libtool
15 %if %{with tests}
16 BuildRequires:  curl-devel
17 %endif
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 GNU libmicrohttpd is a small C library that is supposed to make it easy to run
22 an HTTP server as part of another application. 
23
24 %package devel
25 Summary:        Header files to develop libmicrohttpd applications
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 Header files to develop libmicrohttpd applications.
31
32 %package static
33 Summary:        Static libmicrohttpd libraries
34 Summary(pl.UTF-8):      Biblioteka statyczna libmicrohttpd
35 Group:          Development/Libraries
36 Requires:       %{name}-devel = %{version}-%{release}
37
38 %description static
39 Static libmicrohttpd libraries.
40
41 %description static -l pl.UTF-8
42 Biblioteka statyczna libmicrohttpd.
43
44 %prep
45 %setup -q
46
47 %build
48 %{__libtoolize}
49 %{__aclocal} -I m4
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake}
53 %configure \
54 %if %{with tests}
55         --enable-curl \
56         --enable-client-side \
57 %endif
58         --enable-https \
59         --disable-messages \
60
61 %{__make}
62 %if %{with tests}
63 %{__make} check
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %post   devel -p /sbin/postshell
81 -/usr/sbin/fix-info-dir -c %{_infodir}
82
83 %postun devel -p /sbin/postshell
84 -/usr/sbin/fix-info-dir -c %{_infodir}
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog NEWS README 
89 %attr(755,root,root) %{_libdir}/libmicrohttpd.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libmicrohttpd.so.5
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/libmicrohttpd.so
95 %{_libdir}/libmicrohttpd.la
96 %{_includedir}/microhttpd.h
97 %{_infodir}/microhttpd.info*
98 %{_mandir}/man3/libmicrohttpd.3*
99 %{_pkgconfigdir}/libmicrohttpd.pc
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libmicrohttpd.a
This page took 0.038889 seconds and 3 git commands to generate.