]> git.pld-linux.org Git - packages/liblangtag.git/blob - liblangtag.spec
- libffi rebuild
[packages/liblangtag.git] / liblangtag.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4 %bcond_without  introspection   # GObject interface
5 %bcond_without  tests           # "make check" call
6 #
7 Summary:        An interface library to access tags for identifying languages
8 Summary(pl.UTF-8):      Biblioteka interfejsu dostępu do znaczników identyfikujących języki
9 Name:           liblangtag
10 Version:        0.5.4
11 Release:        2
12 License:        LGPL v3+
13 Group:          Libraries
14 Source0:        https://bitbucket.org/tagoh/liblangtag/downloads/%{name}-%{version}.tar.bz2
15 # Source0-md5:  6bae8919e5322d96b6fa7cd533523b1f
16 URL:            http://tagoh.bitbucket.org/liblangtag/
17 %{?with_tests:BuildRequires:    check-devel >= 0.9.4}
18 %{?with_introspection:BuildRequires:    glib2-devel >= 2.0}
19 BuildRequires:  gobject-introspection-devel >= 1.30.0
20 BuildRequires:  gtk-doc >= 1.0
21 BuildRequires:  libxml2-devel >= 2.1.0
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 liblangtag is an interface library to access tags for identifying
27 languages.
28
29 Features:
30 - several subtag registry database supports:
31   - language
32   - extlang
33   - script
34   - region
35   - variant
36   - extension
37   - grandfathered
38   - redundant
39 - handling of the language tags
40   - parser
41   - matching
42   - canonicalizing
43
44 %description -l pl.UTF-8
45 liblangtag to biblioteka interfejsu dostępu do znaczników
46 identyfikujących języki.
47
48 Możliwości:
49 - baza danych rejestru podznaczników obsługująca:
50   - język
51   - extlang
52   - pismo
53   - region
54   - wariant
55   - rozszerzenie
56   - dziedziczenie
57   - nadmiarowość
58 - obsługa znaczników języków:
59   - analiza
60   - dopasowywanie
61   - sprowadzanie do postaci kanonicznej
62
63 %package devel
64 Summary:        Development files for liblangtag
65 Summary(pl.UTF-8):      Pliki programistyczne biblioteki liblangtag
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       glib2-devel >= 2.0
69
70 %description devel
71 This package contains the header files for developing applications
72 that use liblangtag.
73
74 %description devel -l pl.UTF-8
75 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
76 wykorzystujących bibliotekę liblangtag.
77
78 %package static
79 Summary:        Static liblangtag library
80 Summary(pl.UTF-8):      Statyczna biblioteka liblangtag
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static liblangtag library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka liblangtag.
89
90 %package gobject
91 Summary:        GObject based interface to liblangtag
92 Summary(pl.UTF-8):      Interfejs GObject do biblioteki liblangtag
93 Group:          Libraries
94 Requires:       %{name} = %{version}-%{release}
95
96 %description gobject
97 GObject based interface to liblangtag.
98
99 %description gobject -l pl.UTF-8
100 Interfejs GObject do biblioteki liblangtag.
101
102 %package gobject-devel
103 Summary:        Header files for liblangtag-gobject library
104 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki liblangtag-gobject
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107 Requires:       %{name}-gobject = %{version}-%{release}
108 Requires:       glib2-devel >= 2.0
109
110 %description gobject-devel
111 Header files for liblangtag-gobject library.
112
113 %description gobject-devel -l pl.UTF-8
114 Pliki nagłówkowe biblioteki liblangtag-gobject.
115
116 %package gobject-static
117 Summary:        Static liblangtag-gobject library
118 Summary(pl.UTF-8):      Statyczna biblioteka liblangtag-gobject
119 Group:          Development/Libraries
120 Requires:       %{name}-gobject-devel = %{version}-%{release}
121
122 %description gobject-static
123 Static liblangtag-gobject library.
124
125 %description gobject-static -l pl.UTF-8
126 Statyczna biblioteka liblangtag-gobject.
127
128 %prep
129 %setup -q
130
131 %build
132 %configure \
133         %{!?with_introspection:--disable-introspection} \
134         --disable-silent-rules \
135         %{?with_static_libs:--enable-static} \
136         %{!?with_tests:--disable-test} \
137         --with-html-dir=%{_gtkdocdir}
138
139 %{__make}
140
141 %{?with_tests:%{__make} check}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
150 %{?with_static_libs:%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %post   gobject -p /sbin/ldconfig
159 %postun gobject -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog NEWS README
164 %attr(755,root,root) %{_libdir}/liblangtag.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/liblangtag.so.1
166 %dir %{_libdir}/%{name}
167 %attr(755,root,root) %{_libdir}/%{name}/liblangtag-ext-ldml-t.so
168 %attr(755,root,root) %{_libdir}/%{name}/liblangtag-ext-ldml-u.so
169 %{_datadir}/%{name}
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root)  %{_libdir}/liblangtag.so
174 %dir %{_includedir}/liblangtag
175 %{_includedir}/liblangtag/langtag.h
176 %{_includedir}/liblangtag/lt-database.h
177 %{_includedir}/liblangtag/lt-error.h
178 %{_includedir}/liblangtag/lt-ext-module.h
179 %{_includedir}/liblangtag/lt-ext-module-data.h
180 %{_includedir}/liblangtag/lt-extension.h
181 %{_includedir}/liblangtag/lt-extlang-db.h
182 %{_includedir}/liblangtag/lt-extlang.h
183 %{_includedir}/liblangtag/lt-grandfathered.h
184 %{_includedir}/liblangtag/lt-grandfathered-db.h
185 %{_includedir}/liblangtag/lt-iter.h
186 %{_includedir}/liblangtag/lt-lang.h
187 %{_includedir}/liblangtag/lt-lang-db.h
188 %{_includedir}/liblangtag/lt-list.h
189 %{_includedir}/liblangtag/lt-macros.h
190 %{_includedir}/liblangtag/lt-redundant.h
191 %{_includedir}/liblangtag/lt-redundant-db.h
192 %{_includedir}/liblangtag/lt-region.h
193 %{_includedir}/liblangtag/lt-region-db.h
194 %{_includedir}/liblangtag/lt-script.h
195 %{_includedir}/liblangtag/lt-script-db.h
196 %{_includedir}/liblangtag/lt-string.h
197 %{_includedir}/liblangtag/lt-tag.h
198 %{_includedir}/liblangtag/lt-variant.h
199 %{_includedir}/liblangtag/lt-variant-db.h
200 %{_pkgconfigdir}/liblangtag.pc
201 %{_gtkdocdir}/liblangtag
202
203 %if %{with static_libs}
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/liblangtag.a
207 %endif
208
209 %if %{with introspection}
210 %files gobject
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/liblangtag-gobject.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/liblangtag-gobject.so.0
214 %{_libdir}/girepository-1.0/LangTag-0.5.typelib
215
216 %files gobject-devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/liblangtag-gobject.so
219 %{_includedir}/liblangtag/lt-gobject.h
220 %{_datadir}/gir-1.0/LangTag-0.5.gir
221 %{_pkgconfigdir}/liblangtag-gobject.pc
222
223 %if %{with static_libs}
224 %files gobject-static
225 %defattr(644,root,root,755)
226 %{_libdir}/liblangtag-gobject.a
227 %endif
228 %endif
This page took 0.093396 seconds and 3 git commands to generate.