]> git.pld-linux.org Git - SPECS.git/blob - libklvanc.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libklvanc.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Library to parse/generate Vertical Ancillary Data
7 Summary(pl.UTF-8):      Biblioteka do analizy/generowania danych VANC
8 Name:           libklvanc
9 # from configure.ac /AC_INIT
10 Version:        1.0
11 %define rel     2
12 %define snap    20190806
13 %define gitref  c38d31b428d0e02061f32c14562d172ec3bd9608
14 Release:        0.%{snap}.%{rel}
15 License:        LGPL v2.1
16 Group:          Libraries
17 Source0:        https://github.com/stoth68000/libklvanc/archive/%{gitref}/%{name}-%{snap}.tar.gz
18 # Source0-md5:  a870bc96decfe8951e5f5ec89e4b6a04
19 Patch0:         %{name}-sh.patch
20 URL:            https://github.com/stoth68000/libklvanc
21 BuildRequires:  autoconf >= 2.68
22 BuildRequires:  automake >= 1:1.11
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Libklvanc is a library which can be used for parsing/generation of
30 Vertical Ancillary Data (VANC) commonly found in the Serial Digital
31 Interface (SDI) wire protocol.
32
33 %description -l pl.UTF-8
34 Libklvanc to biblioteka służąca do analizy i generowania danych VANC
35 (Vertical Ancillary Data), używanych generalnbie w protokole Serial
36 Digital Interface (SDI).
37
38 %package devel
39 Summary:        Header files for libklvanc library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libklvanc
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for libklvanc library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki libklvanc.
49
50 %package static
51 Summary:        Static libklvanc library
52 Summary(pl.UTF-8):      Statyczna biblioteka libklvanc
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libklvanc library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka libklvanc.
61
62 %package apidocs
63 Summary:        API documentation for libklvanc library
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki libklvanc
65 Group:          Documentation
66 BuildArch:      noarch
67
68 %description apidocs
69 API documentation for libklvanc library.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API biblioteki libklvanc.
73
74 %prep
75 %setup -q -n %{name}-%{gitref}
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__automake}
83 # --disable-dep-curses: nothing actually uses it
84 %configure \
85         --disable-dep-curses \
86         --disable-silent-rules \
87         %{!?with_static_libs:--disable-static}
88 %{__make}
89
90 %if %{with apidocs}
91 cd doxygen
92 doxygen libklvanc.doxyconf
93 %endif
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # no external dependencies
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libklvanc.la
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc README.md
113 %attr(755,root,root) %{_bindir}/klvanc_*
114 %attr(755,root,root) %{_libdir}/libklvanc.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libklvanc.so.0
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libklvanc.so
120 %{_includedir}/libklvanc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libklvanc.a
126 %endif
127
128 %if %{with apidocs}
129 %files apidocs
130 %defattr(644,root,root,755)
131 %doc doxygen/html/{search,*.css,*.html,*.js,*.png}
132 %endif
This page took 0.432216 seconds and 3 git commands to generate.