]> git.pld-linux.org Git - packages/libiodbc.git/blob - libiodbc.spec
- added build patch to assure respecting config.h
[packages/libiodbc.git] / libiodbc.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # don't build iodbcadm and GUI elements in drvproxy
4 #
5 Summary:        iODBC Driver Manager
6 Summary(pl.UTF-8):      Zarządca sterowników iODBC
7 Name:           libiodbc
8 Version:        3.52.6
9 Release:        1
10 License:        LGPL v2 or BSD
11 Group:          Libraries
12 Source0:        http://www.iodbc.org/downloads/iODBC/%{name}-%{version}.tar.gz
13 # Source0-md5:  761ad547467bd63ac0b2b4f3ee4b5afb
14 Patch0:         %{name}-make-jN.patch
15 Patch1:         %{name}-build.patch
16 URL:            http://www.iodbc.org/
17 BuildRequires:  autoconf >= 2.57
18 BuildRequires:  automake >= 1.4p5
19 BuildRequires:  gtk+2-devel >= 1:2.0.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The iODBC Driver Manager is a free implementation of the SAG CLI and
26 ODBC compliant driver manager which allows developers to write ODBC
27 compliant applications that can connect to various databases using
28 appropriate backend drivers.
29
30 The iODBC Driver Manager was originally created by Ke Jin and is
31 currently maintained by OpenLink Software under an LGPL license.
32
33 %description -l pl.UTF-8
34 Zarządca sterowników iODBC jest wolną implementacją zarządcy
35 sterowników zgodną z SAG CLI i ODBC, pozwalającą programistom pisać
36 aplikacje zgodne z ODBC, które mogą łączyć się z różnymi bazami
37 z wykorzystaniem właściwych sterowników wewnętrznych.
38
39 Zarządca sterowników iODBC pierwotnie został napisany przez Ke Jina,
40 aktualnie jest rozwijany przez OpenLink Software.
41
42 %package devel
43 Summary:        Header files for iODBC development
44 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwoju aplikacji na iODBC
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 The iODBC Driver Manager is a free implementation of the SAG CLI and
50 ODBC compliant driver manager which allows developers to write ODBC
51 compliant applications that can connect to various databases using
52 appropriate backend drivers.
53
54 This package contains the header files needed to develop program that
55 use the driver manager.
56
57 %description devel -l pl.UTF-8
58 Zarządca sterowników iODBC jest wolną implementacją zarządcy
59 sterowników zgodną z SAG CLI i ODBC, pozwalającą programistom pisać
60 aplikacje zgodne z ODBC, które mogą łączyć się z różnymi bazami
61 z wykorzystaniem właściwych sterowników wewnętrznych.
62
63 Ten pakiet zawiera pliki nagłówkowe potrzebne do budowania aplikacji
64 korzystających z zarządcy sterowników iODBC.
65
66 %package static
67 Summary:        Static version of iODBC libraries
68 Summary(pl.UTF-8):      Statyczna wersja bibliotek iODBC
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static version of iODBC libraries.
74
75 %description static -l pl.UTF-8
76 Statyczna wersja bibliotek iODBC.
77
78 %package gtk
79 Summary:        GTK+-based GUI for iODBC administration
80 Summary(pl.UTF-8):      Oparty o GTK+ interfejs do administrowania iODBC
81 Group:          X11/Applications
82 Requires:       %{name} = %{version}-%{release}
83
84 %description gtk
85 GTK+-based GUI for iODBC administration.
86
87 %description gtk -l pl.UTF-8
88 Oparty o GTK+ graficzny interfejs do administrowania iODBC.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I admin
98 %{__automake}
99 %{__autoheader}
100 %{__autoconf}
101 %configure \
102         %{!?with_gtk:--disable-gui}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_sysconfdir}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install etc/odbc.ini.sample $RPM_BUILD_ROOT%{_sysconfdir}/odbc.ini
114 rm -rf $RPM_BUILD_ROOT/usr/share/libiodbc/samples/
115
116 # dlopened by lib*.so
117 rm -f $RPM_BUILD_ROOT%{_libdir}/lib{iodbcadm,drvproxy}.{a,la}
118 # build process side-effects
119 rm -f $RPM_BUILD_ROOT%{_libdir}/lib{iodbcadm,drvproxy}-gtk.{a,la}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %post   gtk -p /sbin/ldconfig
128 %postun gtk -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog LICENSE LICENSE.BSD NEWS README
133 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/odbc.ini
134 %attr(755,root,root) %{_bindir}/iodbctest
135 %attr(755,root,root) %{_bindir}/iodbctestw
136 %attr(755,root,root) %{_libdir}/libiodbc.so.2.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libiodbc.so.2
138 %attr(755,root,root) %{_libdir}/libiodbcinst.so.2.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libiodbcinst.so.2
140 %{_mandir}/man1/iodbctest.1*
141 %{_mandir}/man1/iodbctestw.1
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/iodbc-config
146 %attr(755,root,root) %{_libdir}/libiodbc.so
147 %attr(755,root,root) %{_libdir}/libiodbcinst.so
148 %{_libdir}/libiodbc.la
149 %{_libdir}/libiodbcinst.la
150 %{_includedir}/*.h
151 %{_pkgconfigdir}/libiodbc.pc
152 %{_mandir}/man1/iodbc-config.1*
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libiodbc.a
157 %{_libdir}/libiodbcinst.a
158
159 %if %{with gtk}
160 %files gtk
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/iodbcadm-gtk
163 %attr(755,root,root) %{_libdir}/libiodbcadm.so.2.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libiodbcadm.so.2
165 %attr(755,root,root) %{_libdir}/libdrvproxy.so.2.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libdrvproxy.so.2
167 %attr(755,root,root) %{_libdir}/libiodbcadm.so
168 %attr(755,root,root) %{_libdir}/libdrvproxy.so
169 %{_mandir}/man1/iodbcadm-gtk.1*
170 %endif
This page took 0.040124 seconds and 3 git commands to generate.