]> git.pld-linux.org Git - SPECS.git/blob - libhsts.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libhsts.spec
1 #
2 # Conditional build:
3 %bcond_with     pandoc          # build man pages with pandoc
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        C library to access the HSTS preload list
7 Name:           libhsts
8 Version:        0.1.0
9 Release:        3
10 License:        BSD
11 Group:          Libraries
12 Source0:        https://gitlab.com/rockdaboot/libhsts/uploads/4753f61b5a3c6253acf4934217816e3f/%{name}-%{version}.tar.gz
13 # Source0-md5:  5599c8b2530df6b26ed5e766a8d9ed3c
14 URL:            https://gitlab.com/rockdaboot/libhsts
15 BuildRequires:  doxygen
16 %{?with_pandoc:BuildRequires:   pandoc}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The HSTS preload list is a list of domains that support HTTPS. The
21 list is compiled by Google and is utilised by Chrome, Firefox and
22 others. With this information, a HTTP client may contact a website
23 without trying a plain-text HTTP connection first. It prevents
24 interception with redirects that take place over HTTP. None of the
25 sent data will ever be unencrypted.
26
27 %package devel
28 Summary:        Header files and develpment documentation for libhsts
29 Summary(es.UTF-8):      Arquivos de cabeçalho e bibliotecas de desenvolvimento para libhsts
30 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do libhsts
31 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para a libhsts
32 Summary(ru.UTF-8):      Хедеры и библиотеки програмиста для libhsts
33 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для libhsts
34 Group:          Development/Libraries
35 Requires:       %{name} = %{?epoch}:%{version}-%{release}
36
37 %description devel
38 The HSTS preload list is a list of domains that support HTTPS. The
39 list is compiled by Google and is utilised by Chrome, Firefox and
40 others. With this information, a HTTP client may contact a website
41 without trying a plain-text HTTP connection first. It prevents
42 interception with redirects that take place over HTTP. None of the
43 sent data will ever be unencrypted.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe i dokumentacja do libhsts.
47
48 %package static
49 Summary:        Static libhsts library
50 Summary(es.UTF-8):      Biblioteca estática usada no desenvolvimento de aplicativos com libhsts
51 Summary(pl.UTF-8):      Biblioteka statyczna libhsts
52 Summary(pt_BR.UTF-8):   Biblioteca estática de desenvolvimento
53 Summary(ru.UTF-8):      Статическая библиотека libhsts
54 Summary(uk.UTF-8):      Статична бібліотека libhsts
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{?epoch}:%{version}-%{release}
57
58 %description static
59 Static libhsts library.
60
61 %description static -l pl.UTF-8
62 Biblioteka statyczna libhsts.
63
64 %description static -l ru.UTF-8
65 Статическая библиотека, необходимая для программирования с libhsts.
66
67 %description static -l uk.UTF-8
68 Статична бібліотека, необхідна для програмування з libhsts.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure  \
75         --disable-silent-rules
76
77 %{__make}
78
79 %{?with_tests:%{__make} check}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %if %{without pandoc}
88 install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3}
89 cp -p docs/man/man1/hsts*.1 $RPM_BUILD_ROOT%{_mandir}/man1
90 cp -p docs/man/man3/libhsts.3 $RPM_BUILD_ROOT%{_mandir}/man3
91 %endif
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS NEWS
102 %attr(755,root,root) %{_bindir}/hsts
103 %attr(755,root,root) %{_libdir}/libhsts.so.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libhsts.so.0
105 %{_mandir}/man1/hsts.1*
106 %{_mandir}/man1/hsts-make-dafsa.1*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libhsts.so
111 %{_includedir}/libhsts.h
112 %{_libdir}/libhsts.la
113 %{_pkgconfigdir}/libhsts.pc
114 %{_mandir}/man3/libhsts.3*
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libhsts.a
This page took 0.437318 seconds and 3 git commands to generate.