]> git.pld-linux.org Git - packages/libggi.git/blob - libggi.spec
e349c5c16ae5d3dc8eb00b43dd7d6f2d6e9fa031
[packages/libggi.git] / libggi.spec
1 #
2 # Conditional build:
3 %bcond_with     glide   # with Glide support
4 %bcond_with     kgicon  # with KGICon support
5 %bcond_without  aalib   # without aalib support
6 %bcond_without  svga    # without svgalib support
7 #
8 Summary:        GGI - Generic Graphics Interface
9 Summary(pl):    GGI - Generic Graphics Interface
10 Name:           libggi
11 Version:        2.1.2
12 Release:        1
13 Epoch:          1
14 License:        BSD-like
15 Group:          Libraries
16 Source0:        http://www.ggi-project.org/ftp/ggi/v2.1/%{name}-%{version}.src.tar.bz2
17 # Source0-md5:  f29e844011425ab14706e31a4cdee181
18 URL:            http://www.ggi-project.org/
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_aalib:BuildRequires:    aalib-devel}
23 %{?with_glide:BuildRequires:    glide-devel}
24 %{?with_kgicon:BuildRequires:   kgicon-devel}
25 BuildRequires:  libgii-devel >= 0.9.2
26 BuildRequires:  libtool >= 1:1.4.2-9
27 BuildRequires:  ncurses-devel
28 %{?with_svga:BuildRequires:     svgalib-devel}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 LibGGI, the dynamic GGI (General Graphics Interface) library is a
33 flexible drawing library.
34
35 It provides an opaque interface to the display's acceleration
36 functions. It was originally intended to allow user programs to
37 interface with KGI, the GGI Kernel Graphics Interface, but other
38 display types can be easily used by loading the appropriate "display
39 target" (e.g. X, memory).
40
41 %description -l pl
42 LibGGI, dynamiczne GGI (General Graphics Interface - Generalny
43 Interfejs Graficzny) jest bibliotek± obs³ugi grafiki.
44
45 Dostarcza ona jednolity interfejs do akcelerowanych funkcji
46 wy¶wietlania. Oryginalnie biblioteka zosta³a stworzona do
47 wspó³dzia³ania z KGI (GGI Kernel Graphic Interface) ale inne
48 sterowniki wy¶wietlania mog± byæ ³atwo u¿ywane.
49
50 %package aa
51 Summary:        aalib target for LibGGI
52 Summary(pl):    Obs³uga aalib dla LibGGI
53 Group:          Libraries
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55
56 %description aa
57 LibGGI target for displaying graphics using ascii-art-library.
58
59 %description aa -l pl
60 Modu³ LibGGI do obs³ugi grafiki poprzez bibliotekê ascii-art.
61
62 %package svgalib
63 Summary:        SVGALib target for LibGGI
64 Summary(pl):    Obs³uga SVGALib dla LibGGI
65 Group:          Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67
68 %description svgalib
69 LibGGI target for displaying via SVGALib.
70
71 %description svgalib -l pl
72 Modu³ LibGGI do obs³ugi grafiki poprzez bibliotekê SVGALib.
73
74 %package X11
75 Summary:        X11 targets for LibGGI
76 Summary(pl):    Obs³uga X11 dla LibGGI
77 Group:          Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79
80 %description X11
81 LibGGI targets for displaing in X:
82  - x - graphics via X-protocol
83  - xlib - graphics via X-library
84  - dga - graphics via XFree86 DGA extension
85
86 %description X11 -l pl
87 Modu³y LibGGI do obs³ugi grafiki w XWindow:
88  - x - grafika poprzez protokó³ X
89  - xlib - grafika poprzez bibliotekê xlib
90  - dga - grafika poprzez rozszerzenie X DGA
91
92 %package glide
93 Summary:        Glide (3DFX) target for LibGGI
94 Summary(pl):    Obs³uga Glide (3DFX) dla LibGGI
95 Group:          Libraries
96 Requires:       %{name} = %{epoch}:%{version}-%{release}
97
98 %description glide
99 GGI Glide target.
100
101 %description glide -l pl
102 Modu³ do obs³ugi grafiki poprzez Glide.
103
104 %package programs
105 Summary:        Utilities and demos for GGI
106 Summary(pl):    Programy narzêdziowe i przyk³adowe dla LibGGI
107 Group:          Development/Libraries
108 Requires:       %{name} = %{epoch}:%{version}-%{release}
109 Obsoletes:      libggi-demos
110
111 %description programs
112 Various utilities and demos for GGI.
113
114 %description programs -l pl
115 Ró¿ne programy oraz dema dla GGI
116
117 %package devel
118 Summary:        Development part of LibGGI
119 Summary(pl):    Czê¶æ dla programistów biblioteki LibGGI
120 Group:          Development/Libraries
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122 Requires:       libgii-devel >= 0.9.2
123
124 %description devel
125 Development part of LibGGI.
126
127 %description devel -l pl
128 Pliki potrzebne do programowania z wykorzystaniem LibGGI.
129
130 %prep
131 %setup -q
132
133 rm -f m4/{libtool,ltdl}.m4
134
135 %build
136 %{__libtoolize}
137 %{__aclocal} -I m4
138 %{__autoheader}
139 %{__autoconf}
140 %{__automake}
141 CPPFLAGS="-I/usr/include/glide -I/usr/include/directfb -I/usr/include/directfb-internal"
142 %configure \
143         %{!?debug:--disable-debug} \
144         %{!?with_glide:--disable-glide} \
145         %{!?with_kgicon:--disable-genkgi} \
146         --disable-directfb \
147         %{!?with_svga:--disable-svga --disable-vgagl} \
148         %{!?with_aalib:--disable-aa} \
149         --sysconfdir=%{_sysconfdir} \
150         --enable-threads
151 %{__make}
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
156
157 %{__make} install \
158         DESTDIR="$RPM_BUILD_ROOT"
159
160 install programs/demos/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
161 install programs/demos/Makefile $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
162 install config.h $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
163
164 # demos which are nice, but not installed by make install
165 install programs/demos/.libs/flying_ggis $RPM_BUILD_ROOT%{_bindir}
166 install programs/demos/.libs/slimy $RPM_BUILD_ROOT%{_bindir}
167 install programs/demos/.libs/stars $RPM_BUILD_ROOT%{_bindir}
168
169 rm -f $RPM_BUILD_ROOT%{_libdir}/ggi/{default,default/fbdev/*,display,helper}/*.la
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc README NEWS doc/*.txt
180 %dir %{_libdir}/ggi/default
181 %dir %{_libdir}/ggi/default/fbdev
182 %dir %{_libdir}/ggi/default/fbdev/*
183 %dir %{_libdir}/ggi/display
184
185 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ggi/*.conf
186 %dir %{_sysconfdir}/ggi/targets
187 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ggi/targets/*.conf
188
189 %attr(755,root,root) %{_libdir}/lib*.so.*.*
190 %attr(755,root,root) %{_libdir}/ggi/default/fbdev/*/*.so
191 %attr(755,root,root) %{_libdir}/ggi/default/*.so
192 %attr(755,root,root) %{_libdir}/ggi/display/auto.so
193 %attr(755,root,root) %{_libdir}/ggi/display/fbdev.so
194 %attr(755,root,root) %{_libdir}/ggi/display/file.so
195 %attr(755,root,root) %{_libdir}/ggi/display/ipc.so
196 %ifarch ppc
197 %attr(755,root,root) %{_libdir}/ggi/display/lcd823.so
198 %endif
199 %attr(755,root,root) %{_libdir}/ggi/display/linvtsw.so
200 %attr(755,root,root) %{_libdir}/ggi/display/mansync.so
201 %attr(755,root,root) %{_libdir}/ggi/display/memory.so
202 %attr(755,root,root) %{_libdir}/ggi/display/monotext.so
203 %attr(755,root,root) %{_libdir}/ggi/display/multi.so
204 %attr(755,root,root) %{_libdir}/ggi/display/palemu.so
205 %attr(755,root,root) %{_libdir}/ggi/display/sub.so
206 %attr(755,root,root) %{_libdir}/ggi/display/tele.so
207 %attr(755,root,root) %{_libdir}/ggi/display/terminfo.so
208 %attr(755,root,root) %{_libdir}/ggi/display/tile.so
209 %attr(755,root,root) %{_libdir}/ggi/display/trueemu.so
210 %attr(755,root,root) %{_libdir}/ggi/display/vcsa.so
211
212 %{_mandir}/man7/*
213
214 %if %{with aalib}
215 %files aa
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/ggi/display/aa.so
218 %endif
219
220 %if %{with svga}
221 %files svgalib
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/ggi/display/svga*.so
224 %attr(755,root,root) %{_libdir}/ggi/display/vgagl.so
225 %endif
226
227 %files X11
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/ggi/display/X*.so
230 %attr(755,root,root) %{_libdir}/ggi/display/xf86dga.so
231 %dir %{_libdir}/ggi/helper
232 %attr(755,root,root) %{_libdir}/ggi/helper/helper_x_*.so
233
234 %if %{with glide}
235 %files glide
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/ggi/display/glide.so
238 %endif
239
240 %files programs
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_bindir}/*
243 %{_mandir}/man1/*
244
245 %files devel
246 %defattr(644,root,root,755)
247 %doc ChangeLog
248 %{_includedir}/ggi/*.h
249 %{_includedir}/ggi/display
250 %{_includedir}/ggi/internal/*.h
251 %attr(755,root,root) %{_libdir}/lib*.so
252 %{_libdir}/lib*.la
253 %{_mandir}/man3/*
254 %{_examplesdir}/%{name}-%{version}
This page took 0.110989 seconds and 3 git commands to generate.