]> git.pld-linux.org Git - packages/libggi.git/blob - libggi.spec
- converted to UTF-8
[packages/libggi.git] / libggi.spec
1 #
2 # Conditional build:
3 %bcond_with     glide   # with Glide support
4 %bcond_with     kgicon  # with KGICon support
5 %bcond_without  aalib   # without aalib support
6 %bcond_without  svga    # without svgalib support
7 #
8 Summary:        GGI - Generic Graphics Interface
9 Summary(pl.UTF-8):   GGI - Generic Graphics Interface
10 Name:           libggi
11 Version:        2.1.2
12 Release:        2
13 Epoch:          1
14 License:        BSD-like
15 Group:          Libraries
16 Source0:        http://www.ggi-project.org/ftp/ggi/v2.1/%{name}-%{version}.src.tar.bz2
17 # Source0-md5:  f29e844011425ab14706e31a4cdee181
18 Patch0:         %{name}-ppc.patch
19 Patch1:         %{name}-gcc4.1.patch
20 Patch2:         %{name}-gcc4.patch
21 Patch3:         %{name}-glibc24.patch
22 URL:            http://www.ggi-project.org/
23 %{?with_aalib:BuildRequires:    aalib-devel}
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?with_glide:BuildRequires:    glide-devel}
27 BuildRequires:  libgii-devel >= 0.9.2
28 BuildRequires:  libtool >= 1:1.4.2-9
29 BuildRequires:  ncurses-devel
30 %{?with_svga:BuildRequires:     svgalib-devel}
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXxf86dga-devel
34 BuildRequires:  xorg-lib-libXxf86vm-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 LibGGI, the dynamic GGI (General Graphics Interface) library is a
39 flexible drawing library.
40
41 It provides an opaque interface to the display's acceleration
42 functions. It was originally intended to allow user programs to
43 interface with KGI, the GGI Kernel Graphics Interface, but other
44 display types can be easily used by loading the appropriate "display
45 target" (e.g. X, memory).
46
47 %description -l pl.UTF-8
48 LibGGI, dynamiczne GGI (General Graphics Interface - Generalny
49 Interfejs Graficzny) jest biblioteką obsługi grafiki.
50
51 Dostarcza ona jednolity interfejs do akcelerowanych funkcji
52 wyświetlania. Oryginalnie biblioteka została stworzona do
53 współdziałania z KGI (GGI Kernel Graphic Interface) ale inne
54 sterowniki wyświetlania mogą być łatwo używane.
55
56 %package aa
57 Summary:        aalib target for LibGGI
58 Summary(pl.UTF-8):   Obsługa aalib dla LibGGI
59 Group:          Libraries
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61
62 %description aa
63 LibGGI target for displaying graphics using ascii-art-library.
64
65 %description aa -l pl.UTF-8
66 Moduł LibGGI do obsługi grafiki poprzez bibliotekę ascii-art.
67
68 %package svgalib
69 Summary:        SVGALib target for LibGGI
70 Summary(pl.UTF-8):   Obsługa SVGALib dla LibGGI
71 Group:          Libraries
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73
74 %description svgalib
75 LibGGI target for displaying via SVGALib.
76
77 %description svgalib -l pl.UTF-8
78 Moduł LibGGI do obsługi grafiki poprzez bibliotekę SVGALib.
79
80 %package X11
81 Summary:        X11 targets for LibGGI
82 Summary(pl.UTF-8):   Obsługa X11 dla LibGGI
83 Group:          Libraries
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85
86 %description X11
87 LibGGI targets for displaing in X:
88  - x - graphics via X-protocol
89  - xlib - graphics via X-library
90  - dga - graphics via XFree86 DGA extension
91
92 %description X11 -l pl.UTF-8
93 Moduły LibGGI do obsługi grafiki w XWindow:
94  - x - grafika poprzez protokół X
95  - xlib - grafika poprzez bibliotekę xlib
96  - dga - grafika poprzez rozszerzenie X DGA
97
98 %package glide
99 Summary:        Glide (3DFX) target for LibGGI
100 Summary(pl.UTF-8):   Obsługa Glide (3DFX) dla LibGGI
101 Group:          Libraries
102 Requires:       %{name} = %{epoch}:%{version}-%{release}
103
104 %description glide
105 GGI Glide target.
106
107 %description glide -l pl.UTF-8
108 Moduł do obsługi grafiki poprzez Glide.
109
110 %package programs
111 Summary:        Utilities and demos for GGI
112 Summary(pl.UTF-8):   Programy narzędziowe i przykładowe dla LibGGI
113 Group:          Development/Libraries
114 Requires:       %{name} = %{epoch}:%{version}-%{release}
115 Obsoletes:      libggi-demos
116
117 %description programs
118 Various utilities and demos for GGI.
119
120 %description programs -l pl.UTF-8
121 Różne programy oraz dema dla GGI
122
123 %package devel
124 Summary:        Development part of LibGGI
125 Summary(pl.UTF-8):   Część dla programistów biblioteki LibGGI
126 Group:          Development/Libraries
127 Requires:       %{name} = %{epoch}:%{version}-%{release}
128 Requires:       libgii-devel >= 0.9.2
129
130 %description devel
131 Development part of LibGGI.
132
133 %description devel -l pl.UTF-8
134 Pliki potrzebne do programowania z wykorzystaniem LibGGI.
135
136 %prep
137 %setup -q
138 %patch0 -p1
139 %patch1 -p1
140 %patch2 -p0
141 %patch3 -p1
142
143 rm -f m4/{libtool,ltdl}.m4
144
145 %build
146 %{__libtoolize}
147 %{__aclocal} -I m4
148 %{__autoheader}
149 %{__autoconf}
150 %{__automake}
151 CPPFLAGS="-I/usr/include/glide -I/usr/include/directfb -I/usr/include/directfb-internal"
152 %configure \
153         %{!?debug:--disable-debug} \
154         %{!?with_glide:--disable-glide} \
155         %{!?with_kgicon:--disable-genkgi} \
156         --disable-directfb \
157         %{!?with_svga:--disable-svga --disable-vgagl} \
158         %{!?with_aalib:--disable-aa} \
159         --sysconfdir=%{_sysconfdir} \
160         --enable-threads
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
166
167 %{__make} install \
168         DESTDIR="$RPM_BUILD_ROOT"
169
170 install programs/demos/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171 install programs/demos/Makefile $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
172 install config.h $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
173
174 # demos which are nice, but not installed by make install
175 install programs/demos/.libs/flying_ggis $RPM_BUILD_ROOT%{_bindir}
176 install programs/demos/.libs/slimy $RPM_BUILD_ROOT%{_bindir}
177 install programs/demos/.libs/stars $RPM_BUILD_ROOT%{_bindir}
178
179 rm -f $RPM_BUILD_ROOT%{_libdir}/ggi/{default,default/fbdev/*,display,helper}/*.la
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc README NEWS doc/*.txt
190 %dir %{_libdir}/ggi/default
191 %dir %{_libdir}/ggi/default/fbdev
192 %dir %{_libdir}/ggi/default/fbdev/*
193 %dir %{_libdir}/ggi/display
194
195 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggi/*.conf
196 %dir %{_sysconfdir}/ggi/targets
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggi/targets/*.conf
198
199 %attr(755,root,root) %{_libdir}/lib*.so.*.*
200 %attr(755,root,root) %{_libdir}/ggi/default/fbdev/*/*.so
201 %attr(755,root,root) %{_libdir}/ggi/default/*.so
202 %attr(755,root,root) %{_libdir}/ggi/display/auto.so
203 %attr(755,root,root) %{_libdir}/ggi/display/fbdev.so
204 %attr(755,root,root) %{_libdir}/ggi/display/file.so
205 %attr(755,root,root) %{_libdir}/ggi/display/ipc.so
206 %ifarch ppc
207 %attr(755,root,root) %{_libdir}/ggi/display/lcd823.so
208 %endif
209 %attr(755,root,root) %{_libdir}/ggi/display/linvtsw.so
210 %attr(755,root,root) %{_libdir}/ggi/display/mansync.so
211 %attr(755,root,root) %{_libdir}/ggi/display/memory.so
212 %attr(755,root,root) %{_libdir}/ggi/display/monotext.so
213 %attr(755,root,root) %{_libdir}/ggi/display/multi.so
214 %attr(755,root,root) %{_libdir}/ggi/display/palemu.so
215 %attr(755,root,root) %{_libdir}/ggi/display/sub.so
216 %attr(755,root,root) %{_libdir}/ggi/display/tele.so
217 %attr(755,root,root) %{_libdir}/ggi/display/terminfo.so
218 %attr(755,root,root) %{_libdir}/ggi/display/tile.so
219 %attr(755,root,root) %{_libdir}/ggi/display/trueemu.so
220 %attr(755,root,root) %{_libdir}/ggi/display/vcsa.so
221
222 %{_mandir}/man7/*
223
224 %if %{with aalib}
225 %files aa
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/ggi/display/aa.so
228 %endif
229
230 %if %{with svga}
231 %files svgalib
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/ggi/display/svga*.so
234 %attr(755,root,root) %{_libdir}/ggi/display/vgagl.so
235 %endif
236
237 %files X11
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_libdir}/ggi/display/X*.so
240 %attr(755,root,root) %{_libdir}/ggi/display/xf86dga.so
241 %dir %{_libdir}/ggi/helper
242 %attr(755,root,root) %{_libdir}/ggi/helper/helper_x_*.so
243
244 %if %{with glide}
245 %files glide
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/ggi/display/glide.so
248 %endif
249
250 %files programs
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_bindir}/*
253 %{_mandir}/man1/*
254
255 %files devel
256 %defattr(644,root,root,755)
257 %doc ChangeLog
258 %{_includedir}/ggi/*.h
259 %{_includedir}/ggi/display
260 %{_includedir}/ggi/internal/*.h
261 %attr(755,root,root) %{_libdir}/lib*.so
262 %{_libdir}/lib*.la
263 %{_mandir}/man3/*
264 %{_examplesdir}/%{name}-%{version}
This page took 0.037511 seconds and 3 git commands to generate.