]> git.pld-linux.org Git - packages/libgcrypt.git/blob - libgcrypt.spec
- rel 2
[packages/libgcrypt.git] / libgcrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Cryptographic library based on the code from GnuPG
6 Summary(es.UTF-8):      Libgcrypt es una biblioteca general de desarrole embasada em GnuPG
7 Summary(pl.UTF-8):      Biblioteka kryptograficzna oparta na kodzie GnuPG
8 Summary(pt_BR.UTF-8):   libgcrypt é uma biblioteca de criptografia de uso geral baseada no GnuPG
9 Name:           libgcrypt
10 Version:        1.2.4
11 Release:        2
12 License:        LGPL
13 Group:          Libraries
14 # devel versions:
15 #Source0:       ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/%{name}-%{version}.tar.gz
16 Source0:        ftp://ftp.gnupg.org/gcrypt/libgcrypt/%{name}-%{version}.tar.bz2
17 # Source0-md5:  3675d3e74c3a44aed629d9b12a30bb51
18 Patch0:         %{name}-no_libnsl.patch
19 Patch1:         %{name}-info.patch
20 Patch2:         %{name}-sparc64.patch
21 Patch3:         %{name}-libgcrypt_config.patch
22 URL:            http://www.gnu.org/directory/security/libgcrypt.html
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1:1.9.3
25 BuildRequires:  binutils >= 2:2.12
26 BuildRequires:  gcc >= 5:3.2
27 BuildRequires:  libgpg-error-devel >= 0.5
28 BuildRequires:  libtool >= 1:1.4.3
29 BuildRequires:  texinfo
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is a general purpose cryptographic library based on the code from
34 GnuPG. It provides functions for all cryptograhic building blocks:
35 symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash
36 algorithms (MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all
37 hash algorithms), public key algorithms (RSA, ElGamal, DSA), large
38 integer functions, random numbers and a lot of supporting functions.
39
40 %description -l pl.UTF-8
41 Ten pakiet zawiera bibliotekę kryptograficzną ogólnego przeznaczenia,
42 opartą na kodzie GnuPG. Biblioteka ta dostarcza funkcje do wszystkich
43 podstawowych bloków kryptografii: szyfrów symetrycznych (AES, DES,
44 Blowfish, CAST5, Twofish, Acrfour), algorytmów mieszających (MD5,
45 RIPE-MD160, SHA-1, RIGER-192), MAC-ów (HMAC dla wszystkich algorytmów
46 mieszających), algorytmów klucza publicznego (RSA, ElGamal, DSA),
47 funkcji dużych liczb całkowitych, liczb losowych i wiele funkcji
48 pomocniczych.
49
50 %description -l pt_BR.UTF-8
51 Libgcrypt é uma biblioteca de criptografia de uso geral baseada no
52 GnuPG.
53
54 %package devel
55 Summary:        Header files etc to develop libgcrypt applications
56 Summary(es.UTF-8):      Archivos de desarrollo de libgcrypt
57 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do libgcrypt
58 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento da libgcrypt
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       libgpg-error-devel >= 0.5
62
63 %description devel
64 Header files etc to develop libgcrypt applications.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe i inne do libgcrypt.
68
69 %description devel -l pt_BR.UTF-8
70 Bibliotecas de desenvolvimento para libgcrypt.
71
72 %package static
73 Summary:        Static libgcrypt library
74 Summary(es.UTF-8):      Archivos de desarrollo de libgcrypt - estatico
75 Summary(pl.UTF-8):      Biblioteka statyczna libgcrypt
76 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento da libgcrypt - biblioteca estática
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libgcrypt library.
82
83 %description static -l pl.UTF-8
84 Biblioteka statyczna libgcrypt.
85
86 %description static -l pt_BR.UTF-8
87 Bibliotecas de desenvolvimento para libgcrypt - estático.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95
96 %build
97 rm -f m4/libtool.m4
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --enable-static \
104         %{!?with_static_libs:--disable-static}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         m4datadir=%{_aclocaldir}
114
115 install -d $RPM_BUILD_ROOT/%{_lib}
116 mv -f $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
117 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libgcrypt.so.*.*.*) \
118         $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %post devel
127 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
128
129 %postun devel
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS THANKS NEWS README ChangeLog
135 %attr(755,root,root) /%{_lib}/libgcrypt.so.*.*.*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/libgcrypt-config
140 %attr(755,root,root) %{_libdir}/libgcrypt.so
141 %{_libdir}/libgcrypt.la
142 %{_infodir}/*.info*
143 %{_includedir}/*.h
144 %{_aclocaldir}/*.m4
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgcrypt.a
150 %endif
This page took 0.035411 seconds and 4 git commands to generate.