]> git.pld-linux.org Git - packages/libgcrypt.git/blob - libgcrypt.spec
- release 2
[packages/libgcrypt.git] / libgcrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Cryptographic library based on the code from GnuPG
6 Summary(es.UTF-8):      Libgcrypt es una biblioteca general de desarrole embasada em GnuPG
7 Summary(pl.UTF-8):      Biblioteka kryptograficzna oparta na kodzie GnuPG
8 Summary(pt_BR.UTF-8):   libgcrypt é uma biblioteca de criptografia de uso geral baseada no GnuPG
9 Name:           libgcrypt
10 Version:        1.4.1
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          Libraries
14 # devel versions:
15 #Source0:       ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/%{name}-%{version}.tar.gz
16 Source0:        ftp://ftp.gnupg.org/gcrypt/libgcrypt/%{name}-%{version}.tar.bz2
17 # Source0-md5:  26703ecef4bbe113b8e6a87572b80b32
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-sparc64.patch
20 Patch2:         %{name}-libgcrypt_config.patch
21 URL:            http://www.gnu.org/directory/security/libgcrypt.html
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake >= 1:1.9.3
24 BuildRequires:  binutils >= 2:2.12
25 BuildRequires:  gcc >= 5:3.2
26 BuildRequires:  libgpg-error-devel >= 0.5
27 BuildRequires:  libtool >= 1:1.4.3
28 BuildRequires:  texinfo
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This is a general purpose cryptographic library based on the code from
33 GnuPG. It provides functions for all cryptograhic building blocks:
34 symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash
35 algorithms (MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all
36 hash algorithms), public key algorithms (RSA, ElGamal, DSA), large
37 integer functions, random numbers and a lot of supporting functions.
38
39 %description -l pl.UTF-8
40 Ten pakiet zawiera bibliotekę kryptograficzną ogólnego przeznaczenia,
41 opartą na kodzie GnuPG. Biblioteka ta dostarcza funkcje do wszystkich
42 podstawowych bloków kryptografii: szyfrów symetrycznych (AES, DES,
43 Blowfish, CAST5, Twofish, Acrfour), algorytmów mieszających (MD5,
44 RIPE-MD160, SHA-1, RIGER-192), MAC-ów (HMAC dla wszystkich algorytmów
45 mieszających), algorytmów klucza publicznego (RSA, ElGamal, DSA),
46 funkcji dużych liczb całkowitych, liczb losowych i wiele funkcji
47 pomocniczych.
48
49 %description -l pt_BR.UTF-8
50 Libgcrypt é uma biblioteca de criptografia de uso geral baseada no
51 GnuPG.
52
53 %package devel
54 Summary:        Header files etc to develop libgcrypt applications
55 Summary(es.UTF-8):      Archivos de desarrollo de libgcrypt
56 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do libgcrypt
57 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento da libgcrypt
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       libgpg-error-devel >= 0.5
61
62 %description devel
63 Header files etc to develop libgcrypt applications.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe i inne do libgcrypt.
67
68 %description devel -l pt_BR.UTF-8
69 Bibliotecas de desenvolvimento para libgcrypt.
70
71 %package static
72 Summary:        Static libgcrypt library
73 Summary(es.UTF-8):      Archivos de desarrollo de libgcrypt - estatico
74 Summary(pl.UTF-8):      Biblioteka statyczna libgcrypt
75 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento da libgcrypt - biblioteca estática
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libgcrypt library.
81
82 %description static -l pl.UTF-8
83 Biblioteka statyczna libgcrypt.
84
85 %description static -l pt_BR.UTF-8
86 Bibliotecas de desenvolvimento para libgcrypt - estático.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 rm m4/libtool.m4
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --enable-static \
102         %{!?with_static_libs:--disable-static}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         m4datadir=%{_aclocaldir}
112
113 install -d $RPM_BUILD_ROOT/%{_lib}
114 mv -f $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so.* $RPM_BUILD_ROOT/%{_lib}
115 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libgcrypt.so.*.*.*) \
116         $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %post   devel -p        /sbin/postshell
125 -/usr/sbin/fix-info-dir -c %{_infodir}
126
127 %postun devel -p        /sbin/postshell
128 -/usr/sbin/fix-info-dir -c %{_infodir}
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README THANKS TODO
133 %attr(755,root,root) /%{_lib}/libgcrypt.so.*.*.*
134 %attr(755,root,root) %ghost /%{_lib}/libgcrypt.so.11
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/libgcrypt-config
139 %attr(755,root,root) %{_libdir}/libgcrypt.so
140 %{_libdir}/libgcrypt.la
141 %{_infodir}/gcrypt.info*
142 %{_includedir}/gcrypt*.h
143 %{_aclocaldir}/libgcrypt.m4
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgcrypt.a
149 %endif
This page took 0.10781 seconds and 4 git commands to generate.