]> git.pld-linux.org Git - packages/libgcrypt.git/blob - libgcrypt.spec
- gcc epoch
[packages/libgcrypt.git] / libgcrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Cryptographic library based on the code from GnuPG
6 Summary(es):    Libgcrypt es una biblioteca general de desarrole embasada em GnuPG
7 Summary(pl):    Biblioteka kryptograficzna oparta na kodzie GnuPG
8 Summary(pt_BR): libgcrypt é uma biblioteca de criptografia de uso geral baseada no GnuPG
9 Name:           libgcrypt
10 Version:        1.2.3
11 Release:        1
12 License:        LGPL
13 Group:          Libraries
14 # devel versions:
15 #Source0:       ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/%{name}-%{version}.tar.gz
16 Source0:        ftp://ftp.gnupg.org/gcrypt/libgcrypt/%{name}-%{version}.tar.bz2
17 # Source0-md5:  49810175ab672b19a02509d2a670b156
18 Patch0:         %{name}-no_libnsl.patch
19 Patch1:         %{name}-info.patch
20 Patch2:         %{name}-sparc64.patch
21 URL:            http://www.gnu.org/directory/security/libgcrypt.html
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9.3
24 BuildRequires:  binutils >= 2:2.12
25 BuildRequires:  gcc >= 5:3.2
26 BuildRequires:  libgpg-error-devel >= 0.5
27 BuildRequires:  libtool >= 1:1.4.3
28 BuildRequires:  texinfo
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This is a general purpose cryptographic library based on the code from
33 GnuPG. It provides functions for all cryptograhic building blocks:
34 symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash
35 algorithms (MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all
36 hash algorithms), public key algorithms (RSA, ElGamal, DSA), large
37 integer functions, random numbers and a lot of supporting functions.
38
39 %description -l pl
40 Ten pakiet zawiera bibliotekê kryptograficzn± ogólnego przeznaczenia,
41 opart± na kodzie GnuPG. Biblioteka ta dostarcza funkcje do wszystkich
42 podstawowych bloków kryptografii: szyfrów symetrycznych (AES, DES,
43 Blowfish, CAST5, Twofish, Acrfour), algorytmów mieszaj±cych (MD5,
44 RIPE-MD160, SHA-1, RIGER-192), MAC-ów (HMAC dla wszystkich algorytmów
45 mieszaj±cych), algorytmów klucza publicznego (RSA, ElGamal, DSA),
46 funkcji du¿ych liczb ca³kowitych, liczb losowych i wiele funkcji
47 pomocniczych.
48
49 %description -l pt_BR
50 Libgcrypt é uma biblioteca de criptografia de uso geral baseada no
51 GnuPG.
52
53 %package devel
54 Summary:        Header files etc to develop libgcrypt applications
55 Summary(es):    Archivos de desarrollo de libgcrypt
56 Summary(pl):    Pliki nag³ówkowe i inne do libgcrypt
57 Summary(pt_BR): Arquivos de desenvolvimento da libgcrypt
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       libgpg-error-devel >= 0.5
61
62 %description devel
63 Header files etc to develop libgcrypt applications.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i inne do libgcrypt.
67
68 %description devel -l pt_BR
69 Bibliotecas de desenvolvimento para libgcrypt.
70
71 %package static
72 Summary:        Static libgcrypt library
73 Summary(es):    Archivos de desarrollo de libgcrypt - estatico
74 Summary(pl):    Biblioteka statyczna libgcrypt
75 Summary(pt_BR): Arquivos de desenvolvimento da libgcrypt - biblioteca estática
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libgcrypt library.
81
82 %description static -l pl
83 Biblioteka statyczna libgcrypt.
84
85 %description static -l pt_BR
86 Bibliotecas de desenvolvimento para libgcrypt - estático.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         --enable-static \
101         %{!?with_static_libs:--disable-static}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         m4datadir=%{_aclocaldir}
111
112 install -d $RPM_BUILD_ROOT/%{_lib}
113 mv -f $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
114 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libgcrypt.so.*.*.*) \
115         $RPM_BUILD_ROOT%{_libdir}/libgcrypt.so
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %post devel
124 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
125
126 %postun devel
127 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS THANKS NEWS README ChangeLog
132 %attr(755,root,root) /%{_lib}/libgcrypt.so.*.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/libgcrypt-config
137 %attr(755,root,root) %{_libdir}/libgcrypt.so
138 %{_libdir}/libgcrypt.la
139 %{_infodir}/*.info*
140 %{_includedir}/*.h
141 %{_aclocaldir}/*.m4
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgcrypt.a
147 %endif
This page took 0.065772 seconds and 4 git commands to generate.