]> git.pld-linux.org Git - packages/libgcrypt.git/blob - libgcrypt.spec
- added am18 patch (libgcrypt.m4 quotation fix)
[packages/libgcrypt.git] / libgcrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  pth     # without pth-based version of library
4 #
5 # TODO: separate pth version? disable by default (if !needed at all)?
6 Summary:        Cryptographic library based on the code from GnuPG
7 Summary(es):    Libgcrypt es una biblioteca general de desarrole embasada em GnuPG
8 Summary(pl):    Biblioteka kryptograficzna oparta na kodzie GnuPG
9 Summary(pt_BR): libgcrypt é uma biblioteca de criptografia de uso geral baseada no GnuPG
10 Name:           libgcrypt
11 Version:        1.1.90
12 Release:        2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  c4407f320729a972626fbe6a7ccf2211
17 Patch0:         %{name}-no_libnsl.patch
18 Patch1:         %{name}-info.patch
19 Patch2:         %{name}-am18.patch
20 URL:            http://www.gnu.org/directory/security/libgcrypt.html
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake
23 BuildRequires:  binutils >= 2.12
24 BuildRequires:  gcc >= 3.2
25 BuildRequires:  libgpg-error-devel >= 0.5
26 BuildRequires:  libtool >= 1:1.4.3
27 %{?with_pth:BuildRequires:      pth-devel >= 1.2.0}
28 BuildRequires:  texinfo
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This is a general purpose cryptographic library based on the code from
33 GnuPG. It provides functions for all cryptograhic building blocks:
34 symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash
35 algorithms (MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all
36 hash algorithms), public key algorithms (RSA, ElGamal, DSA), large
37 integer functions, random numbers and a lot of supporting functions.
38
39 %description -l pl
40 Ten pakiet zawiera bibliotekê kryptograficzn± ogólnego przeznaczenia,
41 opart± na kodzie GnuPG. Biblioteka ta dostarcza funkcje do wszystkich
42 podstawowych bloków kryptografii: szyfrów symetrycznych (AES, DES,
43 Blowfish, CAST5, Twofish, Acrfour), algorytmów mieszaj±cych (MD5,
44 RIPE-MD160, SHA-1, RIGER-192), MAC-ów (HMAC dla wszystkich algorytmów
45 mieszaj±cych), algorytmów klucza publicznego (RSA, ElGamal, DSA),
46 funkcji du¿ych liczb ca³kowitych, liczb losowych i wiele funkcji
47 pomocniczych.
48
49 %description -l pt_BR
50 Libgcrypt é uma biblioteca de criptografia de uso geral baseada no
51 GnuPG.
52
53 %package devel
54 Summary:        Header files etc to develop libgcrypt applications
55 Summary(es):    Archivos de desarrollo de libgcrypt
56 Summary(pl):    Pliki nag³ówkowe i inne do libgcrypt
57 Summary(pt_BR): Arquivos de desenvolvimento da libgcrypt
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}
60 Requires:       libgpg-error-devel >= 0.1
61
62 %description devel
63 Header files etc to develop libgcrypt applications.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i inne do libgcrypt.
67
68 %description devel -l pt_BR
69 Bibliotecas de desenvolvimento para libgcrypt.
70
71 %package static
72 Summary:        Static libgcrypt library
73 Summary(es):    Archivos de desarrollo de libgcrypt - estatico
74 Summary(pl):    Biblioteka statyczna libgcrypt
75 Summary(pt_BR): Arquivos de desenvolvimento da libgcrypt - biblioteca estática
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}
78
79 %description static
80 Static libgcrypt library.
81
82 %description static -l pl
83 Biblioteka statyczna libgcrypt.
84
85 %description static -l pt_BR
86 Bibliotecas de desenvolvimento para libgcrypt - estático.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 # ugly hack for am 1.8 (it tries to parse AC_CONFIG_LINKS
98 # but here they are autogenerated at configure time
99 %{__perl} -pi -e 's/(AC_CONFIG_LINKS)/x$1/' configure.ac
100 %{__automake}
101 %{__perl} -pi -e 's/x(AC_CONFIG_LINKS)/$1/' configure.ac
102 %{__autoconf}
103 %configure \
104         --enable-static \
105         %{!?with_pth:--without-pth}
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         m4datadir=%{_aclocaldir}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %post devel
123 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
124
125 %postun devel
126 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS THANKS NEWS README ChangeLog
131 %attr(755,root,root) %{_libdir}/lib*.so.*.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/libgcrypt-config
136 %attr(755,root,root) %{_libdir}/lib*.so
137 %{_libdir}/lib*.la
138 %{_infodir}/*info*
139 %{_includedir}/*.h
140 %{_aclocaldir}/*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*.a
This page took 0.064779 seconds and 4 git commands to generate.