]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- minor build fixes.
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 Name:           kernel-misc-fuse
10 Summary:        Filesystem in Userspace
11 Summary(pl):    System plików w przestrzeni u¿ytkownika
12 Version:        1.1
13 %define         _rel    3
14 Release:        %{_rel}@%{_kernel_ver_str}
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
18 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
19 Patch0:         %{name}-configure.in.patch
20 URL:            http://sourceforge.net/projects/avf
21 %if %{with kernel} && %{with dist_kernel}
22 BuildRequires:  kernel-module-build
23 %endif
24 %{?with_dist_kernel:%requires_releq_kernel_up}
25 BuildRequires:  rpmbuild(macros) >= 1.153
26 Requires(post,postun):  /sbin/depmod
27 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FUSE (Filesystem in Userspace) is a simple interface for userspace
31 programs to export a virtual filesystem to the Linux kernel. FUSE also
32 aims to provide a secure method for non privileged users to create and
33 mount their own filesystem implementations.
34
35 %description -l pl
36 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
37 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
38 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
39 montowania w³asnych implementacji systemów plików przez zwyk³ych
40 (nieuprzywilejowanych) u¿ytkowników.
41
42 %package -n kernel-smp-misc-fuse
43 Summary:        Filesystem in Userspace
44 Summary(pl):    System plików w przestrzeni u¿ytkownika
45 Release:        %{_rel}@%{_kernel_ver_str}
46 License:        GPL v2
47 Group:          Applications/System
48 %{?with_dist_kernel:%requires_releq_kernel_up}
49 Requires(post,postun):  /sbin/depmod
50
51 %description -n kernel-smp-misc-fuse
52 FUSE (Filesystem in Userspace) is a simple interface for userspace
53 programs to export a virtual filesystem to the Linux kernel. FUSE also
54 aims to provide a secure method for non privileged users to create and
55 mount their own filesystem implementations.
56
57 %description -n kernel-smp-misc-fuse -l pl
58 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
59 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
60 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
61 montowania w³asnych implementacji systemów plików przez zwyk³ych
62 (nieuprzywilejowanych) u¿ytkowników.
63
64 %package -n libfuse
65 Summary:        Shared library for Filesytem in Userspace
66 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
67 Group:          Applications/System
68 Release:        %{_rel}
69
70 %description -n libfuse
71 Shared library for Filesytem in Userspace
72
73 %description -n libfuse -l pl
74 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
75
76 %package -n libfuse-devel
77 Summary:        Filesytem in Userspace - Development header fiels and libraries
78 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
79 Group:          Development/Libraries
80 Release:        %{_rel}
81 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
82
83 %description -n libfuse-devel
84 Libfuse library header files.
85
86 %description -n libfuse-devel -l pl
87 Libfuse biblioteki nag³ówkowe dla programistów.
88
89 %package -n libfuse-static
90 Summary:        Filesytem in Userspace - static libraries
91 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
92 Group:          Development/Libraries
93 Release:        %{_rel}
94 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
95
96 %description -n libfuse-static
97 Static libfuse libraries.
98
99 %description -n libfuse-static -l pl
100 Statyczne biblioteki libfuse
101
102 %package -n fusermount
103 Summary:        Filesytem in Userspace utilities
104 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
105 Group:          Applications/System
106 Release:        %{_rel}
107
108 %description -n fusermount
109 Filesytem in Userspace utilities. It provide a secure method for non
110 privileged users to create and mount their own filesystem implementations. 
111
112 %description -n fusermount -l pl
113 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
114 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %prep
120 %setup -q -n fuse-%{version}
121 %patch0 -p1
122
123 %build
124 %{__aclocal}
125 %{__autoconf}
126 %{__automake}
127 %configure \
128     --enable-lib \
129     --enable-util \
130     --with-kernel=%{_kernelsrcdir}
131
132 %if %{with kernel}
133 cd kernel
134 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
135     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
136         exit 1
137     fi
138     rm -rf include
139     install -d include/{linux,config}
140     ln -sf %{_kernelsrcdir}/config-$cfg .config
141     ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
142     ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
143     touch include/config/MARKER
144     %{__make} -C %{_kernelsrcdir} clean modules \
145         EXTRA_CFLAGS="-I../include -DFUSE_VERSION='1.1'" \
146         RCS_FIND_IGNORE="-name '*.ko' -o" \
147         M=$PWD O=$PWD \
148         %{?with_verbose:V=1}
149     mv fuse.ko fuse-$cfg.ko
150 done
151 cd -
152 %endif
153
154 cd lib
155 for f in fuse.c fuse_mt.c helper.c mount.c; do
156 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
157 done
158 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
159 cd -
160
161 %{?with_userspace:%{__make} -C util}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
167
168 %if %{with userspace}
169 cd util
170 install fusermount $RPM_BUILD_ROOT%{_bindir}/
171 cd -
172 %endif
173
174 %if %{with kernel}
175 cd kernel
176 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
177 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
178         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
179 %if %{with smp} && %{with dist_kernel}
180 install fuse-smp.ko \
181         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
182 %endif
183 cd -
184 %endif
185
186 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}
187 cd lib
188 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
189 cd -
190
191 %post
192 %depmod %{_kernel_ver}
193
194 %postun
195 %depmod %{_kernel_ver}
196
197 %post -n kernel-smp-misc-fuse
198 %depmod %{_kernel_ver}
199
200 %postun -n kernel-smp-misc-fuse
201 %depmod %{_kernel_ver}
202
203 %if %{with kernel}
204 %files
205 %defattr(644,root,root,755)
206 %doc README NEWS ChangeLog AUTHORS
207 %doc patch/
208 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
209
210 %if %{with smp} && %{with dist_kernel}
211 %files -n kernel-smp-misc-fuse
212 %defattr(644,root,root,755)
213 %doc README NEWS ChangeLog AUTHORS
214 %doc patch/
215 /lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko*
216 %endif
217 %endif
218
219 %if %{with userspace}
220 %files -n fusermount
221 %defattr(644,root,root,755)
222 # suid needed? NO!
223 %attr(755,root,root) %{_bindir}/fusermount
224 # do it ! failed
225 # %%attr(755,root,root) %{_sbindir}/mount.fuse
226 %endif
227
228 %files -n libfuse
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
231
232 %files -n libfuse-devel
233 %defattr(644,root,root,755)
234 %{_includedir}/fuse.h
235 %{_libdir}/libfuse.la
236 %attr(755,root,root) %{_libdir}/libfuse.so
237
238 %files -n libfuse-static
239 %defattr(644,root,root,755)
240 %{_libdir}/libfuse.a
This page took 0.074813 seconds and 4 git commands to generate.